Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 367015 - app-misc/dtach: scrollback buffer patch
Summary: app-misc/dtach: scrollback buffer patch
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-12 18:08 UTC by yannick
Modified: 2020-06-22 09:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Scrollback buffer patch for dtach-0.8 (scrollback-buffer-0.8.patch,3.10 KB, patch)
2011-05-12 18:09 UTC, yannick
Details | Diff
Patch for dtach-0.8.ebuild; ebuild applies the scrollback buffer patch if USE="scrollback" is set (dtach-0.8.ebuild.patch,779 bytes, patch)
2011-05-12 18:10 UTC, yannick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yannick 2011-05-12 18:08:18 UTC
There are a lot of reasons why a scrollback buffer comes in handy. I found a patch by github user bogner, implementing scrollback functionality in dtach:
https://github.com/bogner/dtach/commit/21ede5c752f1cadcb51d6809964e04387d012133

It seems to work without any trouble (tested on amd64). Note that the command line option "-r winch" for dtach is needed for it to work. The default scrollback buffer size of 8192 bytes seems to be reasonable.

I'll attach the needed scrollback buffer patch for dtach-0.8 and a patch for the ebuild dtach-0.8.ebuild.

Hope to see it included in the tree some day :)

Reproducible: Always
Comment 1 yannick 2011-05-12 18:09:26 UTC
Created attachment 272965 [details, diff]
Scrollback buffer patch for dtach-0.8
Comment 2 yannick 2011-05-12 18:10:55 UTC
Created attachment 272967 [details, diff]
Patch for dtach-0.8.ebuild; ebuild applies the scrollback buffer patch if USE="scrollback" is set
Comment 3 Patrice Clement gentoo-dev 2020-06-22 09:22:19 UTC
Please upstream this patch. Sorry but we don't want to support extra features. Thank you.