Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 366809 - www-apache/mod_perl-2.0.5 fails tests
Summary: www-apache/mod_perl-2.0.5 fails tests
Status: RESOLVED DUPLICATE of bug 362375
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christian Ruppert (idl0r)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-11 01:14 UTC by Kent Fredric (IRC: kent\n)
Modified: 2014-06-02 18:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build/test log with TEST_VERBOSE=1 (mod_perl-2.0.5.log,390.05 KB, text/x-log)
2011-05-11 01:14 UTC, Kent Fredric (IRC: kent\n)
Details
cave info www-apache/mod_perl (cave.info,22.37 KB, text/plain)
2011-05-11 01:21 UTC, Kent Fredric (IRC: kent\n)
Details
emerge --info (emerge.info,5.26 KB, text/plain)
2011-05-11 01:21 UTC, Kent Fredric (IRC: kent\n)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Fredric (IRC: kent\n) gentoo-dev 2011-05-11 01:14:46 UTC
Created attachment 272793 [details]
full build/test log with TEST_VERBOSE=1

Test Summary Report
-------------------
t/apache/read3.t                      (Wstat: 0 Tests: 0 Failed: 0)
  Parse errors: Bad plan.  You planned 1 tests but ran 0.
t/api/request_rec.t                   (Wstat: 0 Tests: 55 Failed: 2)
  Failed tests:  13, 38
t/filter/out_str_reverse.t            (Wstat: 0 Tests: 2 Failed: 1)
  Failed test:  2
t/api/err_headers_out.t               (Wstat: 0 Tests: 6 Failed: 3)
  Failed tests:  2-3, 5


t/api/request_rec.t ..................... 
1..55
# Running under perl version 5.014000 for linux
# Current time local: Wed May 11 07:24:04 2011
# Current time GMT:   Tue May 10 19:24:04 2011
# Using Test.pm version 1.25_02
# Using Apache/Test.pm version 1.36
<snip>
# testing : t->proto_num
# expected: 1000
# received: 1001
not ok 13
<snip>
# expected: GET /TestAPI__request_rec/my_path_info?my_args=3 HTTP/1.0
# received: GET /TestAPI__request_rec/my_path_info?my_args=3 HTTP/1.1
not ok 38
<snip>

t/filter/out_str_reverse.t .............. 
1..2
# Running under perl version 5.014000 for linux
# Current time local: Wed May 11 07:30:04 2011
# Current time GMT:   Tue May 10 19:30:04 2011
# Using Test.pm version 1.25_02
# Using Apache/Test.pm version 1.36
# testing : reverse filter
# expected: abcdefghijklmnopqrstuvwxyz
# 0123456789
# Reversed by mod_perl 2.0
# received: abcdefghijklmnopqrstuvwxyz
# 0123456789
# Reversed by mod_perl 2.0
ok 1
# testing : reverse filter
# expected: abcdefghijklmnopqrstuvwxyz
# 0123456789
# Reversed by mod_perl 2.0
# received: abcdefghijklmnopqrstuvwxyz
# 0123456789
not ok 2
<snip>
t/api/err_headers_out.t ................. 
1..6
# Running under perl version 5.014000 for linux
# Current time local: Wed May 11 07:30:43 2011
# Current time GMT:   Tue May 10 19:30:43 2011
# Using Test.pm version 1.25_02
# Using Apache/Test.pm version 1.36
# testing : OK
# expected: 200
# received: 200
ok 1
# testing : X-err_headers_out: made it
# expected: err_headers_out
# received: undef
not ok 2
# testing : X-headers_out: made it
# expected: headers_out
# received: undef
not ok 3
# Failed test 2 in t/api/err_headers_out.t at line 22
# Failed test 3 in t/api/err_headers_out.t at line 25
# testing : not found
# expected: 404
# received: 404
ok 4
# testing : X-err_headers_out: made it
# expected: err_headers_out
# received: undef
not ok 5
ok 6
Comment 1 Kent Fredric (IRC: kent\n) gentoo-dev 2011-05-11 01:21:14 UTC
Created attachment 272795 [details]
cave info www-apache/mod_perl
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2011-05-11 01:21:44 UTC
Created attachment 272797 [details]
emerge --info
Comment 3 Sergiy Borodych 2014-06-02 07:23:53 UTC
There is no such version (mod_perl-2.0.5) in portage anymore. Vote for close.
Comment 4 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2014-06-02 18:05:23 UTC
Merging with #362375

*** This bug has been marked as a duplicate of bug 362375 ***