Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 365749 - app-emulation/bochs-2.4.5 unable to build in amd64 emulation on x86 platforms
Summary: app-emulation/bochs-2.4.5 unable to build in amd64 emulation on x86 platforms
Status: RESOLVED DUPLICATE of bug 347715
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-02 19:51 UTC by Alex Buell
Modified: 2016-05-28 08:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Buell 2011-05-02 19:51:44 UTC
Apparently bochs will not compile in support for amd64 emulation on x86 platforms. The docs says it should be to emulate an amd64 processor on x86 through bochs runtime configuration options.
Comment 1 Jeroen Roovers gentoo-dev 2011-05-06 03:32:01 UTC
Do you have more information? Say, a build log or configure log? Where is your `emerge --info' output?
Comment 2 Alex Buell 2011-05-07 11:22:14 UTC
Here's the relevant information from the bochs documentation. 

1. x86 processors

-enable-cpu-level={3,4,5,6}elect which CPU level to emulate. Choices are 3,4,5,6 which mean to target 386, 486, Pentium, or Pentium Pro and later emulation. 

2. amd76 processors

--enable-x86-64	no	Add support for x86-64 instruction set, written by Peter Tattam and Stanislav Shwartsman.
Comment 3 Alex Buell 2011-05-07 11:29:06 UTC
Here's the relevant information from the bochs documentation. 

1. x86 processors

-enable-cpu-level={3,4,5,6} Select which CPU level to emulate. Choices are 3,4,5,6 which mean to target 386, 486, Pentium, or Pentium Pro and later emulation. Defaults to 6.

2. amd64 processors

--enable-x86-64	Adds support for x86-64 instruction set, written by Peter Tattam and Stanislav Shwartsman. 

The ebuild for 2.4.5 has this: 

  use x86 && \
        myconf="--enable-idle-hack --enable-fast-function-calls"

  use amd64 && \
        myconf="--enable-x86-64"

The first one is OK, but the second really isn't, as it requires one to have an amd64 box to run an amd64 *emulator*! Perhaps a new local use flag could be set for this. 

Also, the docs says we can select the processor required during build time, so perhaps again, local use flags could be recommended for this, i.e. 386, 486 etc.
Comment 4 Pacho Ramos gentoo-dev 2016-05-28 08:19:14 UTC

*** This bug has been marked as a duplicate of bug 347715 ***