Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 365713 - sys-cluster/maui-3.3.1 - mismatching spool dir in different files
Summary: sys-cluster/maui-3.3.1 - mismatching spool dir in different files
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Cluster Team
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks:
 
Reported: 2011-05-02 14:26 UTC by Zerony
Modified: 2020-11-22 14:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zerony 2011-05-02 14:26:48 UTC
in maui-3.3.1.ebuild, which specifies
--with-spooldir="${EPREFIX}"/var/spool/maui
however, in the init script, which has different spool directory name, /var/spool/maui.
start() {
    ebegin "Starting Maui Scheduler"
    start-stop-daemon  --start --quiet --pidfile /var/spool/maui/maui.pid \
    --exec /usr/sbin/maui
    eend ${?}
}
Those two spool directory names should be same. the init script tries to find maui.pid under /var/spool/maui, but it actually is in /usr/spool/maui.

Reproducible: Always

Steps to Reproduce:
rc-status will complain maui is crashed.
Obvious mismatching.
Actual Results:  
maui is running, but rc-status shows it is crashed, because it can not find the maui.pid, which is actually under /usr/spool/maui, instead of /var/spool/maui

Expected Results:  
maui.pid is under /usr/spool/maui, instead of /var/spool/maui.
I suggest using /var/spool/maui, because torque also uses /usr/spool/maui
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-05-06 03:38:32 UTC
How is this a Gentoo Prefix bug? /var/spool is passed to ./configure. the program doesn't honor it.. add prefix@g.o back if needed.
Comment 2 Zerony 2011-05-08 19:17:50 UTC
(In reply to comment #1)

I found I did not state the bug clearly because of copy and paste.

In 3.3.1 ebuild, the spool-dir is set to 
--with-spooldir="${EPREFIX}"/usr/spool/maui (in my first report, I accidentally copied the line from my modified ebuild. --with-spooldir="${EPREFIX}"/var/spool/maui is a correct approach) and the init script pbs_maui requires the spool-dir is /var/spool/maui/. The spool dir should be consistent.
Basically, it is just change usr to var and the problem will be fixed.
Comment 3 Larry the Git Cow gentoo-dev 2020-10-24 14:19:57 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a05c24f0122b62cae823c3123b545014eefd9189

commit a05c24f0122b62cae823c3123b545014eefd9189
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-10-24 14:19:47 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-10-24 14:19:47 +0000

    package.mask: Last rite sys-cluster/maui
    
    Bug: https://bugs.gentoo.org/365713
    Bug: https://bugs.gentoo.org/405277
    Bug: https://bugs.gentoo.org/405437
    Bug: https://bugs.gentoo.org/414793
    Bug: https://bugs.gentoo.org/415699
    Bug: https://bugs.gentoo.org/422799
    Bug: https://bugs.gentoo.org/479288
    Bug: https://bugs.gentoo.org/740928
    Signed-off-by: David Seifert <soap@gentoo.org>

 profiles/package.mask | 6 ++++++
 1 file changed, 6 insertions(+)
Comment 4 Larry the Git Cow gentoo-dev 2020-11-22 14:54:46 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=23c2fcae268d01a7bcb593febcd963875a822b7c

commit 23c2fcae268d01a7bcb593febcd963875a822b7c
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-11-22 14:54:12 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-11-22 14:54:12 +0000

    sys-cluster/maui: Remove last-rited package
    
    Closes: https://bugs.gentoo.org/365713
    Closes: https://bugs.gentoo.org/405277
    Closes: https://bugs.gentoo.org/405437
    Closes: https://bugs.gentoo.org/414793
    Closes: https://bugs.gentoo.org/415699
    Closes: https://bugs.gentoo.org/422799
    Closes: https://bugs.gentoo.org/479288
    Closes: https://bugs.gentoo.org/740928
    Signed-off-by: David Seifert <soap@gentoo.org>

 profiles/package.mask                            |  6 ---
 sys-cluster/maui/Manifest                        |  1 -
 sys-cluster/maui/files/maui-3.3.1-torque_4.patch | 14 ------
 sys-cluster/maui/files/maui.initd                | 23 ---------
 sys-cluster/maui/maui-3.3.1-r3.ebuild            | 61 ------------------------
 sys-cluster/maui/metadata.xml                    | 12 -----
 6 files changed, 117 deletions(-)