Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 365511 - media-tv/xbmc-11.0_p53_pre: ebuild for xbmc pvr branch by opdenkamp
Summary: media-tv/xbmc-11.0_p53_pre: ebuild for xbmc pvr branch by opdenkamp
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Xbox herd
URL: http://github.com/opdenkamp/xbmc
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-01 07:45 UTC by Leho Kraav (:macmaN @lkraav)
Modified: 2012-07-02 18:33 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xbmc-11.0_p30_pre.ebuild (xbmc-11.0_p30_pre.ebuild,5.04 KB, text/plain)
2011-05-01 07:45 UTC, Leho Kraav (:macmaN @lkraav)
Details
xbmc-11.0_p40_pre.ebuild (xbmc-11.0_p40_pre.ebuild,4.91 KB, text/plain)
2011-07-06 19:19 UTC, Leho Kraav (:macmaN @lkraav)
Details
xbmc-11.0_p44_pre.ebuild (xbmc-11.0_p44_pre.ebuild,5.00 KB, text/plain)
2011-08-12 07:27 UTC, Leho Kraav (:macmaN @lkraav)
Details
xbmc-11.0_p46_pre.ebuild (xbmc-11.0_p46_pre.ebuild,4.98 KB, text/plain)
2011-08-13 18:01 UTC, Leho Kraav (:macmaN @lkraav)
Details
xbmc-11.0_p48_pre.ebuild (xbmc-11.0_p48_pre.ebuild,5.16 KB, text/plain)
2011-10-13 21:31 UTC, Leho Kraav (:macmaN @lkraav)
Details
xbmc-11.0_p50_pre.ebuild (xbmc-11.0_p50_pre.ebuild,5.17 KB, text/plain)
2011-10-17 21:12 UTC, Leho Kraav (:macmaN @lkraav)
Details
update (xbmc-11.0_p70_pre.ebuild,5.75 KB, text/plain)
2012-03-26 09:51 UTC, Leho Kraav (:macmaN @lkraav)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leho Kraav (:macmaN @lkraav) 2011-05-01 07:45:07 UTC
couple of things to note:

 1. i wouldve initially liked to have media-tv/xbmc-pvr for example, but there seems to be no simple way to modify executable names and paths to /usr/*/xbmc-pvr and there is no real benefit for me to spend a lot of time figuring this out

 2. i would like to have a better branch distinction in ebuild version, but my understanding from Ebuild File Format is that xbmc-11.0_odk30_pre is against the rules

 3. opdenkamp tags his releases every couple of weeks with odkXX, tarball snapshots are at http://github.com/opdenkamp/xbmc/downloads. unfortunately github's automatic tarballing is a real nut.

    download url: http://github.com/opdenkamp/xbmc/tarball/pvr-ppa-odk30
       redirects: http://download.github.com/opdenkamp-xbmc-pvr-ppa-odk30-0-gf44db35.tar.gz

    wget will still save the file as pvr-ppa-odk30 and then ebuild will not recognize it's format. i don't know how to make ebuild fetch rename a downloaded asset. haven't been able to figure out a way to not hardcode these file names into every ebuild, since commit hashes are going to change. this means the ebuild will need to be updated for each release, which i will be doing until i figure the Right Way out or someone points me to it.

other than that, it compiles well and XBMC Live TV menu is a lot of new fun.

Reproducible: Always
Comment 1 Leho Kraav (:macmaN @lkraav) 2011-05-01 07:45:41 UTC
Created attachment 271723 [details]
xbmc-11.0_p30_pre.ebuild
Comment 2 Leho Kraav (:macmaN @lkraav) 2011-05-01 07:53:30 UTC
thread opened in xbmc pvr subforum too: http://forum.xbmc.org/showthread.php?p=786833
Comment 3 Leho Kraav (:macmaN @lkraav) 2011-05-01 07:54:55 UTC
noticed that for some reason i haven't merged in git repo migration from -9999 ebuild, will be doing that shortly.
Comment 4 BT 2011-05-04 07:24:23 UTC
I think a simpler approach might be to modify the existing xbmc-9999 ebuild to support alternative git repositories with the following.

EGIT_REPO_URI=${XBMC_EGIT_REPO_URI:-git://github.com/xbmc/xbmc.git}
EGIT_PROJECT=${XBMC_EGIT_PROJECT:-xbmc}

You can then set XBMC_EGIT_REPO_URI and XBMC_EGIT_PROJECT as environment variables and have xbmc-9999 track a different repository.

XBMC_EGIT_REPO_URI=git://github.com/opdenkamp/xbmc.git
XBMC_EGIT_PROJECT=xbmc-pvr

You will have a much better chance of convincing the xbmc package maintainer to make this change, than to maintain another ebuild.
Comment 5 SpanKY gentoo-dev 2011-05-09 20:14:53 UTC
read git.eclass ... it already supports per-package uri overrides transparently

i'm not adding ebuilds to the tree for random branches when people can do this on their own systems locally
Comment 6 Leho Kraav (:macmaN @lkraav) 2011-05-09 20:47:00 UTC
yeah i wasn't even aiming for the tree. i think b.g.o is the best tool there is just work with this for a bit and let interested people find out about the effort. is it OK to continue in this wontfix-corner until pvr is integrated in main branch?
Comment 7 SpanKY gentoo-dev 2011-05-10 15:53:36 UTC
feel free to post updates all you like.  the forums might be a better place to collaborate with people though.
Comment 8 Leho Kraav (:macmaN @lkraav) 2011-07-06 19:19:31 UTC
Created attachment 279259 [details]
xbmc-11.0_p40_pre.ebuild
Comment 9 Leho Kraav (:macmaN @lkraav) 2011-08-12 07:27:08 UTC
Created attachment 282985 [details]
xbmc-11.0_p44_pre.ebuild

bumped
Comment 10 Leho Kraav (:macmaN @lkraav) 2011-08-13 18:01:00 UTC
Created attachment 283219 [details]
xbmc-11.0_p46_pre.ebuild

this ebuild now is independent of github tag SHA marks in the directory name. i'm pretty sure this is a crude hack¹, so improvements welcome.

 ¹: inside src_unpack doing cd "${WORKDIR}; S="${WORKDIR}/$(ls)" to set S, since we don't what we're going to get from the tarball until we unpack it
Comment 11 Marc Perrudin 2011-08-26 15:26:17 UTC
The ebuild fails to build with the last ffmpeg.

The problem is present on all xbmc ebuild (https://bugs.gentoo.org/show_bug.cgi?id=378229)
Comment 12 Leho Kraav (:macmaN @lkraav) 2011-08-26 15:43:12 UTC
yes, you need to apply patch from http://trac.xbmc.org/ticket/11689 until further notice i guess. i'm sure this is fixed in to-be-odk48.
Comment 13 Marc Perrudin 2011-08-26 16:03:44 UTC
(In reply to comment #12)
> yes, you need to apply patch from http://trac.xbmc.org/ticket/11689 until
> further notice i guess. i'm sure this is fixed in to-be-odk48.

Thanks for the patch. I'll try it.

For now, it isn't in the last master git version. (version 9999 of the ebuild fail too)
Comment 14 Marc Perrudin 2011-08-28 10:40:11 UTC
Works like a charm. Thanks.
Comment 15 Leho Kraav (:macmaN @lkraav) 2011-10-13 21:31:24 UTC
Created attachment 289765 [details]
xbmc-11.0_p48_pre.ebuild

this is dated 09/01, will be merging gentoo's latest xbmc-9999.ebuild changes whenever odk50 gets released.
Comment 16 Leho Kraav (:macmaN @lkraav) 2011-10-17 21:12:36 UTC
Created attachment 290119 [details]
xbmc-11.0_p50_pre.ebuild

odk50 bump, updated from xbmc-9999.ebuild 1.84 to 1.93
Comment 17 Leho Kraav (:macmaN @lkraav) 2011-10-17 21:13:20 UTC
ffmpeg 0.7.x patch is no longer necessary here
Comment 18 Leho Kraav (:macmaN @lkraav) 2011-10-26 10:05:08 UTC
just rename the p50 ebuild to p53.
Comment 19 Marc Perrudin 2011-10-26 11:11:57 UTC
Hi,

Does it build with libpng 1.5. I can't build xbmc since this upgrade.

There is a patch for xbmc-10.1 but it doesn't works with recent versions of xbmc (with or without the pvr add-ons).

Regards.
Comment 20 Leho Kraav (:macmaN @lkraav) 2011-10-26 11:13:27 UTC
i am still on libpng-1.4, so i don't know yet.
Comment 21 Marc Perrudin 2011-11-11 16:46:01 UTC
There are patches available on trac.xbmc.org. They work with current git version so probably with odkXX too.

See http://trac.xbmc.org/ticket/12001 and http://forums.gentoo.org/viewtopic-t-900122.html for an easy way to use them.
Comment 22 Jeroen Dekien 2011-12-30 18:26:27 UTC
it doens't seem to work with png 1.5

it fails on:

/usr/include/libpng15/png.h:833:16: error: forward declaration of 'struct png_struct'
ximapng.h:73:18: error: invalid use of incomplete type 'struct png_struct'
Comment 23 Leho Kraav (:macmaN @lkraav) 2011-12-30 18:29:21 UTC
yep, from the xbmc ticket above i'm applying:

0002-xbmc-9999-headers.patch
0003-xbmc-9999-libpng-1.5.patch
0004-xbmc-9999-libpng-1.5-fix-plt-trn-get.patch

just epatch them in this order in the ebuild
Comment 24 Sok Ann Yap 2012-02-07 07:49:27 UTC
After the recent addition of mysql/pvr USE flags to the ebuilds in the tree, "transparent per-package uri overrides" as mentioned in Comment 5 doesn't work for the xbmc-pvr branch anymore.
Comment 25 Leho Kraav (:macmaN @lkraav) 2012-03-26 09:51:18 UTC
Created attachment 306695 [details]
update

here's a fresh ebuild