Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 365321 - eutils.eclass lacks eclass-to-man formatting for documentation of make_desktop_entry function
Summary: eutils.eclass lacks eclass-to-man formatting for documentation of make_deskto...
Status: RESOLVED DUPLICATE of bug 397451
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-29 16:05 UTC by Alex Belykh
Modified: 2013-10-18 17:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed documentation fix for eutils.eclass (eutils.patch,1.57 KB, patch)
2011-04-29 16:12 UTC, Alex Belykh
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Belykh 2011-04-29 16:05:46 UTC
The make_desktop_entry helper function from eutils eclass is mentioned in Gentoo Ebuild How-to (http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1#doc_chap2) and is used in many ebuilds. eutils.eclass file also contains some sort of informal description for the function. However, it lacks proper eclass-to-man-style formatting, which prevents it from being displayed on eutils.eclass manpage. Incidentally, it's the only intended-for-public-use function from that file, that lacks such formatting.


Reproducible: Always

Steps to Reproduce:
1. emerge app-portage/eclass-manpages, if necessary (that will generate man documentation from /usr/portage/eclass/*.eclass files)
2. open "man eutils.eclass"

Actual Results:  
Man page for eutils.eclass is properly opened, but description of make_desktop_entry function is nowhere to be seen.

Expected Results:  
Man page for eutils.eclass should exist and contain description of make_desktop_entry function.
Comment 1 Alex Belykh 2011-04-29 16:12:36 UTC
Created attachment 271567 [details, diff]
Proposed documentation fix for eutils.eclass

I've taken description of make_desktop_entry from Gentoo Ebuild How-to (except for differing description of the 5th argument, which is out-of-date there), and added proper eclass-to-man formatting.
Comment 2 Tony Vroon gentoo-dev 2013-10-18 17:24:37 UTC
Alex, I am sorry to see that your bug report was ignored. A developer noticed the same problem you did but filed a duplicate report. This did thankfully get actioned, so the incorrect text is no longer in the portage tree.
The fixing commit was:
  03 Jan 2012; Justin Lecher <jlec@gentoo.org> eutils.eclass:
  Convert make_desktop_entry() comment block to be eclass-manpages conform,
  #397451

So whilst your report was first, I shall mark it as a duplicate so our records are correct.

*** This bug has been marked as a duplicate of bug 397451 ***