Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 363835 - app-office/libreoffice-bin-3.3.2 - SIGABRT on startup
Summary: app-office/libreoffice-bin-3.3.2 - SIGABRT on startup
Status: RESOLVED DUPLICATE of bug 361695
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-16 15:09 UTC by Martin Doucha
Modified: 2011-08-21 23:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.txt,4.67 KB, text/plain)
2011-04-16 15:09 UTC, Martin Doucha
Details
soffice.bin backtrace after the crash (lo-bin.bt,3.53 KB, text/plain)
2011-04-16 15:10 UTC, Martin Doucha
Details
soffice.bin strace output from start up to the crash (lo-bin.trace,688.69 KB, text/plain)
2011-04-16 15:11 UTC, Martin Doucha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Doucha 2011-04-16 15:09:24 UTC
Libreoffice-bin crashes on startup when it tries to load extensions. When I remove the extension it crashed on manually, it simply crashes on the next one in line. The machine is rather old and non-binary package of LibreOffice would take days to compile.

Reproducible: Always
Comment 1 Martin Doucha 2011-04-16 15:09:56 UTC
Created attachment 270197 [details]
emerge --info
Comment 2 Martin Doucha 2011-04-16 15:10:40 UTC
Created attachment 270199 [details]
soffice.bin backtrace after the crash
Comment 3 Martin Doucha 2011-04-16 15:11:40 UTC
Created attachment 270201 [details]
soffice.bin strace output from start up to the crash
Comment 4 Andreas Proschofsky (RETIRED) gentoo-dev 2011-07-06 22:21:23 UTC
Do you still get this with 3.4.1? I never could reproduce it...
Comment 5 Peter Savichev (proton) 2011-07-09 06:42:30 UTC
(In reply to comment #4)
> Do you still get this with 3.4.1? I never could reproduce it...

Yes, tested on my netbook samsung n230.
Comment 6 Andreas Proschofsky (RETIRED) gentoo-dev 2011-07-14 21:23:49 UTC
How much memory do you have on this machine?
Comment 7 Peter Savichev (proton) 2011-07-15 09:01:38 UTC
(In reply to comment #6)
> How much memory do you have on this machine?

1Gb
Comment 8 Tomáš Chvátal (RETIRED) gentoo-dev 2011-07-27 12:11:06 UTC
This aint easy to fix. Duping this against the rework as with rpms there is
nothing we can do to fix it.

*** This bug has been marked as a duplicate of bug 361695 ***
Comment 9 Peter Savichev (proton) 2011-08-21 23:14:48 UTC
fixed for me in 3.4.2