Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363523 - www-plugins/google-talkplugin-1.8.0.0: can't find libstdc++.so.6
Summary: www-plugins/google-talkplugin-1.8.0.0: can't find libstdc++.so.6
Status: RESOLVED DUPLICATE of bug 377633
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 361683
  Show dependency tree
 
Reported: 2011-04-14 00:52 UTC by Aron
Modified: 2011-08-15 09:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
output requested in comment #5 (output.txt,79.32 KB, text/plain)
2011-05-28 21:42 UTC, Aron
Details
gcc build log (build.log.gz,244.32 KB, application/x-gzip)
2011-06-06 11:43 UTC, Aron
Details
gcc build log (build.log.gz,244.32 KB, application/octet-stream)
2011-06-06 11:50 UTC, Aron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron 2011-04-14 00:52:12 UTC
The google-talkplugin is linked against the 32-bit verison of libstdc++.so.6, but that path is not included in ld.so.conf by default.

Reproducible: Always

Steps to Reproduce:
1. emerge www-plugins/google-talkplugin
2. cd /opt/google/talkplugin
3. ./GoogleTalkPlugin
Actual Results:  
./GoogleTalkPlugin: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Expected Results:  
application should run

Appending the directory with the 32-bit version of libstdc++.so.6 to the end of LDPATH fixes the issue.  I'm not sure if this is the proper solution, but it seems better than symlinking the library into /usr/lib32.

echo 'LDPATH="/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/32"' > /etc/env.d/99google-tlakplugin
env-update
Comment 1 Christoph Junghans gentoo-dev 2011-04-14 14:31:38 UTC
Does the plugin work inside the browser?
Comment 2 Alexey Shvetsov gentoo-dev 2011-04-15 12:56:07 UTC
show me emerge --info please
Comment 3 Aron 2011-04-24 21:13:51 UTC
Sorry for the delay.  I had my email notifications turned off for this Bugzilla (it's been a while!).

The plugin does not work inside the browser either without appending the 32-bit library's path.  Running the plugin directly was merely to provide a test method that is easier than using a web browser.

It looks like the same issue is affecting Skype (https://forums.gentoo.org/viewtopic-p-6663689.html).  I didn't install and run Skype until after I put this fix into place, so I'm sure I would have hit that one too.

Portage 2.1.9.46 (default/linux/amd64/10.0/desktop, gcc-4.5.2, libc-0-r0, 2.6.38.2-zen x86_64)
=================================================================
System uname: Linux-2.6.38.2-zen-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9600_@_2.80GHz-with-gentoo-2.0.2
Timestamp of tree: Sun, 24 Apr 2011 17:00:01 +0000
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.4_p6-r1, 1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
sys-kernel/linux-headers: 2.6.38
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL AdobeFlash-10.1 google-talkplugin skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=2 --load-average=5 --keep-going"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://mirror.qubenet.net/mirror/gentoo/ ftp://mirror.datapipe.net/gentoo ftp://gentoo.mirrors.pair.com/ http://distfiles.gentoo.org"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /usr/local/portage/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 auto-hinter avahi bash-completion berkdb bluetooth bzip2 cairo cdr cli consolekit cracklib crypt css cups cxx dbus dri dts dvd dvdr emboss encode exif faac fam firefox flac fontconfig fuse gconf gdbm gdu gif gnome gnome-keyring gphoto2 gpm gtk gtkstyle iconv inotify ios ipod irc jabber jpeg latex lcms libnotify lvm mad matroska mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd pulseaudio python readline samba sdl session spell sse sse2 sse3 ssl ssse3 startup-notification svg sysfs threads tiff truetype udev unicode usb vim-syntax vorbis x264 xcb xml xorg xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="crypt lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Christoph Junghans gentoo-dev 2011-04-26 07:52:04 UTC
This looks somehow like a missing path for ldconfig.

@toolchain: What do you think about this?
Comment 5 SpanKY gentoo-dev 2011-05-28 17:50:58 UTC
post the output of:
$ gcc-config -l
$ qlist -e sys-devel/gcc
$ ldd /opt/google/talkplugin/GoogleTalkPlugin
$ cat /etc/ld.so.conf /etc/ld.so.conf.d/05gcc-x86_64-pc-linux-gnu.conf
Comment 6 Aron 2011-05-28 21:42:01 UTC
Created attachment 274949 [details]
output requested in comment #5
Comment 7 SpanKY gentoo-dev 2011-05-31 04:27:35 UTC
you've got the file:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/32/libstdc++.so.6

but that path isnt in your ld.so.conf for some reason

post the output of:
cat /etc/env.d/gcc/x86_64-pc-linux-gnu-4.5.2

if that contains LDPATH with the /32 dir in it, then run:
gcc-config -O -f

and see if it now shows up in your /etc/ld.so.conf
Comment 8 Aron 2011-05-31 12:24:10 UTC
Nope, the 32-bit path is not in there.

aron@localhost ~ $ cat /etc/env.d/gcc/x86_64-pc-linux-gnu-4.5.2
LDPATH="/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2"
MANPATH="/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.2/man"
INFOPATH="/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.2/info"
STDCXX_INCDIR="g++-v4"
GCC_PATH="/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.2"
Comment 9 SpanKY gentoo-dev 2011-06-06 00:52:32 UTC
post the full build log of `emerge sys-devel/gcc` as an attachment
Comment 10 Aron 2011-06-06 11:43:48 UTC
Created attachment 275983 [details]
gcc build log
Comment 11 Aron 2011-06-06 11:47:39 UTC
Remerging sys-devel/gcc has added the */32 directory to LDPATH.  

MANPATH="/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.2/man"
INFOPATH="/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.2/info"
LDPATH="/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2:/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/32"
PATH="/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.2"
ROOTPATH="/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.2"
GCC_SPECS=""

4.5.2 was originally pulled in on April 13, which was an upgrade from 4.4.5.
Comment 12 Aron 2011-06-06 11:50:00 UTC
Created attachment 275987 [details]
gcc build log
Comment 13 Alexey Shvetsov gentoo-dev 2011-08-15 09:28:35 UTC
Acualy its duplicate of #377633

*** This bug has been marked as a duplicate of bug 377633 ***