Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363311 - stabilize net-voip/linphone-3.4.3-r1 and dependencies
Summary: stabilize net-voip/linphone-3.4.3-r1 and dependencies
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: voip herd (OBSOLETE)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 384733
  Show dependency tree
 
Reported: 2011-04-12 15:29 UTC by Peter Volkov (RETIRED)
Modified: 2012-01-06 15:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
linpone ebuild (linphone.txt,23.73 KB, text/plain)
2011-05-01 01:17 UTC, blain 'Doc' Anderson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Volkov (RETIRED) gentoo-dev 2011-04-12 15:29:11 UTC
Arch teams, please, stabilize media-plugins/mediastreamer-x264-1.4.1. Currently stable version does not build with the error:

 * QA Notice: Package has poor programming practices which may compile
 *            but will almost certainly crash on 64bit architectures.
 * 
 * Function `yuv_buf_alloc' implicitly converted to pointer at msx264.c:386

Thank you in advance.
Comment 1 Agostino Sarubbo gentoo-dev 2011-04-12 15:38:38 UTC
requires >=media-libs/mediastreamer-2.7.0, please check and change the summary :)
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2011-04-12 16:14:22 UTC
Heh, and that will require ortp and that will be most of linphone libraries that is good to stabilize together with linphone... Well having mediastreamer-x264 on one side and linphone users on the other let's give one week delay after bump for linophone bugs to pop up and then we'll stabilize everything in one go.
Comment 3 Peter Volkov (RETIRED) gentoo-dev 2011-04-30 19:55:52 UTC
Ok, let's start linphone stabilization. Arch teams, please, stabilize following:

net-libs/libosip-3.5.0: amd64 ppc x86
net-libs/libeXosip-3.5.0: amd64 ppc x86
net-libs/ortp-0.16.5: alpha amd64 ia64 ppc sparc x86
media-libs/mediastreamer-2.7.3-r3:  amd64 ppc x86
net-voip/linphone-3.4.3: amd64 ppc x86

media-plugins/mediastreamer-amr-0.0.1: amd64 x86
media-plugins/mediastreamer-ilbc-2.0.3: amd64 ppc x86
media-plugins/mediastreamer-x264-1.4.1: amd64 ppc x86
Comment 4 blain 'Doc' Anderson 2011-05-01 01:17:00 UTC
Created attachment 271693 [details]
linpone ebuild
Comment 5 blain 'Doc' Anderson 2011-05-01 01:18:32 UTC
amd64 fail build on net-voip/linphone-3.4.3 only

all dependencies built fine except for linphone itself, here is the build log. 
maybe someone can find my mistake
Comment 6 Peter Volkov (RETIRED) gentoo-dev 2011-05-01 05:16:38 UTC
blain, please attach full build.log for mediastreamer. It somehow detects that you have linux/videodev.h while it should not do that since that check is remove from configure.ac with sed -i -e 's:linux/videodev.h ::' configure.ac.
Comment 7 blain 'Doc' Anderson 2011-05-01 14:27:04 UTC
amd64 recompiled on my kde box and it compiles fine. i think the issue is with the VM rather than the actual build system. will try and dig out the build log for mediastreamer anyway though. will post later
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2011-05-01 18:09:23 UTC
amd64 done. Thanks Blain
Comment 9 David Abbott gentoo-dev 2011-05-11 17:26:11 UTC
Tested on x86, registered and placed call worked good :)
Comment 10 Thomas Kahle (RETIRED) gentoo-dev 2011-05-14 09:32:02 UTC
x86 stable. Thanks David
Comment 11 Raúl Porcel (RETIRED) gentoo-dev 2011-05-21 17:47:29 UTC
alpha/ia64/sparc stable
Comment 12 Samuli Suominen gentoo-dev 2011-10-02 08:50:44 UTC
This one is now blocking bug 384733 because mediastreamer, required from this bug, has fixes for newer linux-headers
Comment 13 Peter Volkov (RETIRED) gentoo-dev 2011-10-02 10:43:39 UTC
And while this bug is opened I'll put back amd64 and x86 to stabilize:

net-voip/linphone-3.4.3-r1: amd64 ppc x86

TIA.
Comment 14 Agostino Sarubbo gentoo-dev 2011-10-02 14:11:00 UTC
amd64 ok
Comment 15 Ian Delaney (RETIRED) gentoo-dev 2011-10-04 17:34:44 UTC
amd64:

minor QA flaw, not a blocker
amd64 all ok
Comment 16 Tomáš "tpruzina" Pružina (amd64 [ex]AT) 2011-10-04 19:01:29 UTC
(In reply to comment #16)
> Arch teams, please, stabilize media-plugins/mediastreamer-x264-1.4.1. Currently
> stable version does not build with the error:
> 
>  * QA Notice: Package has poor programming practices which may compile
>  *            but will almost certainly crash on 64bit architectures.
>  * 
>  * Function `yuv_buf_alloc' implicitly converted to pointer at msx264.c:386
> 
> Thank you in advance.

amd64 : ok, 
I could not reproduce QA (msx264.c has 340 lines only). Interestingly, there are no signs of patches or different package for amd64.
Comment 17 Tomáš "tpruzina" Pružina (amd64 [ex]AT) 2011-10-04 19:07:02 UTC
> amd64 : ok, 
> I could not reproduce QA (msx264.c has 340 lines only). Interestingly, there
> are no signs of patches or different package for amd64.

Sorry for pollution, I haven't noticed it got stable in mean time. Mea culpa, again.
Comment 18 Tony Vroon gentoo-dev 2011-10-12 09:48:06 UTC
+  12 Oct 2011; Tony Vroon <chainsaw@gentoo.org> linphone-3.4.3-r1.ebuild:
+  Marked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo, Ian
+  "idella4" Delaney & Tomáš "Mepho" Pružina in bug #363311.
Comment 19 Markus Meier gentoo-dev 2011-10-23 11:36:41 UTC
x86 stable
Comment 20 Brent Baude (RETIRED) gentoo-dev 2012-01-06 15:04:28 UTC
ppc done; closing as last arch