Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 362741 - dev-util/kdevplatform-1.0.2/1.1.2 should block >=kde-base/kdelibs-4.5.64
Summary: dev-util/kdevplatform-1.0.2/1.1.2 should block >=kde-base/kdelibs-4.5.64
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2011-04-09 17:14 UTC by Steffen Schaumburg
Modified: 2011-04-11 11:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Schaumburg 2011-04-09 17:14:59 UTC
Emerge output:
CMake Error at CMakeLists.txt:15 (message):
  KDevelop doesn't work (yet) with kdelibs 4.5.64 or later, please use the
  movingranges branch

The issue does not apply to kdevplatform-1.20.
Since kdevplatform is a dep of kdevelop I do not think its necessary to add the block in there, but if I'm wrong it applies to versions 4.0.2 and 4.1.2

Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2011-04-11 11:31:23 UTC
Due to approach we do this thing it is overly crazy to do both way blockers like
>=1.0 while also requiring <2.0. I removed 4.5 requiring kdevelop and added latest 4.6 one so please rather migrate to that one.