Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 362613 - [gnome-overlay] make bluetooth a conditional useflag
Summary: [gnome-overlay] make bluetooth a conditional useflag
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome3.2
  Show dependency tree
 
Reported: 2011-04-08 15:04 UTC by Helmut Eberharter
Modified: 2012-09-10 19:58 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
diff making bluetooth useflag conditional (gnome-3.0.0-fix-blueoth-flag.diff,726 bytes, patch)
2011-04-08 15:06 UTC, Helmut Eberharter
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Eberharter 2011-04-08 15:04:55 UTC
gnome-stack build fine without the bluetooth flag.

Reproducible: Always
Comment 1 Helmut Eberharter 2011-04-08 15:06:19 UTC
Created attachment 269027 [details, diff]
diff making bluetooth useflag conditional
Comment 2 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-04-08 15:36:23 UTC
This will only be enabled if gnome-shell's bluetooth functionality can be made optional. Which it currently can't be, since it fails to start up without that.

https://bugzilla.gnome.org/show_bug.cgi?id=637935
Comment 3 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-04-12 13:17:20 UTC
This is not fixed yet.
Comment 4 Martin von Gagern 2011-11-25 22:52:30 UTC
Is this bug here the reason why gnome-base/gnome-3.2.1 in the main portage tree has an unconditional dependency on gnome-base/gnome-core-apps-3.2.1[bluetooth]?
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-26 02:06:56 UTC
(In reply to comment #4)
> Is this bug here the reason why gnome-base/gnome-3.2.1 in the main portage tree
> has an unconditional dependency on gnome-base/gnome-core-apps-3.2.1[bluetooth]?

Yes.
Comment 6 Rémi Cardona gentoo-dev 2012-09-10 05:38:56 UTC
The upstream bug has been closed, though it looks like it's about a slightly different issue.

Is anyone working on this? Is there interest in doing this? I'd be willing to look into it.

Cheers
Comment 7 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-10 06:23:53 UTC
This can be fixed now that we've properly made bluetooth optional in gnome-shell. Rémi, thanks for the reminder!

>  10 Sep 2012; Alexandre Rostovtsev <tetromino@gentoo.org> gnome-3.2.1.ebuild,
>  gnome-3.4.1.ebuild:
>  Make bluetooth optional, bug #362613.
Comment 8 Rémi Cardona gentoo-dev 2012-09-10 19:58:22 UTC
Outstanding! Thanks!