Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 361835 - Missing build dependency on dev-perl/XML-Parser
Summary: Missing build dependency on dev-perl/XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Thomas Anderson (tanderson) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-03 20:05 UTC by Jens Seidel
Modified: 2013-12-19 15:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,9.68 KB, text/plain)
2011-04-03 20:10 UTC, Jens Seidel
Details
emerge --info =gnome-base/gnome-mime-data-2.18.0 (emerge.log1,4.23 KB, text/plain)
2011-04-03 20:12 UTC, Jens Seidel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Seidel 2011-04-03 20:05:07 UTC
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/gnome-base/gnome-mime-data-2.18.0/work/gnome-mime-data-2.18.0/config.log
 * ERROR: gnome-base/gnome-mime-data-2.18.0 failed (compile phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3037:  Called gnome2_src_compile
 *   environment, line 2345:  Called gnome2_src_configure
 *   environment, line 2359:  Called econf
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
Comment 1 Jens Seidel 2011-04-03 20:10:50 UTC
Created attachment 268401 [details]
config.log
Comment 2 Jens Seidel 2011-04-03 20:12:11 UTC
Created attachment 268405 [details]
emerge --info =gnome-base/gnome-mime-data-2.18.0
Comment 3 Jens Seidel 2011-04-03 20:15:46 UTC
# emerge -pqv =gnome-base/gnome-mime-data-2.18.0 
[ebuild   R   ] gnome-base/gnome-mime-data-2.18.0  USE="-debug*"
Comment 4 Rafał Mużyło 2011-04-03 20:51:44 UTC
Usually such error suggests you need to use 'perl-cleaner' after perl upgrade, but last perl upgrade was quite awhile ago.

Is dev-perl/XML-Parser emerged ?
Comment 5 Jens Seidel 2011-04-05 00:05:25 UTC
Sorry for the delay. I tried to install plog to answer your question but failed
(installed first paludis which required hours until I noticed it doesn't contain
plog so that I installed paludis-tools manually which fails on "import paludis"
in Python code). Grml, Debian is so much easier ...

(In reply to comment #4)
> Usually such error suggests you need to use 'perl-cleaner' after perl upgrade,
> but last perl upgrade was quite awhile ago.

I called perl-cleaner in the past after major pearl update.
 
> Is dev-perl/XML-Parser emerged ?

It was not (as /var/log/emerge.log reveals instead of plog). After installing
it (which I did already yesterday before my system update) gnome-mime-data could be build.

Please note that I have
LINGUAS="de en"
in /etc/make.conf which probably enables i18n support.
Comment 6 Gilles Dartiguelongue gentoo-dev 2011-04-05 10:14:36 UTC
gnome-mime-data depends on intltool which runtime depends on dev-perl/XML-Parser. There is no reason it would be absent from your system under normal circumstances. From a pure dependency POV, if I didn't overlook something, this report is invalid. Maybe it's a bug in paludis ?
Forwarding to paludis maintainer.
Comment 7 Jeroen Roovers gentoo-dev 2013-12-19 15:27:37 UTC

*** This bug has been marked as a duplicate of bug 41124 ***