Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 36158 - [science overlay] dev-python/pysparse-1.1.ebuild (New Package)
Summary: [science overlay] dev-python/pysparse-1.1.ebuild (New Package)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard: Science overlay
Keywords: EBUILD, InOverlay
: 84594 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-12-19 23:40 UTC by Nathaniel C. Domingo
Modified: 2019-12-19 15:19 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
pysparse-0.32.028.ebuild (New Package) (pysparse-0.32.028.ebuild,804 bytes, text/plain)
2003-12-19 23:42 UTC, Nathaniel C. Domingo
Details
patch used by pysparse-0.32.028.ebuild (pysparse-0.32.028.patch,339 bytes, text/plain)
2003-12-19 23:44 UTC, Nathaniel C. Domingo
Details
pysparse-0.33.029.ebuild script (pysparse-0.33.029.ebuild,707 bytes, text/plain)
2004-10-04 22:17 UTC, Nathaniel C. Domingo
Details
patch used by pysparse-0.33.029.ebuild (pysparse-0.33.029.patch,800 bytes, patch)
2004-10-04 22:20 UTC, Nathaniel C. Domingo
Details | Diff
pysparse-0.33.029.ebuild (pysparse-0.33.029.ebuild,698 bytes, text/plain)
2004-11-02 00:39 UTC, David Grant
Details
pysparse-1.1-r1.ebuild (pysparse-1.1-r1.ebuild,570 bytes, text/plain)
2010-05-11 15:38 UTC, Joel Berendzen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nathaniel C. Domingo 2003-12-19 23:40:25 UTC
this ebuild instals the pysparse modules which adds sparse matrix
extentions to python
Comment 1 Nathaniel C. Domingo 2003-12-19 23:42:47 UTC
Created attachment 22457 [details]
pysparse-0.32.028.ebuild (New Package)
Comment 2 Nathaniel C. Domingo 2003-12-19 23:44:02 UTC
Created attachment 22458 [details]
patch used by pysparse-0.32.028.ebuild
Comment 3 Lukasz Strzygowski (RETIRED) gentoo-dev 2004-04-04 01:27:12 UTC
I think you don't have to redefine src_install function, as distutils_src_install will be called automatically. And use epatch instead of patch.
Comment 4 Nathaniel C. Domingo 2004-10-04 22:17:10 UTC
Created attachment 41121 [details]
pysparse-0.33.029.ebuild script
Comment 5 Nathaniel C. Domingo 2004-10-04 22:20:13 UTC
Created attachment 41122 [details, diff]
patch used by pysparse-0.33.029.ebuild
Comment 6 Nathaniel C. Domingo 2004-10-04 22:23:06 UTC
just uploaded an update to pysparse in case it be included into the portage tree
Comment 7 David Grant 2004-11-02 00:24:37 UTC
Thanks Nathaniel, I happen to need this package right now.  If it works for me to the extent that it worked for me in Windows, I will recommend it be added to portage.
Comment 8 David Grant 2004-11-02 00:38:22 UTC
I made some changes

15c15
< KEYWORDS="x86 ~ppc ~sparc ~alpha"
---
> KEYWORDS="~x86 ~ppc ~sparc ~alpha"
20,21c20,21
<         >=virtual/blas
<         >=virtual/lapack
---
>         virtual/blas
>         virtual/lapack
25,29c25,27
< 
<       unpack ${P}.tar.gz
<       cd ${S}
<       patch < ${FILESDIR}/pysparse-0.33.029.patch
< 
---
>       unpack ${A}
>       cd ${S} || die
>       epatch ${FILESDIR}/pysparse-0.33.029.patch
31,33d28
< 
< 
< 
Comment 9 David Grant 2004-11-02 00:39:13 UTC
Created attachment 43149 [details]
pysparse-0.33.029.ebuild

New pysparse-0.33.029.ebuild

Please obsolete old one
Comment 10 David Grant 2004-11-02 00:39:51 UTC
Add EBUILD and Inclusion keywords
Comment 11 David Grant 2004-11-16 12:42:55 UTC
Please transfer this bug to sci or to me.
Comment 12 David Grant 2004-11-22 10:21:56 UTC
Python group, please transfer this to the sci group.  Thanks.
Comment 13 Peter Bienstman (RETIRED) gentoo-dev 2005-09-10 06:09:48 UTC
*** Bug 84594 has been marked as a duplicate of this bug. ***
Comment 14 David Grant 2006-09-23 19:28:03 UTC
if someone assigns this to maintainer-wanted I can submit it to sunrise with the newest release pysparse-0.34.032
Comment 15 David Grant 2006-09-23 22:38:53 UTC
Can someone with permissions please mark all attachments as obsolete?

It's in sunrise now.
Comment 16 Markos Chandras (RETIRED) gentoo-dev 2010-04-30 11:35:55 UTC
Masked for removal since numeric dependency is masked


# Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> (25 Apr 2010)
# Replaced by dev-python/numpy. Masked for deletion in 30 days (bug #181653).
dev-python/numeric
Comment 17 Joel Berendzen 2010-05-11 15:38:32 UTC
Created attachment 231111 [details]
pysparse-1.1-r1.ebuild

removes the numeric dependency, works fine with numpy
Comment 18 Sébastien Fabbro (RETIRED) gentoo-dev 2010-05-11 17:59:25 UTC
Rewrote entirely 1.1 in science overlay. Waiting for more love on superlu for inclusion into portage.
Comment 19 Thomas Sachau gentoo-dev 2010-05-12 17:11:36 UTC
<bicatali> Tommy[D]: i will probably put it in the main tree at some point. i dont have access to sunrise, and the one in the science overlay is quite different, but users are welcome to copy over the pysparse+superlu from the science overlay and maitain it there

So if any user wants to keep a working, not masked version in sunrise, feel free to update the ebuild in sunrise, so it wont get dropped.
Comment 20 Marek Szuba gentoo-dev 2019-08-19 11:42:14 UTC
Upstream has never released a stable version and even the latest pre-release dates back to November 2013. Last but not least, I am quite sure this module does not support Python3 (for one thing print is called as a keyword rather than as a function) and we are only 4.5 months away from Python2 reaching end of life. Just in case though, is there still any interest in adding this to the tree? If not, we shall close this ticket in 30 days.