Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 359879 - net-libs/libproxy fails to compile against xulrunner-2
Summary: net-libs/libproxy fails to compile against xulrunner-2
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
: 359885 360419 360811 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-22 07:40 UTC by Justin Lecher (RETIRED)
Modified: 2012-01-04 06:11 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/log/portage/build/gnome-base/gvfs-1.6.7:20110322-073216.log (gvfs-1.6.7:20110322-073216.log,213.26 KB, text/plain)
2011-03-22 07:40 UTC, Justin Lecher (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher (RETIRED) gentoo-dev 2011-03-22 07:40:27 UTC
/bin/sh ../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -O2 -pipe -march=core2 -mcx16 -msahf -mpopcnt -msse4.2 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wimplicit-function-declaration  -Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -o gvfsd-http gvfsd_http-soup-input-stream.o gvfsd_http-soup-output-stream.o gvfsd_http-gvfsbackendhttp.o gvfsd_http-daemon-main.o gvfsd_http-daemon-main-generic.o libdaemon.la ../common/libgvfscommon.la -pthread -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0   -ldbus-1 -lpthread -lrt   -lgnome-keyring -lglib-2.0   -pthread -lsoup-gnome-2.4 -lsoup-2.4 -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lxml2   -lutil 
libtool: link: x86_64-pc-linux-gnu-gcc -O2 -pipe -march=core2 -mcx16 -msahf -mpopcnt -msse4.2 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wimplicit-function-declaration -Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -o .libs/gvfsd-http gvfsd_http-soup-input-stream.o gvfsd_http-soup-output-stream.o gvfsd_http-gvfsbackendhttp.o gvfsd_http-daemon-main.o gvfsd_http-daemon-main-generic.o -pthread -pthread  ./.libs/libdaemon.a ../common/.libs/libgvfscommon.so -L/usr/lib64 /usr/lib64/libexpat.so /usr/lib64/libsoup-gnome-2.4.so /usr/lib64/libgconf-2.so /usr/lib64/libORBit-2.so -lproxy /usr/lib64/libsqlite3.so /usr/lib64/libgnome-keyring.so -ldbus-1 /usr/lib64/libsoup-2.4.so -L/usr/lib /usr/lib64/libgnutls.so /usr/lib64/libtasn1.so /usr/lib64/libgcrypt.so /usr/lib64/libgpg-error.so /usr/lib64/libgio-2.0.so -lresolv /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so /usr/lib64/libgthread-2.0.so -lrt /usr/lib64/libglib-2.0.so /usr/lib64/libxml2.so -licui18n -licuuc -licudata -lpthread -ldl -lz -lm -lutil -pthread
/usr/lib64/libproxy.so: undefined reference to `JS_GetStringBytes'
/usr/lib64/libproxy.so: undefined reference to `JS_NewString'
collect2: ld returned 1 exit status
make[4]: *** [gvfsd-http] Error 1
make[4]: Leaving directory `/var/tmp/portage/gnome-base/gvfs-1.6.7/work/gvfs-1.6.7/daemon'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gvfs-1.6.7/work/gvfs-1.6.7/daemon'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gvfs-1.6.7/work/gvfs-1.6.7/daemon'



$ einfo =gnome-base/gvfs-1.6.7
Portage 2.2.0_alpha28 (default/linux/amd64/10.0, gcc-4.5.2, glibc-2.12.2-r0, 2.6.37-lh-r2 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.37-lh-r2-x86_64-Intel-R-_Core-TM-_i7_CPU_860_@_2.80GHz-with-gentoo-2.0.2
Timestamp of tree: Tue, 22 Mar 2011 06:30:01 +0000
ccache version 3.1.4 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1::last-hope
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
Repositories: gentoo sunrise dummy science last-hope
Installed sets: 
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf -mpopcnt -msse4.2 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wimplicit-function-declaration"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/nano/ /usr/share/openvpn/easy-rsa /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf -mpopcnt -msse4.2 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wenum-compare"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-t --jobs=12 --load-average=12 --keep-going"
FEATURES="assume-digests binpkg-logs buildsyspkg ccache collision-protect distlocks fixlafiles fixpackages metadata-transfer multilib-strict news noinfo parallel-fetch preserve-libs protect-owned sandbox sfperms sign split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf -mpopcnt -msse4.2 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g"
GENTOO_MIRRORS=" http://gentoo.j-schmitz.net/mirror/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
LINGUAS="en"
MAKEOPTS="-j12 -l12"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-z -v"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/data/local/sunrise/reviewed /data/local/dummy /data/local/sci /data/local/lh/ebuilds"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit 7zip X acpi additions alsa amd64 arpwarp atlas bash-completion berkdb blas branding bzip2 c++ cairo caps cblas ccache cleartype cli command-args consolekit corefonts cracklib cups cupsddk custom-optimization cxx dbus dri dts exif fbcondecor fortran gdbm gif glibc-omitfp gmp gnome gnome-keyring gpm graphics gstreamer gtk hddtemp iconv icu ipod javascript jpeg kqemu lapack largefile lcms ldap libnotify libsexy lm_sensors lzma mailtrain md5sum mmx mng modules mp3 mudflap multilib multiuser nagios-dns nagios-ntp nagios-ping nagios-ssh nano-syntax ncurses network-cron nis nls nptl nptlonly nsplugin objc objc++ opengl openmp openntpd pam pcre pdf perl png policykit pppd pymol python qt-static qt3support readline rrdcgi rrdtool science sensord session smp sqlite sqlite3 sse sse2 ssl startup-notification svg sysfs system-sqlite tcpd threads tiff truetype type1 udev unicode x264 xcb xcomposite xinerama xorg xulrunner zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Justin Lecher (RETIRED) gentoo-dev 2011-03-22 07:40:43 UTC
Created attachment 266805 [details]
/var/log/portage/build/gnome-base/gvfs-1.6.7:20110322-073216.log

build.log
Comment 2 Samuli Suominen gentoo-dev 2011-03-22 08:49:26 UTC
http://code.google.com/p/libproxy/source/detail?r=786

Log message

 issue 155 : fix build against xulrunner 2.0 (tested up to 2.0b11)
Comment 3 Gilles Dartiguelongue gentoo-dev 2011-03-22 10:51:18 UTC
*** Bug 359885 has been marked as a duplicate of this bug. ***
Comment 4 Samuli Suominen gentoo-dev 2011-03-22 18:45:41 UTC
Here is how you can get the upstream Xulrunner 2.0 RC patch:

svn diff -r785:786 http://libproxy.googlecode.com/svn/trunk/

But then it will fail to compile with:

[ 80%] Building CXX object libproxy/CMakeFiles/libproxy.dir/modules/wpad_dns_alias.cpp.o
/var/tmp/portage/net-libs/libproxy-0.4.6-r2/work/libproxy-0.4.6/libproxy/modules/pacrunner_mozjs.cpp:102:1: error: invalid conversion from ‘JSBool (*)(JSContext*, JSObject*, jsid, jsval*)’ to ‘JSBool (*)(JSContext*, JSObject*, jsid, JSBool, jsval*)’
make[2]: *** [libproxy/CMakeFiles/libproxy.dir/modules/pacrunner_mozjs.cpp.o] Error 1

That is reported upstream here at:

http://code.google.com/p/libproxy/issues/detail?id=158
Comment 5 Samuli Suominen gentoo-dev 2011-03-22 21:48:26 UTC
fix in portage
Comment 6 Sergiy Borodych 2011-03-23 08:00:43 UTC
Maybe to do "revision bump" here?
Because only reinstall libproxy helping to update gvfs
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2011-03-23 11:38:37 UTC
(In reply to comment #5)
How are we supposed to get the fix if you don't revbump? :)
Comment 8 Peter Volkov (RETIRED) gentoo-dev 2011-03-23 12:36:20 UTC
Yea, since revdep-rebuild does not catches this undefined references I also think it's good idea to revbump libproxy, so users rebuild it against xulrunner.
Comment 9 Ian Abbott 2011-03-23 12:45:06 UTC
(In reply to comment #7)
> (In reply to comment #5)
> How are we supposed to get the fix if you don't revbump? :)

Good idea. In my case, I only spotted the problem with libproxy when dev-libs/totem-pl-parser failed to emerge due to problems linking with libproxy.so.  revdep-rebuild never showed any problems but I tried to rebuild libproxy anyway and it failed to rebuild due to the xulrunner upgrade.
Comment 10 Pacho Ramos gentoo-dev 2011-03-25 11:50:44 UTC
*** Bug 360419 has been marked as a duplicate of this bug. ***
Comment 11 Samuli Suominen gentoo-dev 2011-03-27 17:54:12 UTC
*** Bug 360811 has been marked as a duplicate of this bug. ***
Comment 12 Samuli Suominen gentoo-dev 2011-03-27 18:11:15 UTC
I've revision bumped libproxy but not because of the reasons mentioned here. I guess this helps a bit for certain people... but it will still fail for people who upgrade libproxy before upgrading into xulrunner-2.0. 

It's mozilla's fault they changed API but didn't raise SONAME (.so version) and revdep-rebuild didn't catch the undefined symbols because of it.

But oh well...