Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 357831 - [desktop-effects] compiz-fusion-0.9.4 VERSION BUMP
Summary: [desktop-effects] compiz-fusion-0.9.4 VERSION BUMP
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 3 votes (vote)
Assignee: Desktop-Effects herd
URL:
Whiteboard:
Keywords: InOverlay
Depends on:
Blocks: 410979
  Show dependency tree
 
Reported: 2011-03-07 20:58 UTC by Ralf Mayer
Modified: 2012-09-15 12:13 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
x11-wm/compiz-0.9.4.ebuild (compiz-0.9.4.ebuild,2.26 KB, text/plain)
2011-04-09 00:41 UTC, mordjah
Details
x11-libs/libcompizconfig-0.9.4.ebuild (libcompizconfig-0.9.4.ebuild,835 bytes, text/plain)
2011-04-09 00:51 UTC, mordjah
Details
x11-plugins/compiz-plugins-main-0.9.4.ebuild (compiz-plugins-main-0.9.4.ebuild,718 bytes, text/plain)
2011-04-09 00:54 UTC, mordjah
Details
x11-plugins/compiz-plugins-unsupported-0.9.4.ebuild (compiz-plugins-unsupported-0.9.4.ebuild,733 bytes, text/plain)
2011-04-09 00:58 UTC, mordjah
Details
x11-libs/compizconfig-backend-gconf-0.9.4.ebuild (compizconfig-backend-gconf-0.9.4.ebuild,607 bytes, text/plain)
2011-04-09 00:59 UTC, mordjah
Details
dev-python/compizconfig-python-0.9.4.ebuild (compizconfig-python-0.9.4.ebuild,579 bytes, text/plain)
2011-04-09 01:16 UTC, mordjah
Details
x11-plugins/compiz-plugins-extra-0.9.4.ebuild (compiz-plugins-extra-0.9.4.ebuild,1.16 KB, text/plain)
2011-04-09 02:13 UTC, mordjah
Details
notification-0.9.4.patch patch for broken function in notification.cpp (notification-0.9.4.patch,557 bytes, patch)
2011-04-09 02:14 UTC, mordjah
Details | Diff
x11-apps/ccsm-0.9.4.ebuild (ccsm-0.9.4.ebuild,522 bytes, text/plain)
2011-04-09 02:18 UTC, mordjah
Details
x11-wm/compiz-fusion-0.9.4.ebuild (compiz-fusion-0.9.4.ebuild,594 bytes, text/plain)
2011-04-09 02:19 UTC, mordjah
Details
x11-libs/compizconfig-backend-kconf-0.9.4.ebuild (compizconfig-backend-kconfig4-0.9.4.ebuild,608 bytes, text/plain)
2011-04-09 02:24 UTC, mordjah
Details
*corrected* x11-libs/compizconfig-backend-kconfig4-0.9.4.ebuild (compizconfig-backend-kconfig4-0.9.4.ebuild,700 bytes, text/plain)
2011-04-09 16:55 UTC, mordjah
Details
fix_cmake_order.patch :patch for broken cmake configuration (fix_cmake_order.patch,668 bytes, patch)
2011-04-09 16:57 UTC, mordjah
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Mayer 2011-03-07 20:58:13 UTC
Hey guys,

According to http://cia.vc/stats/project/compiz-fusion/.message/459e09 i would like to make a version bump for the package above.

Best wishes,

Loko123

Reproducible: Always



Expected Results:  
version bump to 0.9.4
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-03-07 21:45:51 UTC
A < 24 hours day bump bug for desktop-effects.
I missed them :)

I'll try to take care of it soon.
Comment 2 Ralf Mayer 2011-03-07 22:57:23 UTC
I'm sorry for being so greedy ;-) But I'd like to test the latest version & report bug(s) upstream, like a working honeybee ;-).

Thanks for your work! :) God bless the devs! :)

Ralf
Comment 3 mordjah 2011-04-09 00:26:24 UTC
Give me just a few mins and I will post a set of 0.9.4 ebuilds for your convienience :)
Comment 4 mordjah 2011-04-09 00:41:26 UTC
Created attachment 269085 [details]
x11-wm/compiz-0.9.4.ebuild
Comment 5 mordjah 2011-04-09 00:51:53 UTC
Created attachment 269087 [details]
x11-libs/libcompizconfig-0.9.4.ebuild

This required me to build with FEATURES="-sandbox" for the install. looks to be related to a config file installed in /etc
Comment 6 mordjah 2011-04-09 00:54:06 UTC
Created attachment 269089 [details]
x11-plugins/compiz-plugins-main-0.9.4.ebuild
Comment 7 mordjah 2011-04-09 00:58:15 UTC
Created attachment 269091 [details]
x11-plugins/compiz-plugins-unsupported-0.9.4.ebuild
Comment 8 mordjah 2011-04-09 00:59:47 UTC
Created attachment 269093 [details]
x11-libs/compizconfig-backend-gconf-0.9.4.ebuild
Comment 9 mordjah 2011-04-09 01:16:10 UTC
Created attachment 269095 [details]
dev-python/compizconfig-python-0.9.4.ebuild
Comment 10 mordjah 2011-04-09 02:13:58 UTC
Created attachment 269099 [details]
x11-plugins/compiz-plugins-extra-0.9.4.ebuild
Comment 11 mordjah 2011-04-09 02:14:51 UTC
Created attachment 269101 [details, diff]
notification-0.9.4.patch patch for broken function in notification.cpp

this is needed to get it to build :)
Comment 12 mordjah 2011-04-09 02:18:11 UTC
Created attachment 269103 [details]
x11-apps/ccsm-0.9.4.ebuild
Comment 13 mordjah 2011-04-09 02:19:55 UTC
Created attachment 269105 [details]
x11-wm/compiz-fusion-0.9.4.ebuild
Comment 14 mordjah 2011-04-09 02:24:09 UTC
Created attachment 269107 [details]
x11-libs/compizconfig-backend-kconf-0.9.4.ebuild

This build is broken, and i know nothing of cmake.. but here is the rest. you can throw those into an overlay and build it all with USE="-kde" for the eager :)

#
CMake Error at src/CMakeLists.txt:6 (include):
#
  include could not find load file:
#
#
    KDE4Defaults
#
 
#
CMake Error at src/CMakeLists.txt:8 (include):
#
  include could not find load file:
#
#
    MacroLibrary
#
Comment 15 mordjah 2011-04-09 02:32:31 UTC
Comment on attachment 269101 [details, diff]
notification-0.9.4.patch patch for broken function in notification.cpp

just drop this into the compiz-plugins-extra/files subdir of your overlay.. i have nowhere to host the patch so I couldnt put a src uri in the ebuild.. I'm sure the desktop-effects people will handle it for us

cheers
Comment 16 mordjah 2011-04-09 16:55:00 UTC
Created attachment 269169 [details]
*corrected* x11-libs/compizconfig-backend-kconfig4-0.9.4.ebuild

this is a fixed ebuild for kconfig. you will need the patch that follows. again, i have noplace to host it, so drop it to the files subdir in your overlay till desktop effects hosts it and adds a url.
Comment 17 mordjah 2011-04-09 16:57:32 UTC
Created attachment 269173 [details, diff]
fix_cmake_order.patch :patch for broken cmake configuration

this patch fixes the cmake ordering so that it can find the kde4 config info it needs. this should let the whole thing build correctly.*



*this is my first attempt at ebuilds and patching, so please let me know if i did anything that does not conform to best practices.. I would like to be a useful member of the community.. 

~Mordjah
Comment 18 Billy DeVincentis 2011-04-16 20:00:45 UTC
Jorge Manuel, how far off are you from updating the overlay. I really would love to see the new 9.4 compiz!!
Comment 19 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-04-18 03:52:52 UTC
(In reply to comment #18)
> Jorge Manuel, how far off are you from updating the overlay. I really would
> love to see the new 9.4 compiz!!

I had planned to work on compiz this weekend, but life got in the way.
Comment 20 Vicente Olivert Riera (RETIRED) gentoo-dev 2011-04-28 19:51:33 UTC
I have added three dependences to x11-wm/compiz-0.9.4.ebuild:

dev-libs/boost
dev-util/boost-build
dev-cpp/glibmm

Now, I have the following error:

Linking C executable gtk-window-decorator
CMakeFiles/gtk-window-decorator.dir/frames.c.o: In function `decor_frame_refresh':
frames.c:(.text+0x5c0): undefined reference to `set_frame_scale'
CMakeFiles/gtk-window-decorator.dir/wnck.c.o: In function `decorations_changed':
wnck.c:(.text+0x8b1): undefined reference to `set_frames_scales'
collect2: ld devolvió el estado de salida 1
make[2]: *** [gtk/window-decorator/gtk-window-decorator] Error 1
make[1]: *** [gtk/window-decorator/CMakeFiles/gtk-window-decorator.dir/all] Error 2
make[1]: *** Se espera a que terminen otras tareas....

Here is the complete emerge build log:

http://paste.pocoo.org/show/379917/
Comment 21 Vicente Olivert Riera (RETIRED) gentoo-dev 2011-04-28 20:12:21 UTC
Ok, x11-wm/compiz-0.9.4 compiles with gtk use flag disabled, but compiz won't has support for gtk-window-decorator.
Comment 22 keenblade 2011-06-12 14:47:07 UTC
(In reply to comment #21)
> Ok, x11-wm/compiz-0.9.4 compiles with gtk use flag disabled, but compiz won't
> has support for gtk-window-decorator.

x11-wm/compiz-0.9.4 compiles fine here with gtk useflag. Probably, because I have x11-libs/gtk+-9999 and dev-libs/glib-9999 from gnome overlay.
Anyway, using fix_cmake_order.patch fixed some but not all errors for x11-libs/compizconfig-backend-kconfig4-0.9.4.ebuild. It fails with this:

make -j1 
CMake Error: Parse error in cache file /var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/work/compizconfig-backend-kconfig4-0.9.4_build/CMakeCache.txt. Offending entry: ()]
-- Found Qt-Version 4.7.3 (using /usr/bin/qmake)
-- Found X11: /usr/lib64/libX11.so
-- Found Threads: TRUE (found version "0.9.4")
-- Found Automoc4: /usr/bin/automoc4 
-- Found Perl: /usr/bin/perl (found version "0.9.4")
CMake Error at /usr/share/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:188 (MESSAGE):
  Could NOT find Phonon: Found version "0.9.4", but required is at least
  "4.3.80" (found /usr/include)
Call Stack (most recent call first):
  /usr/share/apps/cmake/modules/FindPhonon.cmake:35 (find_package_handle_standard_args)
  /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:705 (find_package)
  /usr/share/cmake/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
  src/CMakeLists.txt:1 (find_package)


-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] Error 1
emake failed
Comment 23 David J Cozatt 2011-07-29 02:37:38 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=32246 for an issue found on r600 missing check for null pointer in one 'case'
Comment 24 Billy DeVincentis 2011-08-24 03:07:46 UTC
Any chance of updating this to 9.5? And actually having it work?
Comment 25 Machredsch 2011-09-01 14:05:44 UTC
(In reply to comment #5)
> Created attachment 269087 [details]
> x11-libs/libcompizconfig-0.9.4.ebuild
> 
> This required me to build with FEATURES="-sandbox" for the install. looks to be
> related to a config file installed in /etc

You don't have to disable sandbox. It's safer to write: 
[code]SANDBOX_PREDICT="/etc/compizconfig/"[/code] 
to /etc/sandbox.conf or make an appropriate file in /etc/sandbox.d/

For compiling compiz with the "gtk" useflag, you have to enable the "gnome" useflag and compiz will compile here (on an amd64 with gtk+-2.24.5-r1, gdk-pixbuf-2.22.1-r2).

(Compiz starts here, but composite, opengl and gtk-window-decorator doesn't seem to work.
Compiz-fusion-9999 works in that case on my machine, but is very lazy and unstable. Me personally, switched back to 0.8 branch, but maybe those things helps the ebuild maintainers or someone else)
Comment 26 Sergey Popov gentoo-dev 2012-09-15 12:10:58 UTC
Compiz 0.9.4 ebuild does not build/work in modern environment. Recently i commited 0.9.8.2 into desktop-effects overlay.

Mark this bug as OBSOLETE