Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 357015 - sys-apps/lshw is missing build dependencies
Summary: sys-apps/lshw is missing build dependencies
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-01 20:39 UTC by André Malo
Modified: 2011-03-03 19:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch against lshw-02.15b.ebuild (h.diff,458 bytes, patch)
2011-03-01 20:41 UTC, André Malo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description André Malo 2011-03-01 20:39:55 UTC
sys-apps/lshw is missing build dependencies.

The gtk useflag misses dev-util/pkgconfig, x11-proto/glproto and x11-proto/dri2proto. The sqlite useflag misses dev-util/pkgconfig.

Reproducible: Always

Steps to Reproduce:
1. Cleanup your system, for example using emerge --depclean --with-bdeps n
2. USE=gtk emerge sys-apps/lshw # I'm using 02.15b here (the latest right now)
3. - or - USE=static emerge sys-apps/lshw

Actual Results:  
Build failure missing the described dependencies.

Expected Results:  
No build failure :-)

Patch is going to be attached.
Comment 1 André Malo 2011-03-01 20:41:00 UTC
Created attachment 264303 [details, diff]
Patch against lshw-02.15b.ebuild
Comment 2 SpanKY gentoo-dev 2011-03-03 04:13:42 UTC
i see no indication that either of those proto packages are needed.  the pc and header files they install do not seem to be used by lshw.

ive added the pkgconfig dep only:
http://sources.gentoo.org/sys-apps/lshw/lshw-02.15b.ebuild?r1=1.3&r2=1.4
Comment 3 André Malo 2011-03-03 08:24:22 UTC
Hmm, it dies here in the src/gui Makefile when calling

pkg-config gtk+-2.0 --cflags

when calling directly on the shell it looks like:

gui # pkg-config gtk+-2.0 --cflags
Package dri2proto was not found in the pkg-config search path.
Perhaps you should add the directory containing `dri2proto.pc'
to the PKG_CONFIG_PATH environment variable
Package 'dri2proto', required by 'egl', not found

(after installing dri2proto it misses glproto, after installing that it works)

x11-libs/gtk+-2.22.1-r1[cups jpeg tiff xinerama] is installed.

Do you need any more information?
Comment 4 SpanKY gentoo-dev 2011-03-03 09:05:15 UTC
you're stepping into a gray area.  those are *gtk* dependencies, not lshw.  we do not list dependencies of dependencies in packages.
Comment 5 André Malo 2011-03-03 09:10:36 UTC
*scratchinghead* so this is not fixed, but a WONTFIX. Grey area or not - it does not build without those deps.
Comment 6 SpanKY gentoo-dev 2011-03-03 09:48:36 UTC
uh, no.  by your logic, every single package in the tree that depends on gtk+ must also depend on every proto package that gtk+ depends on.  you can obviously see how that makes absolutely no sense.

what you're actually complaining about is the lack of BDEPEND.  there are other bugs which track this issue.  for now, stop unmerging random proto packages from your system.
Comment 7 André Malo 2011-03-03 13:07:54 UTC
Yes, that actually makes sense, because it doesn't build otherwise. Calling a package with unresolved deps "fixed" is... well... strange, but not my decision. I've tried my best to be honest ;-)

About BDEPEND - I thought DEPEND specifies build dependencies (and RDEPEND runtime deps). What would be the difference between DEPEND and BDEPEND? Can you point me to some document about that?

(about unmerging "random" packages - depclean does this for me. Maybe the --with-bdeps option should be removed then)
Comment 8 Samuli Suominen gentoo-dev 2011-03-03 14:54:39 UTC
(In reply to comment #7)
> Yes, that actually makes sense, because it doesn't build otherwise. Calling a
> package with unresolved deps "fixed" is... well... strange, but not my
> decision. I've tried my best to be honest ;-)
> 
> About BDEPEND - I thought DEPEND specifies build dependencies (and RDEPEND
> runtime deps). What would be the difference between DEPEND and BDEPEND? Can you
> point me to some document about that?
> 
> (about unmerging "random" packages - depclean does this for me. Maybe the
> --with-bdeps option should be removed then)
> 

Rant in bug 342393 instead, not here.
Comment 9 André Malo 2011-03-03 19:51:43 UTC
(In reply to comment #8)

> Rant in bug 342393 instead, not here.

When I'm going to rant, I'll do that where it belongs. But thanks for the insight.

Someone care to answer my question though?