Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 356853 - myspell-* dictionaries are broken by used filenames
Summary: myspell-* dictionaries are broken by used filenames
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on:
Reported: 2011-02-28 12:39 UTC by Florian Manschwetus
Modified: 2014-01-05 11:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Florian Manschwetus 2011-02-28 12:39:46 UTC as mentioned here.

To get it, install myspell-de and myspell-en
hunspell / openoffice (not bin here)
start openoffice writer try e.g. on spell check with de_DE "Maß" maybe marked as wrong suggests "Mass" as correct for de_CH.
Anyway in options for spell-checking you will see an unknown dictionary module (I guess it is en_GB-oed) but you will see that no spell-checker for de_CH was found and de_AT won't be listed at all.

Now change the filenames in /usr/share/myspell and /usr/lib/openoffice/share/dict/ooo as well as in the and dictionary.lst files there everything from  de_*_frami to de_* (read as de_AT, de_DE, de_CH)

Start oowriter again check spell-checker options and you will have spell-checker modules listed for de_AT, de_DE and de_CH, also now "Maß" is no longer wrong wen using de_DE, but when using de_CH it will again suggest "Mass".

Reproducible: Always

Actual Results:  
A usable German dictionary depends on some random factors (no idea my old x86 have had same problem, but it has seemed to has disappeared by reinstalling the spell-checking stuff). Today I took a closer look (checked the found spell-checkers) seeing that the problem is still there but for some reasons it seems to use the de_DE dictionary.

Expected Results:  
All installed dictionaries are detected correctly and are usable.

emerge --info
Portage 2.2.0_alpha23 (default/linux/amd64/10.0, gcc-4.5.2, glibc-2.13-r0, 2.6.37-thinkpad x86_64)
System uname: Linux-2.6.37-thinkpad-x86_64-Intel-R-_Core-TM-_i7_CPU_Q_720_@_1.60GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 25 Feb 2011 10:15:01 +0000
ccache version 3.1.4 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7.1, 3.1.3
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers: (sys-kernel/linux-headers)
Repositories: gentoo My-own-local-Overlay
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=core2 -msse4.1 -msse4.2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -msse4.1 -msse4.2 -fomit-frame-pointer -pipe"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="16bittmp X X509 a52 aac aalib accessibility acl acpi addbookmarks addns ads aio alias alsa amd64 amr amrnb amrr amrwb ao apache2 autoreplace avahi bacula-clientonly bacula-console bacula-nodir bacula-nosd bacula-split-init bash-completion binfilter bluetooth branding bzip2 cairo cardbus cdaudio cdda cddb cdio cdparanoia cdr chipcard chipcard2 cisco cli connectionstatus consolekit contactnotes cracklib crypt css ctype cups cupsddk curl custom-cflags custom-cpuopts custom-optimization cxx dba dbus dbx declarative device-mapper dga dhcp dialup directfb dlna dns dri drm dts dv dvb dvd dvdr dvdread eap-tls eds embedded emerald encode ethereal exchange exif extra extras fat fbcon festival ffmpeg firefox flac flite fontconfig foomaticdb fortran ftp fts3 fuse gallium garmin gd gdbm geldkarte gif gimp gimpprint git glade glib glitz glut glx gmp gnutls gphoto2 gpm gps gstreamer gtk h323 hal hbci hdaps hddtemp highlight history htmlhandbook httpd ibmacpi icc iconv icq id3 id3tag ifp ilbc imagemagick imlib immqt-bc innodb ipod ipv6 ipw3945 irc irda italk itrax iwl3945 jabber java java5 java6 javascript jingle john jpeg jpeg2k kde kdehiddenvisibility kerberos kontact kpathsea lame langpacks laptop latex ldap ldap-sasl libnotify libsamplerate live logitech-mouse lua lzma lzo lzw mad madwifi mdnsresponder-compat mikmod mime mjpeg mmx mmxext mng modules mono motif mozdevelop mozsvg mp2 mp3 mp3rtp mp3tunes mp4 mp4live mpd mpeg mpeg2 mplayer msn mtp mudflap multilib musepack musicbrainz mysql mysqli ncurses nepomuk netmeeting nfs njb nls nowin nowlistening nptl nptlonly nsplugin ntfs objc odbc ofx ogg openal opengl openmp openssl opensslcrypt openstreetmap openvg openvpn oscar otr pam parport passwordsave pbxt pcmcia pcre pcsc-lite pda pdf perl php pipechan plasma plotutils png policykit portaudio postgres ppds pppd pptp prediction python qt3support qt4 query-browser quicktime radius rar raw rdp rdpusb readline reiser4 reiserfs replytolist resolvconf samba sametime sasl scanner scenarios sco_flowcontrol scripting sdl sdl-image sdl-sound sdlaudio semantic-desktop session shout sip slp smbsharemodes smp sms snmp spell sql sqlite sse sse2 sse3 sse4 sse4a ssl startup-notification static-ppds statistics stream stun subversion svg swat sysfs syslog szip t60 tcpd templates texteffect theora threads threadsafe tidy tiff tk tntc translator truetype twolame type1 udev-acl unicode unzip upnp urandom usb userlocales v4l v4l2 vboxwebsrv vcd vdpau video visualization vnc vorbis vram wav webdav webkit webpresence wifi wimax winpopup wma wmf wps wxwindows x264 xcb xcomposite xforms xfs xine xinerama xml xmlreader xmlwriter xorg xosd xrandr xrender xscreensaver xulrunner xv xvid xvmc yahoo zeroconf zip zlib zrtp zsh-completion" ALSA_CARDS="hda-intel usb-audio bt87x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="adc65 agfa-cl20 aox barbie canon casio clicksmart310 digigr8 digita dimera directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 kodak konica largan lg_gsm mars minolta mustek panasonic pccam300 pccam600 polaroid ptp2 ricoh samsung sierra sipix smal sonix sonydscf1 sonydscf55 soundvision spca50x sq905 stv0674 stv0680 sx330z template toshiba" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="dibusb-usb1 dibusb-usb2 nxt200x or51132 or51211 sp8870 sp887x tda1004x ttpci ttusb-dec usb-a800 usb-dtt200u usb-umt usb-vp702x usb-vp7045 usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" NETBEANS_MODULES="cnd dlight enterprise php profiler ide harness java apisupport websvccommon nb" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Atman Sense 2011-05-16 11:01:12 UTC
same problem with app-office/lyx (see bug #366567 Comment 6)

hunspell -D lists only de_DE_frami, so hunspell -d de_DE oder LC_MESSAGES=de_DE hunspell doen't work. I did a workaround with symlinks, see bug #305725 Comment 2.
Comment 2 Michael Hofmann 2013-06-04 17:41:46 UTC
This problem should be solved with app-dicts/myspell-de-2012.06.17-r1
Comment 3 Pacho Ramos gentoo-dev 2014-01-05 11:43:24 UTC
(In reply to Michael from comment #2)
> This problem should be solved with app-dicts/myspell-de-2012.06.17-r1

Try with that version