Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 356681 - Please remove media-libs/phonon dependency from kde-base/kdelibs
Summary: Please remove media-libs/phonon dependency from kde-base/kdelibs
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on: kde-qtphonon
Blocks:
  Show dependency tree
 
Reported: 2011-02-27 11:52 UTC by Markos Chandras (RETIRED)
Modified: 2013-12-10 14:53 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras (RETIRED) gentoo-dev 2011-02-27 11:52:21 UTC
Hi

I am able to use kdelibs ( + kde apps ) with qt-phonon installed at the same time. Can you please remove the media-sound/phonon dependency from kdelibs or add x11-libs/qt-phonon as well.

I can verify that kdelibs build fine even if I don't have media-sound/phonon installed

ps: I am talking about the latest ~arch packages

kdelibs: Installed versions:  4.6.0-r1
qt-phonon: Installed versions:  4.7.1(4)
Comment 1 Andreas K. Hüttel archtester gentoo-dev 2011-08-23 21:37:11 UTC
I put this on the agenda for the next KDE meeting; needs to be discussed.
Comment 2 Maciej Mrozowski gentoo-dev 2011-08-24 21:10:31 UTC
Maybe you can build kdelibs itself with no Phonon present, but Phonon is part of KDE API, therefor it cannot be dropped entirely.
However providing qt-phonon as a substitution is some option, especially now when media-sound/phonon doesn't bundle plugins anymore.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-08-29 01:02:14 UTC
As long as KDE defaults to media-sound/phonon if the user doesn't have x11-libs/qt-phonon installed, it's fine by me.
Let's not get back to the "old mess" with media-libs/phonon and x11-libs/qt-phonon blocking each other when a user installs KDE, though.
Comment 4 Davide Pesavento gentoo-dev 2012-01-20 16:34:36 UTC
FYI, the qt-phonon module will be dropped for Qt 5.0, officially replaced by QtMultimedia. Phonon will be maintained exclusively by KDE.
Comment 5 Andreas K. Hüttel archtester gentoo-dev 2012-03-24 16:54:22 UTC
(In reply to comment #4)
> FYI, the qt-phonon module will be dropped for Qt 5.0, officially replaced by
> QtMultimedia. Phonon will be maintained exclusively by KDE.

Right. After some discussion in the kde team meeting- we won't support using qt-phonon as replacement for phonon, for two reasons:
1) it's generating complications
2) kde usptream says "while it might work it is stupid because you lose a lot of functionality"
3) qt-phonon is going away
Comment 6 Johannes Huber gentoo-dev 2012-04-06 08:57:33 UTC
*** Bug 410943 has been marked as a duplicate of this bug. ***