Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 356493 - app-pda/synce-sync-engine-0.15.1-r1: ImportError: No module named pyrtfcomp
Summary: app-pda/synce-sync-engine-0.15.1-r1: ImportError: No module named pyrtfcomp
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-25 22:12 UTC by Simeon Maryasin
Modified: 2011-02-25 22:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simeon Maryasin 2011-02-25 22:12:29 UTC
I have just installed app-pda/synce-sync-engine-0.15.1-r1 and app-pda/synce-connector-0.15.1 (along with all deps).
When I try to start sync-engine I get an error:

$ sync-engine
Traceback (most recent call last):
  File "/usr/bin/sync-engine-2.7", line 45, in <module>
    import SyncEngine.config as Config
  File "/usr/lib64/python2.7/site-packages/SyncEngine/config.py", line 32, in <module>
    from formatapi import SupportedFormats,DefaultFormat
  File "/usr/lib64/python2.7/site-packages/SyncEngine/formatapi.py", line 21, in <module>
    import formats
  File "/usr/lib64/python2.7/site-packages/SyncEngine/formats/__init__.py", line 21, in <module>
    import parser
  File "/usr/lib64/python2.7/site-packages/SyncEngine/formats/parser.py", line 25, in <module>
    import conversions
  File "/usr/lib64/python2.7/site-packages/SyncEngine/formats/conversions.py", line 29, in <module>
    import pyrtfcomp
ImportError: No module named pyrtfcomp

`eix -sS rtfcomp` and `locate rtfcomp` shows nothing...

Reproducible: Always

Steps to Reproduce:
1. install synce-sync-engine
2. run sync-engine

Actual Results:  
ImportError: No module named pyrtfcomp

Expected Results:  
Normal start?..

$ emerge --info synce-sync-engine
Portage 2.1.9.40 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r1, 2.6.37-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.37-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 25 Feb 2011 21:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7.1, 3.1.3
dev-util/cmake:      2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 IBM-J1.6 skype-eula AdobeFlash-10.1 googleearth"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -mtune=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -mtune=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.corbina.net/pub/Linux/gentoo/  ftp://ftp.fi.debian.org/pub/gentoo/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/x11 /var/lib/layman/pro-audio /var/lib/layman/rion /var/lib/layman/arcon /var/lib/layman/java-overlay /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 aspell avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cdparanoia cdr cjk cli consolekit cracklib crypt cups curl cvs cxx dbus djvu dri dts dv dvd dvdr emboss encode esd exif fam fbcon ffmpeg firefox flac fontconfig foomaticdb fortran ftp gcj gd gdbm gdu gif gimp gnutls gpm gsm gtk h323 iconv icu id3tag idn ieee1394 ipv6 jabber jack java jingle jpeg jpeg2k kqemu kvm ladspa lame lash lcms libcaca libnotify libsamplerate lzo mad midi mikmod mmx mng modplug modules mono motif mp3 mp4 mpeg mplayer mudflap multilib mysql nas ncurses nfs nls nptl nptlonly nsplugin offensive ogg openal opengl openmp pam pango pcre pda pdf perl php png policykit portaudio ppds pppd pulseaudio python qt3support qt4 rar readline samba scanner sdl session sip smp sndfile soundtouch sox speex spell sqlite sse sse2 ssl startup-notification svg sysfs tcpd theora threads tiff timidity tk truetype twolame udev unicode usb v4l v4l2 vamp vim-syntax vorbis wav wavpack webkit wma wmf x264 xcb xcomposite xft xml xorg xscreensaver xulrunner xv xvid zip zlib zsh-completion" ALSA_CARDS="hda-intel intel8x0 intel8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="samsung canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse ps2mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" LIRC_DEVICES="devinput" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa vga radeonhd radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-pda/synce-sync-engine-0.15.1-r1 was built with the following:
USE="(multilib)"
Comment 1 Samuli Suominen gentoo-dev 2011-02-25 22:17:27 UTC
just fixed it (and librra too)
Comment 2 Samuli Suominen gentoo-dev 2011-02-25 22:18:59 UTC
(if you sync in a hour they'll get pulled in as deps)