Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 355661 - net-misc/youtube-dl should RDEPEND on media-video/rtmpdump
Summary: net-misc/youtube-dl should RDEPEND on media-video/rtmpdump
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
: 530194 639028 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-20 09:41 UTC by Priit Laes (IRC: plaes)
Modified: 2017-12-21 15:41 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Priit Laes (IRC: plaes) 2011-02-20 09:41:50 UTC
$ youtube-dl -t some-youtube-url-that-has-rtmp-media
[youtube] Setting language
[youtube] xxx: Downloading video webpage
[youtube] xxx: Downloading video info webpage
[youtube] xxx: Extracting video information
[youtube] RTMP download detected
[download] Destination: About_to_download_the_video.flv
ERROR: RTMP download detected but "rtmpdump" could not be run
Comment 1 Joe Stroller 2011-09-29 23:09:44 UTC
<pantomime>

Oh, no, it shouldn't!

</pantomime>


Many YouTube videos work perfectly fine without rtmpdump.

This should be a USE flag or left to the user's discretion.

It's really not hard to see what needs installing if a video does need rtmpdump - the error message in the opening comment is quite clear.

On a system without rtmpdump:


$ youtube-dl "http://www.youtube.com/watch?v=I9E2eXXwW28"
[youtube] Setting language
[youtube] I9E2eXXwW28: Downloading video webpage
[youtube] I9E2eXXwW28: Downloading video info webpage
[youtube] I9E2eXXwW28: Extracting video information
[download] Destination: I9E2eXXwW28.mp4
[download]   0.0% of 646.94M at  132.27k/s ETA 83:28^C
…
Comment 2 Jeroen Roovers gentoo-dev 2011-11-22 19:18:16 UTC
Works for me. It isn't obvious which version of youtube-dl you were using, so perhaps this has been fixed in a newer version.

Adding a USE flag goes against a Gentoo development principle: do not add USE flags only to pull in runtime dependencies (RDEPEND="foo? ( cat/misc-bar )"). If users insist I could add a "helpful" pkg_postinst() { elog ""; } message to reflect the optional use of rtmpdump...
Comment 3 Jeroen Roovers gentoo-dev 2014-11-23 21:37:03 UTC
*** Bug 530194 has been marked as a duplicate of this bug. ***
Comment 4 Jeroen Roovers gentoo-dev 2017-11-28 05:41:07 UTC
*** Bug 639028 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen Roovers gentoo-dev 2017-12-21 15:29:48 UTC
I'll respond here instead of underneath bug #639028 comment #3 as that's a duplicate.

(In reply to Jeroen Roovers from comment #2)

You should really read that comment, deso@. It gives useful objections to the USE flag proposal.

> If users insist I could add a "helpful" pkg_postinst() { elog ""; }
> message to reflect the optional use of rtmpdump...

commit f283834fafa5b322de69aff78a853846cb1aa3d6
Author: Jeroen Roovers <jer@gentoo.org>
Date:   Mon Dec 4 00:51:45 2017 +0100

    net-misc/youtube-dl: Version bump.

    Package-Manager: Portage-2.3.16, Repoman-2.3.6

That commit (landing in net-misc/youtube-dl-2017.12.02) added the friendly message.
Comment 6 Jeroen Roovers gentoo-dev 2017-12-21 15:41:30 UTC
(In reply to Jeroen Roovers from comment #2)
> Adding a USE flag goes against a Gentoo development principle: do not add
> USE flags only to pull in runtime dependencies (RDEPEND="foo? ( cat/misc-bar
> )").

To expand on that a bit. What I say is `emerge rtmpdump` fixes your problem. What you say is

echo net-misc/youtube-dl rtmp >> /etc/portage/profile/package.use
emerge youtube-dl

fixes your problem. In the process, you do the equivalent of `emerge rtmdump` but you also pointlessly re-emerge youtube-dl which was already installed (or you would not have had the problem in the first place).

Why do you think it helps to make the process more convoluted? Because it gives you a nice and cosy logical link between how you like one package to work with another? I can understand that it does, as it makes me feel better, too, but I still don't think that is the right technical solution. That is a problem that should be fixed elsewhere (look for earlier suggestions on the gentoo-dev@ mailing list under "EAPI 5+: split PDEPEND introducing SDEPEND" in 2012 and under "Suggested packages option in portage" in 2013).