Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 354441 - emerge tries to reinstall binary if the corresponding ebuild is masked or removed
Summary: emerge tries to reinstall binary if the corresponding ebuild is masked or rem...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS, REGRESSION
Depends on:
Blocks: 349307
  Show dependency tree
 
Reported: 2011-02-11 08:43 UTC by Dennis Schridde
Modified: 2023-10-09 21:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2011-02-11 08:43:27 UTC
Situation as described on IRC:

net-dns/nsd-3.2.6 is installed, a binary package for it is available, it is unmasked via package.keywords.

The overlay was updated, version 3.2.6 was dropped, 3.2.7 added. This version is keyword masked for my arch.

When updating world (--newuse or not), portage will want to reinstall the net-dns/nsd-3.2.6 binary package. Reason is probably that the new 3.2.7 version triggered an update, but later 3.2.6 was selected as the only installable option because of the keyword mask of 3.2.7.

Reproducible: Always
Comment 2 Zac Medico gentoo-dev 2011-02-11 21:38:49 UTC
We can count this bug as a regression since the different_version code, that was remove in the following commit, guarded against this type of problem:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=2553847b6b7795719ee7b4439f34182dcd66fcae
Comment 3 Zac Medico gentoo-dev 2011-02-15 19:02:04 UTC
This is fixed in 2.1.9.40 and 2.2.0_alpha24.