Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 353164 - sys-apps/coreutils-8.9: tests/ls/readdir-mountpoint-inode fails if mountpoint is not accessible
Summary: sys-apps/coreutils-8.9: tests/ls/readdir-mountpoint-inode fails if mountpoint...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL: http://lists.gnu.org/archive/html/bug...
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2011-01-29 20:05 UTC by Sebastian Kühn
Modified: 2017-11-06 16:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed fix for readdir-mountpoint-inode (readdir-mountpoint-inode.patch,428 bytes, patch)
2011-01-29 20:09 UTC, Sebastian Kühn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Kühn 2011-01-29 20:05:54 UTC
I've mounted a disk at /home/sebastian/Archive while /home/sebastian is not accessible by anyone except the user sebastian.
The test ls/readdir-mountpoint-inode fails with
ls: cannot open directory /home/sebastian: Permission denied


Reproducible: Always

Steps to Reproduce:
1. create a directory not accessible by the portage user
2. mount something within this directory
3. run tests as portage user (emerge package)

Actual Results:  
tests/ls/readdir-mountpoint-inode fails

Expected Results:  
tests/ls/readdir-mountpoint-inode skips this mount point
and succeeds
Comment 1 Sebastian Kühn 2011-01-29 20:09:55 UTC
Created attachment 261040 [details, diff]
Proposed fix for readdir-mountpoint-inode

Check the return value of the ls call and fail the test with 77 (as checked by the caller; I'm not sure why 77)
Comment 2 Jeroen Roovers gentoo-dev 2011-02-01 17:13:02 UTC
Please paste your `emerge --info =sys-apps/coreutils-8.9' output in a comment.
Comment 3 Sebastian Kühn 2011-02-01 21:24:22 UTC
(In reply to comment #2)
> Please paste your `emerge --info =sys-apps/coreutils-8.9' output in a comment.
> 

Portage 2.2.0_alpha19 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.2, glibc-2.12.2-r0, 2.6.37 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.37-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 01 Feb 2011 14:45:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7
dev-util/cmake:      2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.2.4-r1, 4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo perl-experimental sunrise ramaloke kde
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -ggdb -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/init.d/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /sbin/rc /usr/share/X11/xkb/"
CXXFLAGS="-march=core2 -ggdb -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en_GB en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/perl-experimental /usr/portage/local/layman/sunrise /usr/portage/local/layman/ramaloke /usr/portage/local/layman/kde"
SYNC="rsync://proxy/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi alsa amd64 audiofile bash-completion berkdb bluetooth bzip2 cairo caps cdr cli consolekit cracklib crypt css cups curl cxx dbus dga dri dts dvd dvdr dvdread emboss encode exif fam ffmpeg flac gd gdu gif git gphoto2 gpm graphviz gstreamer handbook iconv icq idn imagemagick inotify jabber java6 jpeg jpeg2k kde ladspa lcms libcaca libnotify lm_sensors lzma mad mikmod mjpeg mmap mmx mmxext mng modplug mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg openal openexr opengl openmp pam pango pcre pdf pic plasma png policykit postgres ppds pppd qt qt3 qt3support qt4 quicktime readline rss samba sasl sdl semantic-desktop session speex spell sse sse2 sse4 ssl ssse3 startup-notification subversion svg sysfs system-sqlite tcpd theora threads tiff truetype udev unicode usb vcd vorbis wmf x264 xattr xcb xcomposite xinerama xml xmp xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en_GB en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-apps/coreutils-8.9 was built with the following:
USE="acl caps (multilib) nls test unicode xattr -gmp (-selinux) -static -vanilla"
Comment 4 Jeroen Roovers gentoo-dev 2011-02-01 22:56:29 UTC
Thanks.
Comment 5 Thomas Deutschmann gentoo-dev Security 2017-11-06 12:08:16 UTC
Thanks for patch, still valid for 8.28.

I submitted your patch to upstream.
Comment 6 Larry the Git Cow gentoo-dev 2017-11-06 16:21:53 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0edff67f453a7509c08fce538d3da9c947daa433

commit 0edff67f453a7509c08fce538d3da9c947daa433
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2017-11-06 16:20:43 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2017-11-06 16:20:57 +0000

    sys-apps/coreutils: Rev bump to address multiple test failures
    
    - Running test suite with FEATURES=usersandbox is no longer supported
      due to various sandbox issues. (bug #413621, #439574, #629660)
    
    - Due to sandbox failures previously disabled tests
      re-enabled. (bug #415487)
    
    - tests/ls/readdir-mountpoint-inode test failure fixed. (bug #353164)
    
    - "caps" USE flag description more specified. (bug #617702
    
    - Tools/programs/libraries used in test suite now listed in
      DEPEND="test? (...)" which requires re-keywording for some
      architectures.
    
    Bug: https://bugs.gentoo.org/413621
    Bug: https://bugs.gentoo.org/439574
    Bug: https://bugs.gentoo.org/629660
    Bug: https://bugs.gentoo.org/415487
    Closes: https://bugs.gentoo.org/353164
    Closes: https://bugs.gentoo.org/617702
    Package-Manager: Portage-2.3.13, Repoman-2.3.4

 sys-apps/coreutils/Manifest                 |   1 +
 sys-apps/coreutils/coreutils-8.28-r1.ebuild | 210 ++++++++++++++++++++++++++++
 sys-apps/coreutils/metadata.xml             |   1 +
 3 files changed, 212 insertions(+)