Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 351969 - sys-fs/udisks requires CONFIG_USB_SUSPEND in kernel .config but it doesn't exist
Summary: sys-fs/udisks requires CONFIG_USB_SUSPEND in kernel .config but it doesn't exist
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 351976 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-18 06:52 UTC by mjbjr
Modified: 2011-01-18 20:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mjbjr 2011-01-18 06:52:49 UTC
While emerging thunar, I got the following from the dependency 'udisks':

 * Messages for package sys-fs/udisks-1.0.2:

 *   CONFIG_USB_SUSPEND:         is not set when it should be.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.

That config isn't found in 2.6.36-gentoo-r5

Reproducible: Always

Actual Results:  
# grep -i SUSPEND /usr/src/linux/.config
CONFIG_ARCH_SUSPEND_POSSIBLE=y
CONFIG_SUSPEND_NVS=y
CONFIG_SUSPEND=y
# CONFIG_PM_TEST_SUSPEND is not set
CONFIG_SUSPEND_FREEZER=y



# emerge --info
Portage 2.1.9.33 (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.11.2-r3, 2.6.36-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-x86_64-Intel-R-_Core-TM-2_CPU_6700_@_2.66GHz-with-gentoo-1.12.14
Timestamp of tree: Tue, 18 Jan 2011 05:15:01 +0000
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA googleearth AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.mcs.anl.gov/pub/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 apache2 berkdb bzip2 cairo cli cracklib crypt css cups cxx dbi dbus device-mapper dri dvd dvdr exif extras fortran gdbm gdu gnutls gpm gtk iconv ipv6 jpeg lcms libnotify mime mmx modules mp3 mudflap multilib ncurses nls nptl nptlonly nsplugin odbc opengl openmp pam pcre perl png policykit postgres pppd python readline session smp sndfile sse sse2 ssl sysfs tcpd threads tiff udev unicode usb v4l v4l2 wav xcomposite xml xorg xulrunner zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="nikon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Cyprien Nicolas (fulax) 2011-01-18 07:14:24 UTC
It does, but you have to enable PM_RUNTIME "Run-time PM core functionality" for USE_SUSPEND "USB runtime power management (autosuspend) and wakeup (NEW)" to appear in menuconfig.

Symbol: USB_SUSPEND [=y]
Type  : boolean
Prompt: USB runtime power management (autosuspend) and wakeup
  Defined at drivers/usb/core/Kconfig:93
  Depends on: USB_SUPPORT [=y] && USB [=y] && PM_RUNTIME [=y]
  Location:
    -> Device Drivers
      -> USB support (USB_SUPPORT [=y])
        -> Support for Host-side USB (USB [=y])
Comment 2 Torsten Veller (RETIRED) gentoo-dev 2011-01-18 08:23:50 UTC
*** Bug 351976 has been marked as a duplicate of this bug. ***
Comment 3 Jeroen Roovers gentoo-dev 2011-01-18 20:29:11 UTC
From the source:

 Symbol: USB_SUSPEND [=n]
 Prompt: USB runtime power management (suspend/resume and wakeup)
   Depends on: USB_SUPPORT [=y] && USB [=y] && PM_RUNTIME [=n]
   Location:
     -> Device Drivers
       -> USB support (USB_SUPPORT [=y])
         -> Support for Host-side USB (USB [=y])

It's there alright.
Comment 4 mjbjr 2011-01-18 20:41:18 UTC
(In reply to comment #1)
> It does, but you have to enable PM_RUNTIME "Run-time PM core functionality" for
> USE_SUSPEND "USB runtime power management (autosuspend) and wakeup (NEW)" to
> appear in menuconfig.
> 
> Symbol: USB_SUSPEND [=y]
> Type  : boolean
> Prompt: USB runtime power management (autosuspend) and wakeup
>   Defined at drivers/usb/core/Kconfig:93
>   Depends on: USB_SUPPORT [=y] && USB [=y] && PM_RUNTIME [=y]
>   Location:
>     -> Device Drivers
>       -> USB support (USB_SUPPORT [=y])
>         -> Support for Host-side USB (USB [=y])
> 

Thank you for pointing it out...

Is there a way to search/grep the complete list of config possibilities, including those that need to be "turned on"?