Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 351154 - sys-auth/polkit-0.99 should depend on dev-perl/XML-Parser
Summary: sys-auth/polkit-0.99 should depend on dev-perl/XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-08 21:46 UTC by David E. Narváez
Modified: 2013-12-19 15:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David E. Narváez 2011-01-08 21:46:15 UTC
I was trying to emerge polkit and it failed upon checking for the Perl XML::Parser module. In fact, I had the module installed but not updated to latest version (2.36-r1 in my case) so after updating it everything went on fine.

Reproducible: Always

Steps to Reproduce:
1. emerge polkit without latest  dev-perl/XML-Parser
Actual Results:  
Fails on check for XML::Parser Perl module

Expected Results:  
Successful emerge

$ emerge --info
Portage 2.1.9.25 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.11.2-r3, 2.6.36-gentoo-r5 x86_64)

...

$ layman -l
* kde
* mozilla
* qting-edge
* rion
Comment 1 Rafał Mużyło 2011-01-08 22:23:53 UTC
You've failed to attach the log, but let me make a guess:
it failed on intltool check and you haven't run perl-cleaner after upgrade ?
Comment 2 David E. Narváez 2011-01-09 00:24:46 UTC
(In reply to comment #1)
> You've failed to attach the log, but let me make a guess:
> it failed on intltool check and you haven't run perl-cleaner after upgrade ?

Right, it failed on intltool and I haven't run perl-cleaner at all (does it run automatically after an upgrade to a perl module?)

David E. Narváez

Comment 3 Rafał Mużyło 2011-01-09 05:05:03 UTC
Well, it needs to be run after perl upgrade.
I doubt upgrade mattered, just a rebuild was probably required.
Do test it for the other packages.
Comment 4 Jeroen Roovers gentoo-dev 2013-12-19 15:29:42 UTC

*** This bug has been marked as a duplicate of bug 41124 ***