Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 351145 - media-libs/libgphoto2 USE flag st2205 wrecks gphoto2
Summary: media-libs/libgphoto2 USE flag st2205 wrecks gphoto2
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-08 19:28 UTC by Kristian Niemi
Modified: 2011-01-12 17:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kristian Niemi 2011-01-08 19:28:08 UTC
When enabling USE flag st2205 for package libgphoto2[1] *no* cameras are detected anymore.

[1] Tried versions 2.4.9 and ~2.4.10 with same results.

Reproducible: Always

Steps to Reproduce:
1. Build libgphoto2 with USE st2205
2. Attach camera that used to work prior to step 1.
3. Try gphoto2 -L

Actual Results:  
No camera is found.

Expected Results:  
Camera found by gphoto2 as usual.

The USE flag st2250 is supposed to enable support for some small, flash-based picture frames. Having enabled the USE flag I was, however, unable to connect to the picture frame. Thought it was just that support that didn't work. But then I connected a camera that used to work flawlessly --- and got the exact same results. That is, "no camera attached". 

Tried unstable 2.4.10, but same results. The udev rules for libgphoto2 were changed at some point (perhaps 2.4.10); tried going back to old udev rules, but that didn't help either. Downgraded back to 2.4.9 --- no change.

The only thing that worked --- ie. enabled gphoto2 to locate the cameras it used to find --- was to build libgphoto2 *without* USE st2250. 

Clearly, USE st2250 was at fault. Regardless if that works or not, surely it's not supposed to disrupt the function of the connectivity with other cameras.

Perhaps said USE-flag should be disabled altogether?
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-01-10 10:50:42 UTC
please paste emerge -pv libgphoto2 in both cases. It looks like there is a misunderstanding.
Comment 2 Kristian Niemi 2011-01-10 11:23:56 UTC
(In reply to comment #1)
> please paste emerge -pv libgphoto2 in both cases. It looks like there is a
> misunderstanding.
> 

Thanks for taking the time to look at this. 

[1] With CAMERAS="canon"

----------------------------------------------------------------
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/libgphoto2-2.4.9  USE="exif nls -doc -examples -hal -zeroconf" CAMERAS="canon -adc65 -agfa_cl20 -aox -ax203 -barbie -casio_qv -clicksmart310 -digigr8 -digita -dimagev -dimera3500 -directory -enigma13 -fuji -gsmart300 -hp215 -iclick -jamcam -jd11 -jl2005a -kodak_dc120 -kodak_dc210 -kodak_dc240 -kodak_dc3200 -kodak_ez200 -konica -konica_qm150 -largan -lg_gsm -mars -mustek -panasonic_coolshot -panasonic_dc1000 -panasonic_dc1580 -panasonic_l859 -pccam300 -pccam600 -polaroid_pdc320 -polaroid_pdc640 -polaroid_pdc700 -ptp2 -ricoh -ricoh_g3 -samsung -sierra -sipix_blink -sipix_blink2 -sipix_web2 -smal -sonix -sony_dscf1 -sony_dscf55 -soundvision -spca50x -sq905 -st2205 -stv0674 -stv0680 -sx330z -template -topfield -toshiba_pdrm11" 0 kB

----------------------------------------------------------------

[2] With CAMERAS="canon st2205"

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/libgphoto2-2.4.9  USE="exif nls -doc -examples -hal -zeroconf" CAMERAS="canon st2205* -adc65 -agfa_cl20 -aox -ax203 -barbie -casio_qv -clicksmart310 -digigr8 -digita -dimagev -dimera3500 -directory -enigma13 -fuji -gsmart300 -hp215 -iclick -jamcam -jd11 -jl2005a -kodak_dc120 -kodak_dc210 -kodak_dc240 -kodak_dc3200 -kodak_ez200 -konica -konica_qm150 -largan -lg_gsm -mars -mustek -panasonic_coolshot -panasonic_dc1000 -panasonic_dc1580 -panasonic_l859 -pccam300 -pccam600 -polaroid_pdc320 -polaroid_pdc640 -polaroid_pdc700 -ptp2 -ricoh -ricoh_g3 -samsung -sierra -sipix_blink -sipix_blink2 -sipix_web2 -smal -sonix -sony_dscf1 -sony_dscf55 -soundvision -spca50x -sq905 -stv0674 -stv0680 -sx330z -template -topfield -toshiba_pdrm11" 0 kB

----------------------------------------------------------------

When libgphoto2 is built as [1], the canon camera is found. When built as [2] it is not, and neither is the picture frame.
Comment 3 Gilles Dartiguelongue gentoo-dev 2011-01-10 11:33:45 UTC
hum, what's you canon camera model ?
Comment 4 Kristian Niemi 2011-01-10 12:24:00 UTC
Canon DIGITAL IXUS 950 IS
Comment 5 Kristian Niemi 2011-01-10 12:28:35 UTC
Built libgphoto2 on another machine (amd64), normally CAMERAS="directory ptp2 canon", with the additional USE flag st2205. No problems connecting to a PTP2 camera (Nikon D90). :-/
Comment 6 Gilles Dartiguelongue gentoo-dev 2011-01-10 12:42:31 UTC
your canon is actually a ptp2 camera. I wonder how it worked with the canon driver only.
Comment 7 Kristian Niemi 2011-01-10 16:33:54 UTC
(In reply to comment #6)
> your canon is actually a ptp2 camera. I wonder how it worked with the canon
> driver only.
> 

Oh. I'll build it with ptp2, then, and try with that.
Comment 8 Kristian Niemi 2011-01-10 16:55:43 UTC
Well, well! The canon worked both with CAMERAS="ptp2" and with CAMERAS="ptp2 st2205"! 

However, the picture frame that should work with st2205 still doesn't. But that's another problem, another bug. :)

[1] http://hansdegoede.livejournal.com/9183.html (frame in question is 1908:0102)
Comment 9 Gilles Dartiguelongue gentoo-dev 2011-01-10 18:10:08 UTC
(In reply to comment #8)
> Well, well! The canon worked both with CAMERAS="ptp2" and with CAMERAS="ptp2
> st2205"! 

nice

> However, the picture frame that should work with st2205 still doesn't. But
> that's another problem, another bug. :)
> 
> [1] http://hansdegoede.livejournal.com/9183.html (frame in question is
> 1908:0102)

from this link and libgphoto2 NEWS file I'd advise trying to enable ax203 driver from your second camera.

Comment 10 Kristian Niemi 2011-01-10 18:50:57 UTC
(In reply to comment #9)
> from this link and libgphoto2 NEWS file I'd advise trying to enable ax203
> driver from your second camera.

Has anyone told you lately that you're both helpful AND good at this?

Really appreciate you taking the time to look into this. As you might've guessed by now, you were right on the money. Thanks again!!

Oh, and you're good at this! And helpful!
Comment 11 Gilles Dartiguelongue gentoo-dev 2011-01-10 20:52:06 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > from this link and libgphoto2 NEWS file I'd advise trying to enable ax203
> > driver from your second camera.
> 
> Has anyone told you lately that you're both helpful AND good at this?
> 
> Really appreciate you taking the time to look into this. As you might've
> guessed by now, you were right on the money. Thanks again!!
> 
thanks, I guess the bug can be closed invalid now since it was a configuration problem.
Thanks for reporting.
Comment 12 Kristian Niemi 2011-01-10 21:47:56 UTC
(In reply to comment #11)
> thanks, I guess the bug can be closed invalid now since it was a configuration
> problem.
> Thanks for reporting.
> 

Yes. Though I intentionally left it open, as there still was something fishy going on. Either of camera working /with/ canon, which it perhaps shouldn't have had(?), or that it stopped working with the st2055 driver. On the one hand it'd be interesting if someone who'd actually needed to use the canon-driver, and not the ptp2 one, to try building with (that and) st055 support. On the other hand, I guess there's so few people this possible bug might annoy that the effort that'd go into properly finding it, nevermind squashing it, far overweighs the benefits.
Comment 13 Gilles Dartiguelongue gentoo-dev 2011-01-12 17:39:20 UTC
from libgphoto:

        if test "x$BUILD_THESE_CAMLIBS_BASE" = "x canon" ; then
                # Gentoo mode... if user just said "canon", add "ptp2" ... should save support requests.
                BUILD_THESE_CAMLIBS_BASE="$BUILD_THESE_CAMLIBS_BASE ptp2"
                camlibs="$camlibs ptp2"
                AC_MSG_WARN([
                        You have just selected the old canon driver. However most current Canons
                        are supported by the PTP2 driver.
                        Autoselecting ptp2 driver too to avoid support requests.
                ])

explains everything, they tried to outsmart users blaming gentoo... bastards...