Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 35039 - Ebuild fails on a very simple new package, don't understand why
Summary: Ebuild fails on a very simple new package, don't understand why
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2003-12-04 02:38 UTC by Federico Zenith
Modified: 2011-10-30 22:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

[Buggy] Ebuild for KimDaBa (kimdaba-1.0.ebuild,207 bytes, text/plain)
2003-12-04 02:39 UTC, Federico Zenith
_Working_ ebuild for KimDaBa (kimdaba-1.0.ebuild,270 bytes, text/plain)
2003-12-05 00:29 UTC, Federico Zenith
Configuration output from econf (confbad,11.41 KB, text/plain)
2003-12-05 00:30 UTC, Federico Zenith
Configuration output from ./configure (listgood,40.76 KB, text/plain)
2003-12-05 00:32 UTC, Federico Zenith
File list for econf (listbad,36.68 KB, text/plain)
2003-12-05 00:34 UTC, Federico Zenith
File list for ./configure (listgood,40.76 KB, text/plain)
2003-12-05 00:35 UTC, Federico Zenith

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Zenith 2003-12-04 02:38:02 UTC
I was trying to write an ebuild for KimDaBa, part of kdeextragear-2, an image
database. A simple ebuild with no special feature failed at the beginning of
make time. However, doing the same thing manually with ./configure && make &&
make install did the trick flawlessly.
I suspect some environment variable issues.

Reproducible: Always
Steps to Reproduce:
1. Write a simple ebuild e.g. in media-gfx/kimdaba, see attachment
2 [details]. Make the digest: # ebuild /usr/portage/media-gfx/kimdaba/kimdaba-1.0.ebuild
3. emerge kimdaba

Actual Results:  
At make time, make cannot find its files and crashes instantaneously.

Expected Results:  
make should have found its files as normal.

A simple ./configure && make && make install works fine, but the emerge refuses
to function. Already tried taking out inherit kde\nneed-kde 3.1 .

General info on kimdaba from
Comment 1 Federico Zenith 2003-12-04 02:39:50 UTC
Created attachment 21682 [details]
[Buggy] Ebuild for KimDaBa
Comment 2 Paul de Vrieze (RETIRED) gentoo-dev 2003-12-04 03:20:02 UTC
Probably this ebuild does not use the standard source directory convention. Try to find out the name and set the S variable.
Comment 3 Federico Zenith 2003-12-05 00:28:12 UTC
Negative, the default S variable is correctly set. Setting another will just crash the config.
However, I managed to make it working by writing a simple src_compile():

    cd ${WORKDIR}{S}

It seems that for some reason econf gives buggy configuration, among other things not creating a kimdaba/.deps directory, which is the reason make fails.
I'll attach a new, working ebuild, output of config for ./configure and econf, and listings of the source directories after ./configure and econf.

Please test the ebuild! :-)
Comment 4 Federico Zenith 2003-12-05 00:29:30 UTC
Created attachment 21728 [details]
_Working_ ebuild for KimDaBa
Comment 5 Federico Zenith 2003-12-05 00:30:42 UTC
Created attachment 21729 [details]
Configuration output from econf

This is the output one gets when trying an emerge kimdaba with the [buggy]
Comment 6 Federico Zenith 2003-12-05 00:32:21 UTC
Created attachment 21730 [details]
Configuration output from ./configure

This is the output one gets when manually launching ./configure in the source
directory. Among other things, gcc3 seems to be detected. This configuration
results in successful execution of make later on.
Comment 7 Federico Zenith 2003-12-05 00:34:18 UTC
Created attachment 21731 [details]
File list for econf

This is how the source directory looks after an emerge kimdaba with the [buggy]
ebuild, notice how .deps directory is missing. Notice that make has _not_ been
run (that is, it has crashed immediately not finding the .deps directory)
Comment 8 Federico Zenith 2003-12-05 00:35:47 UTC
Created attachment 21732 [details]
File list for ./configure

This is how the tree looks after a successful, manual ./configure .
Notice how .deps directory is present an non-empty.
A following make will work.
Comment 9 Paul de Vrieze (RETIRED) gentoo-dev 2003-12-05 01:46:19 UTC
For one S is normally defined as S=${WORKDIR}/kimdaba-1.0, so with a correct S your compile statement should not work.

On another area. I found out why econf does not work. The package is broken. It has a --disable-dependency-tracking function, but it cannot actually work with disable dependency tracking.
Comment 10 Thomas Bettler 2005-10-31 17:32:29 UTC
KimDaBa works now in portage. 
We might close this bug. 
Comment 11 Gregorio Guidi (RETIRED) gentoo-dev 2005-11-05 10:07:08 UTC