Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 349496 - Stabilize app-admin/system-config-printer-{common,gnome}-1.3.3
Summary: Stabilize app-admin/system-config-printer-{common,gnome}-1.3.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Maciej Mrozowski
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 352952
  Show dependency tree
 
Reported: 2010-12-23 14:16 UTC by Pacho Ramos
Modified: 2011-08-10 21:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2010-12-23 14:16:32 UTC
They work fine for me since a lot of time:

Portage 2.1.9.26 (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.4, glibc-2.11.2-r3, 2.6.36-ck-r4 x86_64)
=================================================================
System uname: Linux-2.6.36-ck-r4-x86_64-AMD_Athlon-tm-_64_Processor_3200+-with-gentoo-1.12.14
Timestamp of tree: Wed, 22 Dec 2010 17:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11-r1
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages multilib-strict news parallel-fetch protect-owned sandbox sfperms sign split-log strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org 		http://ftp.ussg.iu.edu/linux/gentoo 		http://mirror.ovh.net/gentoo-distfiles/ 		http://ftp.heanet.ie/pub/gentoo/ 		http://gentoo-euetib.upc.es/mirror/gentoo/ 		http://ftp.udc.es/gentoo/ 		http://darkstar.ist.utl.pt/gentoo/"
LANG="es_ES.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/local/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 applet avahi bash-completion berkdb branding bzip2 cairo cdda cddb cdinstall cdr cdrom cleartype cli consolekit cracklib crypt css cups cxx daap dbus djvu dri dts dvd dvdr dvi eds emboss encode evo exif fam fat ffmpeg firefox flac fortran fuse gdbm gdu gif git gnome gnome-keyring gpm gstreamer gtk hddtemp iconv java jpeg kpathsea latex lcdfilter lcms libnotify lm_sensors lyx lzma mad mikmod mmx mmxext mng modules mono mp3 mp4 mpeg mudflap multilib musicbrainz nautilus ncurses network network-cron nls nptl nptlonly ntfs nvidia ogg opengl openmp pam pango pch pcre pdf perl png policykit ppds pppd python qt3support qt4 readline reiserfs scanner sdl session spell sse sse2 sse3 ssl startup-notification subversion svg sysfs t1lib tcpd test threads tiff truetype unicode usb v4l2 vcd vorbis webkit x264 xattr xcb xml xmp xorg xpm xulrunner xv xvid zeroconf zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Thanks

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2011-03-07 10:19:58 UTC
1.2.5 was dropped, I couldn't test newer versions as they need cups-1.4 (that I don't know when will be stabilized)
Comment 2 Pacho Ramos gentoo-dev 2011-06-19 10:15:55 UTC
As older versions were dropped, we will need to stabilize 1.3.3
Comment 3 Maciej Mrozowski gentoo-dev 2011-06-20 17:33:48 UTC
Yes, I dropped <1.3.3 purposely - they wouldn't be stabilized anyway because of cups-1.4 dependency. But now with cups-1.4 no longer needed for 1.3.3...

(removing dependency on 333781)
Comment 4 Pacho Ramos gentoo-dev 2011-07-15 11:50:24 UTC
Are you ok with stabilizing 1.3.3?
Comment 5 Maciej Mrozowski gentoo-dev 2011-07-15 12:02:19 UTC
Hmm, I have upgraded to cups-1.4 long time ago so cannot fully verify whether this SCP actually works well with 1.3.
If you use it and it works well, then we can proceed.
Comment 6 Pacho Ramos gentoo-dev 2011-07-15 16:20:43 UTC
I also use this with cups-1.4 as it was stabilized some time ago on amd64, I can make this depend on cups stabilization bug to be more sure about this working properly :-/
Comment 7 Andreas K. Hüttel gentoo-dev 2011-07-16 11:16:45 UTC
(In reply to comment #5)
> Hmm, I have upgraded to cups-1.4 long time ago so cannot fully verify whether
> this SCP actually works well with 1.3.
> If you use it and it works well, then we can proceed.

How about you just let it depend on cups-1.4 then? After all cups-1.4 is now stable on most arches (probably on all relevant here?)...
Comment 8 Maciej Mrozowski gentoo-dev 2011-07-16 12:50:03 UTC
Ah, I was using ~arch version of cups and I missed cups 1.4 stabilization it seems... well, in such case there's no need really to allow 1.3 hence I have raise dependencies again.
(I was under impression that cups 1.4 stabilization is unreachable in finite time so when cups-1.3 support arrived in system-config-printer, I have dropped version deps on cups in order not to depend on cups-1.4 stabilization)

system-config-printer is a desktop application and relevant desktop architectures have cups-1.4 stable already.
Comment 9 Andreas K. Hüttel gentoo-dev 2011-07-17 08:44:09 UTC
As of comment #4 by Pacho and comment #8 by Maciej: Arches, please do.

Target:
app-admin/system-config-printer-common-1.3.3: alpha amd64 ia64 ppc sparc x86
app-admin/system-config-printer-gnome-1.3.3: amd64 x86

Note: for ia64 and sparc, cups-1.4 needs to be stabilized first.
Comment 10 Agostino Sarubbo gentoo-dev 2011-07-17 11:33:31 UTC
@arch teams:

Please test also =dev-python/pycups-1.9.57 is pulled in.
Comment 11 Agostino Sarubbo gentoo-dev 2011-07-17 12:39:31 UTC
compile ok, no hw to test it.
Comment 12 Pacho Ramos gentoo-dev 2011-07-17 13:14:31 UTC
Adding more arches as we want to remove gnome-cups-manager and all of them have it stable, if they don't mind losing their stable keyword, feel free to unCC
Comment 13 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2011-07-18 08:52:24 UTC
ppc/ppc64 stable
Comment 14 Markus Meier gentoo-dev 2011-07-19 19:45:01 UTC
x86 stable
Comment 15 Markos Chandras (RETIRED) gentoo-dev 2011-07-24 09:49:34 UTC
amd64 done. Thank you all
Comment 16 Raúl Porcel (RETIRED) gentoo-dev 2011-08-07 14:55:27 UTC
alpha/ia64/sparc stable
Comment 17 Markus Meier gentoo-dev 2011-08-10 21:21:56 UTC
arm stable, all arches done.