Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 34928 - xine-ui-0.9.22 build fails
Summary: xine-ui-0.9.22 build fails
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-02 14:51 UTC by Leif Sandstede
Modified: 2003-12-08 13:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leif Sandstede 2003-12-02 14:51:31 UTC
This is the compiler output I get when I try to build xine-ui(even by hand):

main.c: In function `event_listener':
main.c:837: `XINE_EVENT_SPU_BUTTON' undeclared (first use in this function)
main.c:837: (Each undeclared identifier is reported only once
main.c:837: for each function it appears in.)
main.c:839: `xine_spu_button_t' undeclared (first use in this function)
main.c:839: `spubtn' undeclared (first use in this function)
main.c:839: parse error before ')' token
main.c:1050: structure has no member named `mute'
make[4]: *** [main.o] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory
`/var/tmp/portage/xine-ui-0.9.22/work/xine-ui-0.9.22/src/xitk'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
`/var/tmp/portage/xine-ui-0.9.22/work/xine-ui-0.9.22/src/xitk'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/xine-ui-0.9.22/work/xine-ui-0.9.22/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/xine-ui-0.9.22/work/xine-ui-0.9.22'
make: *** [all] Error 2

!!! ERROR: media-video/xine-ui-0.9.22 failed.
!!! Function src_compile, Line 51, Exitcode 2
!!! (no error message)

Reproducible: Always
Steps to Reproduce:
1.emerge rsync
2.emerge xine-ui
3.

Actual Results:  
build failed


Portage 2.0.49-r15 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r3, 2.4.22-pre3-ac1)
=================================================================
System uname: 2.4.22-pre3-ac1 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.4.3.10p1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -O3 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="sandbox ccache autoaddcvs"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo
ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo
http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/
ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 oss apm avi crypt cups encode foomaticdb gif jpeg gnome libg++ mad
mikmod mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv zlib
alsa gdbm berkdb slang readline arts tetex aalib nas svga java guile X sdl gpm
tcpd pam libwww ssl perl python esd imlib oggvorbis gtk qt kde motif opengl
mozilla cdr moznocompose moznoirc radeon ruby tcltk tiff usb"
Comment 1 Martin Holzer (RETIRED) gentoo-dev 2003-12-07 17:48:47 UTC
which version of xine-lib is installed ?
Comment 2 Leif Sandstede 2003-12-07 23:29:19 UTC
The latest xine-lib 1-rc2
xine-ui 0.9.21 still works fine with the new lib version though.
Comment 3 Martin Holzer (RETIRED) gentoo-dev 2003-12-08 13:01:21 UTC
closing since your already created a bug upstream

http://sourceforge.net/tracker/index.php?func=detail&aid=851763&group_id=9655&atid=109655