Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 348587 - dev-lang/yasm-1.1.0 fails to build with >=dev-python/cython-0.14
Summary: dev-lang/yasm-1.1.0 fails to build with >=dev-python/cython-0.14
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: AMD64 Project
URL: http://codespeak.net/pipermail/cython...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-13 06:34 UTC by Robert Cabrera
Modified: 2010-12-25 05:30 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (yasm.log,50.63 KB, text/plain)
2010-12-13 14:36 UTC, Fernando (likewhoa)
Details
yasm-1.1.0-cython-0.14.patch (yasm-1.1.0-cython-0.14.patch,672 bytes, patch)
2010-12-24 23:46 UTC, Arfrever Frehtes Taifersar Arahesis (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cabrera 2010-12-13 06:34:16 UTC
dev-lang/yasm-1.1.0 crashes during compile stage of emerge on my ~x86 laptop with the following error msg:

  File "/usr/lib/python2.7/site-packages/Cython/Compiler/TypeSlots.py", line 100, in fixed_arg_type
    return self.format_map[self.fixed_arg_format[i]]
KeyError: 'T'
make[2]: *** [yasm_python.c] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
emake failed
 * ERROR: dev-lang/yasm-1.1.0 failed:
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 4959:  Called _eapi2_src_compile
 *     ebuild.sh, line  654:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 * 
 * If you need support, post the output of 'emerge --info =dev-lang/yasm-1.1.0',
 * the complete build log and the output of 'emerge -pqv =dev-lang/yasm-1.1.0'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/yasm-1.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/yasm-1.1.0/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/yasm-1.1.0/work/yasm-1.1.0'

>>> Failed to emerge dev-lang/yasm-1.1.0, Log file:

>>>  '/var/tmp/portage/dev-lang/yasm-1.1.0/temp/build.log'


Reproducible: Always

Steps to Reproduce:
1. emerge -1av yasm
2. build crashes
3.

Actual Results:  
See above error message.

Expected Results:  
complete compilation

emerge --info
Portage 2.2.0_alpha7 (default/linux/x86/10.0/desktop/kde, gcc-4.5.1, glibc-2.12.1-r3, 2.6.36-zen1 i686)
=================================================================
System uname: Linux-2.6.36-zen1-i686-Intel-R-_Pentium-R-_M_processor_2.26GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 12 Dec 2010 18:45:02 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python:     2.7.1, 3.1.3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo portage
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/config/kdm /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/skel /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=native -pipe"                                                                            
GENTOO_MIRRORS="http://gentoo.netnitco.net http://gentoo.osuosl.org/ http://gentoo.mirrors.tds.net/gentoo http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.wetzlmayr.com/ http://osmirrors.cerias.purdue.edu/pub/gentoo/ http://www.cyberuse.com/gentoo/ http://gentoo.mirrors.hoobly.com/ ftp://gentoo.imj.fr/pub/gentoo/ http://130.59.10.35/ftp/mirror/gentoo/"                                                             
LANG="en_US.UTF-8"                                                                                          
LC_ALL=""                                                                                                   
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                           
LINGUAS="en en_US"                                                                                          
MAKEOPTS="-j1 -s"                                                                                           
PKGDIR="/usr/portage/packages"                                                                              
PORTAGE_CONFIGROOT="/"                                                                                      
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="S3TC X a52 aac aalib acl acpi addressbook alsa amr apm audiofile autoipd avahi bash-completion berkdb binary-drivers binfilter bittorrent bluetooth bonjour branding bzip2 cairo cdda cddb cdinstall cdio cdparanoia cdr chm cli clucene connection-sharing consolekit contrast cracklib crypt cups custom-cflags custom-cpuopts custom-optimization cxx dbus dc1394 dell designer-plugin desktopglobe dga dhcpcd dirac djvu dri dts dv dvb dvd dvdr ebook editor eix emboss emovix enca encode exif extensions faac faad fam fbcon fbcondecor fbsplash ffmpeg firefox firefox3 fits flac flash fortran ftp gallium gcj gcrypt gd gdbm geolocation ggi gif gimp git glibc-omitfp gmm gmp gnutls google-gadgets gphoto2 gpm graphite graphviz groupwise gsm gtk hal handbook httpd hyperestraier iconv id3tag ieee1394 imagemagick imlib indi inotify iodbc ipod ipv6 jabber jack java javascript jbig jce jingle joystick jpeg jpeg2k kate kde kerberos kig-scripting kipi konqueror ladspa lame laptop lastfm latex lcms ldap libass libcaca libnotify libproxy libsamplerate libtiger libv4l libv4l2 live lm_sensors lto lua lzma lzo mad matroska md5sum mdnsresponder-compat meanwhile mikmod mjpeg mmx mng modplug modules mozilla mp3 mp3tunes mp4 mpeg mplayer msn mtp mudflap musepack musicbrainz ncurses network networkmanager nls nova npp nptl nptlonly nsplugin ntfs nut objc objc++ objc-gc odbc offensive ogg openal openexr opengl openmp optimization optimized-qmake oscar otr pam pango pch pcmcia pcre pdf perl plasma pm-utils pmu png pnm policykit ppds ppp pppd pvr python python3 qalculate qt-faststart qt3support qt4 quicktime qwt radio raw rdp readline reports resolvconf rle rss rtmp rtsp samba sasl scanner schroedinger sdl sdl-image secure-delete semantic-desktop session shout skins skype sms sndfile solver sox speex spell sqlite sqlite3 sse sse2 ssl stable startup-notification stream strong-optimization subversion svg svga symlink sysfs system-sqlite taglib tcl tcpd teamarena templates tga themedesigner theora threads thumbnail tidy tiff timidity tremor truetype twolame udev unicode upnp usb v4l v4l2 vaapi vcd vcdx video vidix vlm vnc vorbis vpx watchdog wavpack webpresence wicd wifi win32codecs windeco winpopup wmf wpd wpg wps wxwidgets x264 x86 xanim xattr xcb xcomposite xine xinerama xml xorg xosd xulrunner xv xvid xvmc yahoo yv12 zeroconf zlib" ALSA_CARDS="intel8x0 intel8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="radeon r300" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Aleksey Frolov 2010-12-13 07:30:34 UTC
For me not compile it with USE=python.
I use python ~2.7.1
Comment 2 Aleksey Frolov 2010-12-13 07:42:41 UTC
(In reply to comment #1)
> For me not compile it with USE=python.
> I use python ~2.7.1
> 

от ~amd64
Comment 3 Aleksey Frolov 2010-12-13 07:43:25 UTC
(In reply to comment #1)
> For me not compile it with USE=python.
> I use python ~2.7.1
> 
ooops, sorry
on ~amd64
Comment 4 Fernando (likewhoa) 2010-12-13 14:34:13 UTC
confirmed here that -python works. ~amd64 here.
Comment 5 Fernando (likewhoa) 2010-12-13 14:36:29 UTC
Created attachment 257031 [details]
build.log

USE=python nls
Comment 6 Helmut Jarausch 2010-12-13 15:39:01 UTC
(In reply to comment #0)
> dev-lang/yasm-1.1.0 crashes during compile stage of emerge on my ~x86 laptop
> with the following error msg:

Here (python-2.7.1, cython-0.14_rc0 on ~amd64) I get
x86_64-pc-linux-gnu-gcc -std=gnu99  -mtune=native -O2 -msse3 -pipe  -Wl,-O1 -Wl,--as-needed -o vsyasm vsyasm.o yasm-options.o libyasm.a  
# pyxstr...
# wrote _yasm.pxi, 2188 lines
/usr/bin/python -c "from Cython.Compiler.Main import main; main(command_line=1)" \
	-o yasm_python.c yasm.pyx
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Main.py", line 790, in main
    result = compile(sources, options)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Main.py", line 765, in compile
    return compile_multiple(source, options)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Main.py", line 737, in compile_multiple
    result = run_pipeline(source, options)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Main.py", line 601, in run_pipeline
    err, enddata = context.run_pipeline(pipeline, source)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Main.py", line 240, in run_pipeline
    data = phase(data)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/ParseTreeTransforms.py", line 1025, in __call__
    return super(AnalyseDeclarationsTransform, self).__call__(root)        
  File "Visitor.py", line 272, in Cython.Compiler.Visitor.CythonTransform.__call__ (Cython/Compiler/Visitor.c:4936)
  File "Visitor.py", line 255, in Cython.Compiler.Visitor.VisitorTransform.__call__ (Cython/Compiler/Visitor.c:4696)
  File "Visitor.py", line 163, in Cython.Compiler.Visitor.TreeVisitor._visit (Cython/Compiler/Visitor.c:3254)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/ParseTreeTransforms.py", line 1033, in visit_ModuleNode
    node.analyse_declarations(self.env_stack[-1])
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/ModuleNode.py", line 64, in analyse_declarations
    self.body.analyse_declarations(env)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Nodes.py", line 346, in analyse_declarations
    stat.analyse_declarations(env)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Nodes.py", line 346, in analyse_declarations
    stat.analyse_declarations(env)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Nodes.py", line 3249, in analyse_declarations
    self.body.analyse_declarations(scope)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Nodes.py", line 346, in analyse_declarations
    stat.analyse_declarations(env)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Nodes.py", line 1999, in analyse_declarations
    self.analyse_signature(env)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/Nodes.py", line 2097, in analyse_signature
    arg.hdr_type = sig.fixed_arg_type(i)
  File "/usr/lib64/python2.7/site-packages/Cython/Compiler/TypeSlots.py", line 100, in fixed_arg_type
    return self.format_map[self.fixed_arg_format[i]]
KeyError: 'T'


I don't know if this is a cython or a yasm problem,
Helmut.
Comment 7 Robert Cabrera 2010-12-13 17:51:18 UTC
I too can confirm on my ~x86 laptop that yasm builds and installs with USE="-python" flag during emerge.

I don't know how this changes functionality or what package even brought in yasm in the first place. But it does build with -python flag.
Comment 8 Rabbe Fogelholm 2010-12-14 08:25:49 UTC
I came across this problem too when trying to emerge mplayer on Gentoo Prefix. A sufficient workaround in the Gentoo Prefix case is to put a mask "=dev-lang/yasm-1.1.0" in etc/portage/package.mask, which causes version 1.0.1 to be emerged instead.
Comment 9 Robert Cabrera 2010-12-14 22:23:20 UTC
(In reply to comment #8)
> I came across this problem too when trying to emerge mplayer on Gentoo Prefix.
> A sufficient workaround in the Gentoo Prefix case is to put a mask
> "=dev-lang/yasm-1.1.0" in etc/portage/package.mask, which causes version 1.0.1
> to be emerged instead.
> 

I don't know how new to Gentoo or Linux you are, but masking an unstable package to downgrade to a previous stable version is really not a workaround. A workaround is when you come up with a solution or method that allows the package in question to work as intended or work with some limited functionality.

Example: In comment #4 on this thread Fernando V. suggested that building with -python use flag allows yasm to compile and install. This is a workaround, as it allows the package in question to build and install. None of us know yet what effect this has on functionality, but since we're running an ~ arch this is what we are here to find out. People running ~ arches are the beta testers for those running stable arches.

All you did was downgrade to the stable version. Anyone can do this at any time to any package they so choose. In fact, sometimes you may find you have to run a stable version because it is critical for what you need to do at that time. As experienced Gentoo users we know that we can mask a package that doesn't compile or crashes, or unmask one that we'd would like to experiment with. This goes without saying. However, doing so does nothing to help in ironing out the issue(s) that's causing the problem in the first place and thus not a workaround.

I hope this clarifies things.
Comment 10 Dan Goodliffe 2010-12-16 01:17:26 UTC
I just stumbled across this myself... I found that I had upgraded cython by accident... try downgrading to dev-python/cython-0.13, yasm doesn't compile for me with 0.14.
Comment 11 Alexandre Hannud Abdo 2010-12-16 02:47:57 UTC
I run an Intel processor and noticed this problem after I upgraded to python-2.7

Not sure if it is related to the update, as I had already unmerged python-2.6 by the time.

USE=-python does let it compile fine.
Comment 12 Marijn Schouten (RETIRED) gentoo-dev 2010-12-16 11:49:23 UTC
(In reply to comment #10)
> I just stumbled across this myself... I found that I had upgraded cython by
> accident... try downgrading to dev-python/cython-0.13, yasm doesn't compile for
> me with 0.14.

I can confirm that dev-lang/yasm-1.1.0 fails to compile with cython-0.14_rc0, but compiles fine with 0.13. 

Comment 13 Rabbe Fogelholm 2010-12-16 21:09:13 UTC
(In reply to comment #9)
> (In reply to comment #8)

Oops, I realize that my comment looks silly. I was about to file a bug under Gentoo/Alt-PrefixSupport when I found that the yasm problem was already reported. In the context of applications on Gentoo Prefix that may pull in dozens of dependencies, or Gentoo Prefix itself, I tend to think of little tweaks such as changing the emerge order or inserting a mask as a "workaround" if it gets me to the goal. Not so in the case of this bug report though. Thanks for the notice.
Comment 14 Robert Cabrera 2010-12-17 06:28:23 UTC
(In reply to comment #13)
Rabbe, sorry if I came on strong this was not my intention and I don't want to discourage you. We are all trying to make Gentoo better and comments in bug reports are an important way to do so. Please keep helping with your input when you find a problem. Thanks for your comments.
Comment 15 Fernando (likewhoa) 2010-12-17 09:59:40 UTC
(In reply to comment #14)
> (In reply to comment #13)
> Rabbe, sorry if I came on strong this was not my intention and I don't want to
> discourage you. We are all trying to make Gentoo better and comments in bug
> reports are an important way to do so. Please keep helping with your input when
> you find a problem. Thanks for your comments.
> 

np, next time just try to be positive and don't across as being negative. the whole point is to encourage collaboration and communications. i know you was trying to come across positive but your words didn't, try harder as you mention. I understand your point of view but try to come across a different way next time around ;) 

Gentoo is a family so treat users like one. :)
Comment 16 Lukas Miczka 2010-12-21 19:37:01 UTC
Same problem for me on ~amd64 - yasm compiles fine with cython-0.13, with cython-0.14 no luck. Of course for 2.x branch I have set python-2.7.1.
Comment 17 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-24 23:43:10 UTC
dev-python/cython-0.14-r1 prints proper error message instead of raising exception.

Now dev-lang/yasm needs to be fixed.
Comment 18 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-24 23:46:27 UTC
Created attachment 257994 [details, diff]
yasm-1.1.0-cython-0.14.patch
Comment 19 Samuli Suominen gentoo-dev 2010-12-25 05:30:26 UTC
(In reply to comment #18)
> Created an attachment (id=257994) [details]
> yasm-1.1.0-cython-0.14.patch
> 

thanks, applied in tree

please take yasm-1.1.0-r1 with cython-0.14 when you plan to stabilize it