Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 348537 - =sys-kernel/gentoo-sources-2.6.36-r5: suspend failes due to tpm_tis
Summary: =sys-kernel/gentoo-sources-2.6.36-r5: suspend failes due to tpm_tis
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2010-12-12 17:18 UTC by Stefan Huber
Modified: 2011-02-01 15:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Huber 2010-12-12 17:18:03 UTC
Suspend (resp. hibernate) fails with this kernel version. The kernel immediately resumes from the attempt to suspend. In the kernel logs the following lines appear:

[ 8173.612038] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
[ 8173.839097] tpm_tis 00:0a: tpm_transmit: tpm_send: error -5
[ 8173.839106] legacy_suspend(): pnp_bus_suspend+0x0/0x66 returns -5
[ 8173.839109] PM: Device 00:0a failed to suspend: error -5
[ 8174.106747] PM: Some devices failed to suspend
[ 8175.395383] PM: resume of devices complete after 1288.632 msecs
[ 8175.395710] Restarting tasks ... done.

This is a regression since it worked for gentoo-sources-2.6.36-r4.

Reproducible: Always

Steps to Reproduce:
Comment 1 Stefan Huber 2010-12-13 07:30:22 UTC
Apparently related prior bugs are known since the development phase of 2.6.36. (But since gentoo-sources-2.6.36-r4 works this seems to be a new issue). See:

As reported above, removing the module tpm_tis before suspending (resp. hibernating) resolves the problem.
Comment 2 Doron Fediuck 2011-01-02 10:42:30 UTC
(In reply to comment #1)
> As reported above, removing the module tpm_tis before suspending (resp.
> hibernating) resolves the problem.

It seems that there's a nice workaround for it:
modprobe -r tpm_tis  && modprobe tpm_tis itpm=1

The itpm=1 parameter makes it work.
Comment 3 Jimmy C. Chau 2011-01-07 07:42:57 UTC
I appear to have the same problem/error on my Lenovo X301 (same error code, different numbers following pnp_bus_suspend though):
[ 8341.241285] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 8341.247119] tpm_tis 00:0a: tpm_transmit: tpm_send: error -5
[ 8341.247130] legacy_suspend(): pnp_bus_suspend+0x0/0x90 returns -5
[ 8341.247134] PM: Device 00:0a failed to freeze: error -5
[ 8341.467030] sd 0:0:0:0: [sda] Starting disk

Started consistently experiencing this after upgrading from sys-kernel/gentoo-sources-2.6.34-r12 to sys-kernel/gentoo-sources-2.6.36-r5.  

Activating the iTPM (the itpm=1 option to tpm_tis) workaround appears to fix this hibernation problem for me.  Thanks!
Comment 4 Mike Pagano gentoo-dev 2011-02-01 15:54:12 UTC
We'll track the upstream bug, it's good the workaround is working for you.