Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 348240 - gnome-base/gnome-panel 2.32.1 crashes with multiple X screens (NVIDIA)
Summary: gnome-base/gnome-panel 2.32.1 crashes with multiple X screens (NVIDIA)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-09 08:25 UTC by BoyZonder
Modified: 2011-01-15 15:12 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
modified ebuild to incorporate 'screens.patch' (gnome-panel-2.32.1.ebuild,2.48 KB, text/plain)
2010-12-09 08:26 UTC, BoyZonder
Details
patch for single-screen gnome-panel (screens.patch,4.22 KB, patch)
2010-12-09 08:28 UTC, BoyZonder
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description BoyZonder 2010-12-09 08:25:43 UTC
gnome-panel 2.32.1 crashes on X displays with multiple screens (in this case on X using 'nvidia' driver). This has been reported before and is currently open as bug 346955. However, because it is specific to gnome-panel which this other bug does not mention, I'm reporting it again.

The solution provided in this report is to install a patched version of 'gnome-panel' which is hardcoded to return '1' in place of the original calls to 'gdk_display_get_n_screens (display)'. The benefit is that multiple X screens can be used, the downside is that there is only a gnome-panel on the first screen. To use this solution, install the provided ebuild into 'gnome-base/gnome-panel' on your local overlay and the provided patch into 'gnome-base/gnome-panel/files'.

Reproducible: Always

Steps to Reproduce:
1. Upgrade to gnome-panel 2.32.1
2. Start X with multiple screens (with NVIDIA driver)
3. Witness the horror

Actual Results:  
gnome-panel does not start but keeps crashing, 'BadMatch' errors reported in ~/.xsession-errors

Expected Results:  
gnome-panel starts nicely on all screens

This occurs with gdk-pixbuf-2.22.1 and nvidia-drivers-260.19.*
Comment 1 BoyZonder 2010-12-09 08:26:58 UTC
Created attachment 256718 [details]
modified ebuild to incorporate 'screens.patch'
Comment 2 BoyZonder 2010-12-09 08:28:06 UTC
Created attachment 256719 [details, diff]
patch for single-screen gnome-panel

This patch returns '1' in place of calls to 'gdk_display_get_n_screens (display)'.
Comment 3 Gilles Dartiguelongue gentoo-dev 2010-12-09 13:59:06 UTC
This patch will not make it to the tree. We will not mess the code to the detriment of free driver users. This is most likely a problem in the nvidia closed source driver and there is nothing we can reasonably do about it.

Please forward your issue to upstream developers (most likely gtk+) and see if they can do something about it. You can keep us posted about this issue by adding gnome@gentoo.org to the CC list on the upstream bug report.

Thanks for reporting.
Comment 4 Ilija Hadzic 2010-12-29 13:20:29 UTC
The problem is not limited to nvidia (closed source) driver. On my system it happens with radeon (open source) driver. It's the Zaphod mode that is
affected from what I can see. 

(In reply to comment #3)
> This patch will not make it to the tree. We will not mess the code to the
> detriment of free driver users. This is most likely a problem in the nvidia
> closed source driver and there is nothing we can reasonably do about it.
> 
> Please forward your issue to upstream developers (most likely gtk+) and see if
> they can do something about it. You can keep us posted about this issue by
> adding gnome@gentoo.org to the CC list on the upstream bug report.
> 
> Thanks for reporting.
> 

Comment 5 Ilija Hadzic 2010-12-29 13:48:15 UTC
I should also say that the patch has made the Zaphod mode quite useless, since
there is no panel on any screen but screen #1, so it's very difficult to lauch
anything on other screens. This patch is only to stop the panel from crashing, 
until the more permanent fix is available. 

BTW, my primary suspects are either xorg-server or gnome-panel


(In reply to comment #4)
> The problem is not limited to nvidia (closed source) driver. On my system it
> happens with radeon (open source) driver. It's the Zaphod mode that is
> affected from what I can see. 
> 
Comment 6 Gilles Dartiguelongue gentoo-dev 2010-12-29 15:06:23 UTC
I'm running zaphod mode on a r200 with the open source driver and I can't see this problem so...
Comment 7 Ilija Hadzic 2010-12-29 16:01:23 UTC
Well, I didn't have the problem either, until I updated the whole system 
a few days ago (emerge --update --newuse --deep world). I am using RV730 
GPU, but I also tried on two Evergreens I have (Juniper and Cypress) 
and the problem is visible on all cards. I don't have an R200 handy, but I 
don't think the problem has anything to do with the hardware (like 
I said, I suspect it's somewhere between the window manager and X server). 

Below is the error that I am getting (they just keep rolling forever 
until X is killed). My gnome-base/gnome is 2.32.0 (with packages in its dependency tree up-to-date), gnome-base/gnome-panel is 2.32.1 and x11-base/xorg-server is 1.9.2.902.

Error cut-and-paste:
--------------------
The program 'gnome-panel' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 857 error_code 8 request_code 7 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(gnome-panel:1596): GConf-WARNING **: Directory `/apps/panel/toplevels/bottom_panel_screen3/screen' was not being monitored by GConfClient 0x9993320

(gnome-panel:1596): GConf-WARNING **: Directory `/apps/panel/toplevels/top_panel_screen3/screen' was not being monitored by GConfClient 0x9993320

(gnome-panel:1596): GConf-WARNING **: Directory `/apps/panel/toplevels/bottom_panel_screen2/screen' was not being monitored by GConfClient 0x9993320

(gnome-panel:1596): GConf-WARNING **: Directory `/apps/panel/toplevels/top_panel_screen2/screen' was not being monitored by GConfClient 0x9993320
Comment 8 Ilija Hadzic 2010-12-29 17:18:30 UTC
FWIW, I have just tired to back up gnome-panel to version 2.30.2 and the problem
went away. Acknowledged or not, 2.32.1 definitely has an issue. 
Comment 9 qdii 2011-01-15 15:12:47 UTC
Hello. 
I think I am having the same bug.
I opened http://bugs.gentoo.org/show_bug.cgi?id=348253 with a callstack, if it helps anyone.