Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 34791 - chroot gives "Invalid Instruction" inside Virtual PC on MacOSX
Summary: chroot gives "Invalid Instruction" inside Virtual PC on MacOSX
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Release Team
Depends on:
Reported: 2003-11-30 18:59 UTC by Yancey Yeargan
Modified: 2004-03-15 11:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Yancey Yeargan 2003-11-30 18:59:37 UTC
While attempting to install gentoo 1.4 from "live" CD, I get stopped at the 
part where one is meant to chroot into the new environtment. Everytime I 
attempt to execute chroot /mnt/gentoo /bin/bash, I only get the 
response "Invalid Instruction".

Reproducible: Always
Steps to Reproduce:
1. Boot Virtual PC with Gentoo live CD.
2. Follow install to step 6a.
3. Issue "chroot /mnt/gentoo /bin/bash" command.

Actual Results:  
Message "Invalid argument" appears and the prompt returns.

Expected Results:  
The system should change root and return to a bash shell prompt.

I'm using Virtual PC 6.1 on MacOS 10.3.1 on a Titanium PowerBook G4 1 Ghz with 
1 GB RAM. I realize this is an unusual "hardware" environment which you 
probably don't have access to for testing. If you're interested in 
debugging/fixing this issue with chroot, I can offer to test for you.
Comment 1 SpanKY gentoo-dev 2003-11-30 19:57:40 UTC
what livecd version and what stage ?
Comment 2 Yancey Yeargan 2003-11-30 20:53:32 UTC
Yes, I discovered and am reporting the bug. I was using i686-1.4-20030911-cd1.iso this time.  I had tried the Pentium3 version first, but the result was the same for both.
Comment 3 Yancey Yeargan 2003-11-30 20:58:18 UTC
Oh, doesn't matter what stage.. you never get that far.

Heh.. sorry about that first bit in the last comment. I'm accustomed to the email sent from and thought the bottom part was you asking a question. I'll try to pay more attention.
Comment 4 Bob Johnson (RETIRED) gentoo-dev 2004-01-20 17:11:28 UTC
we either need to find a way to support these emulators, or take 
make a official policy of no support
Comment 5 Luca Barbato gentoo-dev 2004-01-22 00:28:02 UTC
let's support just the ones we could be sure that we can fix or make the upstream dev fix (eg bochs)
Comment 6 Emanuel Hein 2004-01-25 10:38:07 UTC
i've got the exactly the same problem but on a real PC (VIA EPIA Mainboard and C3-CPU).

I tried to install gentoo the first time (by liveCD) and a co-worker had switch off the machine while had been working.
After that I retried the installation => "Invalid Instruction"
I restarted at step 0 by deleting the partition-table but I still get the same bug.

It's the same CD it's the same stage and the harddisk should be empty
Tomorrow I'll try it with an new harddisk - maybe this will work
Comment 7 Benjamin Judas (RETIRED) gentoo-dev 2004-01-25 10:59:53 UTC
You should try blank stages, i.e. those that are compiled for 386 - especially for that via-cpu
Comment 8 John Davis (zhen) (RETIRED) gentoo-dev 2004-03-15 11:40:25 UTC
we don't currently have the hardware to test this, so I am closing it until we do.