Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 347683 - sys-libs/cracklib-2.8.18 fails to build after python update from ver 2.6 to 2.7
Summary: sys-libs/cracklib-2.8.18 fails to build after python update from ver 2.6 to 2.7
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-03 21:17 UTC by tangram
Modified: 2010-12-06 13:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
cracklib_build.log (build.log,19.03 KB, text/plain)
2010-12-03 21:19 UTC, tangram
Details
output from emerge --info (myemerge.info,3.83 KB, text/plain)
2010-12-03 21:21 UTC, tangram
Details
sys-libs/cracklib-2.8.18/temp/environment (environment,193.85 KB, text/plain)
2010-12-03 21:23 UTC, tangram
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tangram 2010-12-03 21:17:27 UTC
After dev-lang/python update from version 2.6.* to 2.7.1, sys-libs/cracklib-2.8.18 rebuild( initialized from revdep-rebuild) fails with error. Log file attached.
Comment 1 tangram 2010-12-03 21:19:10 UTC
Created attachment 256274 [details]
cracklib_build.log
Comment 2 tangram 2010-12-03 21:21:21 UTC
Created attachment 256275 [details]
output from emerge --info
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2010-12-03 21:22:40 UTC
Did you run 

  python-updater

after 2.6 -> 2.7 upgrade?
Comment 4 tangram 2010-12-03 21:23:00 UTC
Created attachment 256276 [details]
sys-libs/cracklib-2.8.18/temp/environment
Comment 5 tangram 2010-12-03 21:24:28 UTC
Yes, I did
Comment 6 tangram 2010-12-03 21:27:55 UTC
Yes, I did
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2010-12-03 21:30:14 UTC
Did you try to emerge cracklib with ccache being disabled?
Comment 8 tangram 2010-12-03 21:57:58 UTC
No, I did not. I will try to emerge without ccache enabled. Hm btw, how can I temporaryli disable ccache ? 

Comment 9 tangram 2010-12-03 22:14:50 UTC
With:
export CCACHE_DISABLE=1
emerge -v sys-libs/cracklib
same error.
Comment 10 tangram 2010-12-03 22:30:04 UTC
I was not sure whether export environment variable ( export CCACHE_DISABLE=1
) is the right way to stop using ccache. I done it with keyword FEATURES="-ccache" in my /etc/make.conf and repeated cracklib build again - without success :(
Comment 11 Alexander 2010-12-05 13:48:29 UTC
(In reply to comment #10)
> I was not sure whether export environment variable ( export CCACHE_DISABLE=1
> ) is the right way to stop using ccache. I done it with keyword
> FEATURES="-ccache" in my /etc/make.conf and repeated cracklib build again -
> without success :(
> 

Had the same error.
I ran eselect python set python2.7
And once again ran python-updater. After this cracklib successfully established.


Comment 12 tangram 2010-12-06 08:26:02 UTC
Alexander thank you very much for your very, very helpful tip.
That was it.
However, remains master know-how to me why I had to call twice python-updater.
I tell allways my wife: twice is beter then once ;) ... but this is another story.

Could someone change the bug status to solved - please.
Comment 13 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-06 13:12:39 UTC
sys-libs/cracklib-2.8.18 already has dependency on dev-python/setuptools.
Reinstall dev-python/setuptools.