Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 346877 - sys-apps/coreutils-8.7 fails tests du/long-from-unreadable, dd/skip-seek-past-dev, test-mkdirat
Summary: sys-apps/coreutils-8.7 fails tests du/long-from-unreadable, dd/skip-seek-past...
Status: RESOLVED DUPLICATE of bug 413621
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: TESTFAILURE
: 349089 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-26 18:28 UTC by Theo Chatzimichos (RETIRED)
Modified: 2015-09-28 20:27 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,706.71 KB, text/plain)
2010-11-26 18:29 UTC, Theo Chatzimichos (RETIRED)
Details
build.log for 8.9 (build.log,500.46 KB, text/plain)
2011-01-05 15:43 UTC, Theo Chatzimichos (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-11-26 18:28:22 UTC
tampakrap@homeboy ~/Source_Code/gentoo/gentoo-x86 $ emerge --info coreutils
Portage 2.2.0_alpha5 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.1, glibc-2.12.1-r3, 2.6.35-gentoo-r2 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.35-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Unknown
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.5
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo multimedia kde qting-edge jedi-mind-builds mysql
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe -ggdb"
DISTDIR="/home/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg candy distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.cc.uoc.gr/mirrors/linux/gentoo/ http://ftp.ntua.gr/pub/linux/gentoo/ http://distfiles.gentoo.org/"
LANG="en_US.utf8"
LDFLAGS="-Wl,--as-needed"
LINGUAS="en el"
MAKEOPTS="-j5"
PKGDIR="/home/portage/binaries"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/home/tampakrap/Source_Code/gentoo/gentoo-x86"
PORTDIR_OVERLAY="/var/lib/layman/multimedia /home/tampakrap/Source_Code/gentoo/kde /home/tampakrap/Source_Code/gentoo/qting-edge /home/tampakrap/Source_Code/gentoo/tampakrap /home/tampakrap/Source_Code/gentoo/mysql"
SYNC="cvs://tampakrap@cvs.gentoo.org:/var/cvsroot"
USE="64bit 7zip X X509 a52 aac aalib acl acpi addressbook akonadi alsa amd64 amr apache2 asf bash-completion berkdb bidi bluetooth branding bzip2 cairo cdda cddb cdio cdparanoia cdr cgi chm cli consolekit cpudetection cracklib crypt cups curl cvs cxx dbus directfb dmx dri dts dv dvb dvd dvdr emboss encode esd exif expat fam fame fbcon ffmpeg firefox flac foomaticdb fortran gdbm gif gimp git glitz gnutls gphoto2 gpm graphviz hal handbook hash hddtemp hpn iconv idn ieee1394 imagemagick ipod ithreads java joystick jpeg jpeg2k kde kdrive kipi kqemu kvm lame lcms ldap libcaca libnotify lirc lm_sensors lzma mad matroska mikmod mjpeg mmx mmxext mng modules mono mp3 mp4 mpeg mplayer mudflap multilib musepack mysql mysqli nas ncurses network networkmanager nfs nls nodrm npp nptl ogg openexr opengl openmp pam pango pcre pdf perl phonon php plasma png policykit ppds pppd python qt qt3support qt4 quicktime radio rar raster rdesktop readline ruby samba sasl scanner sdl semantic-desktop sensord session sftp simplexml smp sndfile snmp speex spell sql sqlite srt sse sse2 sse3 ssl ssse3 startup-notification subtitles subversion svg sysfs syslog tcpd theora threads tiff truetype unicode usb v4l v4l2 vcd vdpau vhosts vim-syntax vorbis webkit winbind wma x264 xcb xcomposite xine xinerama xml xmlreader xmlrpc xmlwriter xorg xpm xscreensaver xsl xulrunner xv xvid xvmc yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en el" LIRC_DEVICES="devinput hauppauge" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-apps/coreutils-8.6 was built with the following:
USE="acl (multilib) nls test unicode -caps -gmp (-selinux) -static -vanilla -xattr"
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-11-26 18:29:05 UTC
Created attachment 255517 [details]
build.log
Comment 2 SpanKY gentoo-dev 2010-11-26 22:45:01 UTC
the first two should have been skipped because you're running as non-root
Comment 3 Brant Gurganus 2010-11-27 09:21:37 UTC
SpanKY: What makes you think those tests should be skipped? I didn't see anything permissions related where an error occurred nor did I see anything that seemed to depend on being root in what I read of the long-from-unreadable test. Besides, neither of userpriv nor usersandbox were being used. Other tests were skipped because the user was root.

The mkdirat test is the same as other mkdirats originating with gnulib. I reported that issue earlier today as bug 346929. That's an issue related to sandbox and may be a regression since it appeared mkdirat was made to work in sandbox with bug 297026.
Comment 4 Brant Gurganus 2010-11-27 16:55:29 UTC
I just built today with FEATURES="-sandbox -usersandbox" and otherwise unchanged and tests passed, so the other issues seem sandbox related and not privilege related since the use of sandbox was the only variable I changed.
Comment 5 SpanKY gentoo-dev 2010-12-20 18:29:02 UTC
*** Bug 349089 has been marked as a duplicate of this bug. ***
Comment 6 Xake 2010-12-26 12:50:29 UTC
I do not know about the mkdirat, but I think (and think I have seen before) that something in how sandbox rewrites and resolves paths may trigger problems with long paths. The mkdirat problem I have to, maybe related to that other supposedly fixed bug about the *at functions and file descriptors that may have some problems left?

And they still apperes with 8.8 here.
Comment 7 Xake 2010-12-26 13:24:27 UTC
My preliminary tests seems to suggest that it is the adding of "pwd" (as done while resolving the path in reference to root directory) that tips the scale towards a "too long filename". Here on my computer when I try the commands outside of portage, then rm "path" works, but rm `pwd`"path" gives too long filename ()the same error as with sandbox).
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2011-01-05 01:27:33 UTC
With 8.9 only the mkdirat test fails for me.
Comment 9 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-05 15:43:47 UTC
Created attachment 258940 [details]
build.log for 8.9

confirmed, i'm attaching build.log for the record :)
Comment 10 Xake 2011-01-06 11:14:30 UTC
(In reply to comment #9)
> Created an attachment (id=258940) [details]
> build.log for 8.9
> 
> confirmed, i'm attaching build.log for the record :)
> 

FAIL: du/long-from-unreadable (exit: 1)

Did you really check your log? Remember coreutils runs tests in two stages, first is coreutils tests, the second is gnulib tests, and all the failing tests except mkdirat belongs in coreutils testsuite.


This is why you have in the end of your log:
======================================
1 of 215 tests failed
(14 tests were not run)
See gnulib-tests/test-suite.log
Please report to bug-coreutils@gnu.org
======================================

but a bit longer up you got:
======================================
3 of 355 tests failed
(87 tests were not run)
See tests/test-suite.log
Please report to bug-coreutils@gnu.org
======================================

Also if you had run thie with userprivs coreutils would not have skipped "rm/deep-2" which fails for the same reason.


This fails mostly just because coreutils testsuite evaluates the commands/functions after how much they should be able to handle, look close at the dir structure and you will see that the directory they try to remove is about "x/x/x/x/x/x/x", but the testsuite only passes "x/x" to rm depending on how long path it thinks rm can handle. And if sandbox then forces rm to get "/y/y/x/x/ when the testsuite evaluated for some reason that rm could only handle a max path of "x/x" you may see why this breaks.

So how can we fix this? Either we get the testsuite to recongize that the possible path is shorter than it thinks, or sandbox has to only evaluate if rm may remove "/y/y/x/x" and then pass "x/x" instead of "/y/y/x/x".


You can try this yourself. cd into the testdir, and look inside the log of a failing test. You will find something like "rm could not remove x/x: path too long", and run it but as "rm `pwd`/x/x" and you will get the same error. remove `pwd` and rm will work fine.
Comment 11 SpanKY gentoo-dev 2015-09-28 20:27:06 UTC
i'm going to dupe to a newer one because a bit more triaging has been done there

*** This bug has been marked as a duplicate of bug 413621 ***