Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 346539 - ALSA 1.0.23 upgrade broke previously working sound
Summary: ALSA 1.0.23 upgrade broke previously working sound
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2010-11-23 16:42 UTC by Peter
Modified: 2010-12-15 01:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2010-11-23 16:42:32 UTC
ALSA stopped working with 1.0.23.  At first I thought it was my 2.6.34-r1 kernel, but compiling a 2.6.34-r12 kernel and it still doesn't work:

I have the AC97 drivers in the kernel and note ALSA did work prior to 1.0.23

 0 [ICH5           ]: ICH4 - Intel ICH5
                      Intel ICH5 with AD1985 at irq 17

An alsa application:
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4633:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
cannot open audio device default (No such file or directory)

alsactl init
Found hardware: "ICH4" "Analog Devices AD1985" "AC97a:41445375" "0x1043" "0x80f3"
Hardware is initialized using a generic method

I did find something about this returning a 99 exit status which alsalib sees as an error.

Reproducible: Always

Steps to Reproduce:
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2010-11-24 01:43:39 UTC
Did you run alsaconf after the upgrade?

Please post your `emerge --info' in a comment while you think about an answer.
Comment 2 Peter 2010-11-24 02:01:33 UTC
I did anything that emerge mentioned I should do after the upgrade. I don't think I ran alsaconf, but I just did and it says it can't find any supported devices.  I don't think I ran alsaconf before when alsa was working.

Anyway "alsa" is in my USE flags and I think the errors I listed pretty clearly have nothing to do with that.
Comment 3 Peter 2010-11-26 17:30:07 UTC
The first thing I tried was to add my username to the audio group and there was no audio group.  I guess something deleted that group on the install.  Running alsaconf must have added that group again.  I was at first relieved, like it was something stupid, but sound still doesn't work even though applications no longer come up with the ALSA lib confmisc.c:768 cannot find card '0' errors.

I compiled the 2.6.35-r12 kernel, I tried adding SND_USB or whatever since I read somewhere sometimes its necessary for onboard sound cards, no change.

I've tried every setting, rewriting the asound.conf file.  I've set every single bar in alsamixer to 100% and umute just in case it thinks the mic is the speaker or something.

What's so insanely annoying about this is that the sound worked perfectly not a month ago and now it doesn't work at all.

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This is a bit suspicious to me, that there's two devices, but I've tried using 0 and 4 in asound.conf and neither seems to do anything.

Again, why did this work before... also frustrating is that alsaconf does nothing and that alsactl init says "Found hardware: "ICH4" "Analog Devices AD1985" "AC97a:41445375" "0x1043" "0x80f3"
Hardware is initialized using a generic method"

Why is a generic method used?  And apparently one that doesn't work...
Comment 4 Peter 2010-11-29 13:29:28 UTC
I finally got this working by muting the headphone jack sense! Which apparently now conflicts with something.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2010-12-09 19:29:48 UTC
(In reply to comment #1)
> Please post your `emerge --info' in a comment while you think about an answer.
Comment 6 Peter 2010-12-09 19:52:21 UTC
What does my emerge --info have to do with anything?  Its a bug in the alsa driver with AC97 and the info I listed in another comment that others have run into: the headphone jack mutes all the other sound?!?!?

Look, if you don't care, then just comment "don't care" and close it.  If you do care, then make a note of it somewhere or maybe there's a new version of alsa or you could email the people who handle the alsa builds.
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2010-12-15 00:03:31 UTC
If you don't provide the requested information with your bug report, then maybe you were looking to find our nice support forums or you want to do a quick check of our irc:// IRC channel to obtain support. If and when you do provide that information, then we can start using the whole of that information as a path toward solving any possible bugs that may be out there. If you refuse that information and question why you should, then perhaps using our bug tracker simply isn't for you.
Comment 8 Peter 2010-12-15 01:23:34 UTC
You idiot.

Its a minor bug with the alsa drivers with certain hardware, all of which I have provided details of. Maybe its better provided to alsa people but you're ridiculous.