Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 346257 - x11-drivers/nvidia-drivers-260.*: segmentation fault with glx applications (ex. glxinfo, glxgears)
Summary: x11-drivers/nvidia-drivers-260.*: segmentation fault with glx applications (e...
Status: RESOLVED DUPLICATE of bug 336837
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Michal Januszewski (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-21 04:49 UTC by Mike Haskell
Modified: 2010-11-25 04:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
My X.Org config file. (xorg.conf,2.53 KB, text/plain)
2010-11-21 04:51 UTC, Mike Haskell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Haskell 2010-11-21 04:49:33 UTC
Applications using hardware acceleration crash with the x11-drivers/nvidia-drivers-260.* versions. Reverting to 256.53 seems to work, at the expense of bug fixes and any improvements of newer versions, but nothing newer works.



Reproducible: Always

Steps to Reproduce:
1. emerge x11-drivers/nvidia-drivers-260.19.21 
2. eselect opengl set nvidia
3. run x session
4. execute glxinfo / glxgears / any other application using the glx api
Actual Results:  
Segmentation fault (SIGSEGV) on any application using the glx api. this is the best case scenario... so far I haven't seen full X crashes, yet.

For example:
(gdb) r
Starting program: /usr/bin/glxgears 
[Thread debugging using libthread_db enabled]
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.

Program received signal SIGSEGV, Segmentation fault.
0xb73b7265 in ?? () from /usr/lib/libnvidia-glcore.so.260.19.21
(gdb) back
#0  0xb73b7265 in ?? () from /usr/lib/libnvidia-glcore.so.260.19.21
Cannot access memory at address 0xb

$ ldd /usr/bin/glxgears
	linux-gate.so.1 =>  (0xffffe000)
	libGL.so.1 => /usr/lib/opengl/nvidia/lib/libGL.so.1 (0xb7624000)
	libm.so.6 => /lib/libm.so.6 (0xb75fe000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0xb74dc000)
	libpthread.so.0 => /lib/libpthread.so.0 (0xb74c2000)
	libc.so.6 => /lib/libc.so.6 (0xb7364000)
	libnvidia-tls.so.260.19.21 => /usr/lib/opengl/nvidia/lib/libnvidia-tls.so.260.19.21 (0xb7362000)
	libnvidia-glcore.so.260.19.21 => /usr/lib/libnvidia-glcore.so.260.19.21 (0xb5cb1000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0xb5ca1000)
	libdl.so.2 => /lib/libdl.so.2 (0xb5c9d000)
	/lib/ld-linux.so.2 (0xb7718000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb5c81000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0xb5c7d000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb5c77000)



Expected Results:  
Applications using hw acceleration/GLX should work instead of crashing, when using the newest drivers.

I'm using a vanilla kernel.

Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.4.5, glibc-2.12.1-r3, 2.6.36 i686)
=================================================================
System uname: Linux-2.6.36-i686-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 20 Nov 2010 01:45:03 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11-r1
dev-lang/python:     2.6.4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.4
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.4_p6-r1, 1.6.3-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.2-r3, 4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -mtune=core2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -mtune=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fail-clean fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.ISO-8859-1"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en es en_GB en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/portage-tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/vmware /usr/local/portage/layman/x11 /usr/local/portage/layman/wirelay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa archive async audiofile automount avahi bash-completion battstat berkdb bluetooth branding bzip2 cairo cdda cddb cdio cdparanoia cdr chroot cleartype cli consolekit cracklib crypt cscope ctypes-python cue cups curl cvs cxx dbus device-mapper dhcpcd djvu dri dts dvb dvd dvdr dvi emboss encode exif expat faac fam fat ffmpeg firefox flac fontconfig fuse gcj gd gdbm gdu gif gimp glade gmp gnome gnome-keyring gnutls gpm graphviz gs gstreamer gtk hal hardened hash hdri iconv id3 id3tag ieee1394 imagemagick imap injection iproute2 ipv6 jack java java6 javamail javascript jbig jpeg jpeg2k kdrive kvm lame laptop lastfmradio lcms ldap libcaca libffi libmms libnotify libsamplerate libv4l2 lua lzma lzo mad madwifi matroska mdnsresponder-compat mhash mikmod mjpeg mmap mmx mng modplug modules mono mp3 mp4 mpeg mudflap nautilus ncurses nethack network networkmanager nls nptl nptlonly objc objc-gc odbc offensive ogg openexr opengl openmp optimisememory pam pango pcmcia pcre pdf perl pic pidgin pie pipe pkcs11 png postproc ppds pppd profile pulseaudio python qt3support quicktime readline remote-access rtsp ruby samba sdl session shout silc smp sndfile sockets socks5 sound spell sqlite sqlite3 sse sse2 sse3 ssl ssp startup-notification stream subversion suexec svg sysfs taglib tcpd theora threads tiff tools tordns truetype twolame unicode usb utils v4l v4l2 vcd vcdx vim-pager vim-syntax vorbis wavpack win32codecs wma-fixed wmf x264 x86 xcb xine xinerama xinetd xml xmp xorg xpm xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache deflate dir disk_cache env expires ext_filter file_cache filter headers include log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling unique_id userdir usertrack vhost_alias auth_digest log_forensic version" APACHE2_MPMS="event" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en es en_GB en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa nvidia nv" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mike Haskell 2010-11-21 04:51:20 UTC
Created attachment 254977 [details]
My X.Org config file.

Added X11 config file. I added the DRI section trying to figure out if this was causing the problem, but it didn't help.

It's a dual screen setup, however this has never been a problem, provided that the installed version of the drivers works :)
Comment 2 Harris Landgarten 2010-11-22 00:32:34 UTC
Don't know if this is related but I am running 269.19.21 on multiple monitors and on my last restart Xorg was hanging after loading the nvidia driver and nothing would display. Seems like the graphics hardware locked up. After a power down and wait 30 sec everything started ok.
Comment 3 Doug Goldstein gentoo-dev 2010-11-25 04:54:31 UTC

*** This bug has been marked as a duplicate of bug 336837 ***