Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 34394 - mozilla paints whole screen (even outside it's own window)
Summary: mozilla paints whole screen (even outside it's own window)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
Depends on:
Reported: 2003-11-26 02:12 UTC by Barry Cardiff
Modified: 2004-04-07 20:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Barry Cardiff 2003-11-26 02:12:49 UTC
When I start Mozilla, it's almost OK, but just near the end of it's
initialisation the whole screen gets painted in a 'cream' colour, making the
whole system almost unsable. The Mozilla window itself is also a bit messed up,
with this 'cream' colour 'leaking' all over the icons etc. Placing the mouse
over the icons will restore (repaint) them. 
Moving the window or min/maxing it can clear part of the screen.
Mozilla itself works correctly, its just display problem.

Reproducible: Always
Steps to Reproduce:
1. emerged just enough stuff for a basic text install
2. emerge xfce4  (i.e. I never installed kde or gnome)
3. emerge mozilla

Actual Results:  
All the emerge commands worked fine, see 'details' below for description of error.

I believe this problem not to be a mozilla problem as such, as I've tried
downloading a binary verions from, and it does the same (but I know
for sure that this binary works fine on xfce4).
I am guessing that the problem is more to do a dependancy problem whereby
Mozilla relies on some kde or gnome library to be installed.
Note that haven gotten the basic text based install working I when straight for
an emerge xfce4, rather than installing gnome.
Comment 1 Barry Cardiff 2003-11-27 01:33:13 UTC
Looking into the problem a bit more it seems that the problem is data dependant, i.e. mozillla only has this problem if it accesses certain pages, and ironically, it's default homepage is one such page.
I still think this is not a mozilla bug, as there is no way it should not be able to write outside it's own window. It must be that some (external) function/library that mozilla calls while rendering this page is not installed correctly.

Comment 2 Brad Laue (RETIRED) gentoo-dev 2004-02-15 09:53:07 UTC
Are you still experiencing this?
Comment 3 Aron Griffis (RETIRED) gentoo-dev 2004-04-07 20:11:35 UTC
No response from poster (scary bug though!)