Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 343523 - kde-base/kde-l10n-de-4.4.5 fails with LINGUAS="de"
Summary: kde-base/kde-l10n-de-4.4.5 fails with LINGUAS="de"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-31 14:12 UTC by Martin Baute
Modified: 2011-05-29 21:51 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info aoutput for kde-l10n (kde-l10n.info,4.73 KB, text/plain)
2010-11-01 17:09 UTC, Paolo Barile
Details
Patch for kde4-base.eclass file to avoid patching man-kpat.6.docbook's DTD (kde4-base.eclass.patch,839 bytes, patch)
2010-11-11 02:02 UTC, David E. Narváez
Details | Diff
kde4-base.eclass patch to remove docbook upgrading (kde4-base-no-docbook-fix.patch,574 bytes, patch)
2010-11-19 05:56 UTC, David E. Narváez
Details | Diff
patch to enable dtd upgrade only outside kde-base/koffice/... (kde4-base-eclass.patch,864 bytes, patch)
2010-11-21 19:46 UTC, Andreas K. Hüttel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Baute 2010-10-31 14:12:18 UTC
Setting up a new system, using the desktop-kde profile, stable x86, and no custom USE flags. I successfully emerged kde-meta, then added LINGUAS="de" to /etc/make.conf and ran "emerge -uDN world".

kde-base/kde-l10n-de-4.4.5 fails with:

[ 89%] Generating kpat.6
man-kpat.6.docbook:43: parser error : Entity 'kpat' not defined



Reproducible: Always

Steps to Reproduce:
Comment 1 Martin Baute 2010-10-31 14:14:35 UTC
# emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0/desktop/kde, gcc-4.4.4, glibc-2.11.2-r2, 2.6.32-21-generic i686)
=================================================================
System uname: Linux-2.6.32-21-generic-i686-Genuine_Intel-R-_CPU_T2300_@_1.66GHz-with-gentoo-1.12.13
Timestamp of tree: Sun, 31 Oct 2010 07:30:20 +0000
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -mtune=generic -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -mtune=generic -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.halifax.rwth-aachen.de/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk hal iconv ipv6 jpeg kde lcms ldap libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support qt4 readline sdl session spell ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 2 Martin Baute 2010-10-31 14:15:45 UTC
# cat /var/lib/portage/world 
app-admin/syslog-ng
dev-lang/perl
dev-vcs/rcs
kde-base/kde-meta
media-gfx/gimp
net-misc/dhcpcd
net-wireless/wpa_supplicant
sys-apps/pcmciautils
sys-fs/reiserfsprogs
sys-kernel/genkernel
sys-kernel/gentoo-sources
sys-process/vixie-cron
www-client/firefox
Comment 3 Andreas Nyback 2010-10-31 18:37:42 UTC
same for me.
Fresh gentoo installation on amd64 laptop.
But LINGUAS set to swedish (sv)
Comment 4 Martin Baute 2010-10-31 20:33:45 UTC
Possibly related to #340056 ?
Comment 5 Christian D. 2010-11-01 10:05:37 UTC
Reproduced on amd64.
Fails with: LINGUAS="de en"
(obviously) compiles with: LINGUAS=""
Comment 6 Agostino Sarubbo gentoo-dev 2010-11-01 10:59:46 UTC
fail also on LINGUAS="it"

man-kpat.6.docbook:484: parser error : Entity 'kpat' not defined
>&kpat; è documentato in dettaglio nel <emphasis
       ^
man-kpat.6.docbook:485: parser error : Entity 'kpat' not defined
>Manuale di &kpat; </emphasis
                  ^
man-kpat.6.docbook:503: parser error : Entity 'kpat' not defined
>&kpat; è stato prodotto da:</para>
Comment 7 Peter Sliepenbeek 2010-11-01 13:29:16 UTC
And with LINGUAS="en en_GB nl" with the following excerpt from the log:

...
[ 46%] Generating index.cache.bz2
[ 46%] Built target kompare-handbook
Scanning dependencies of target pofiles
[ 46%] Generating ksayit.gmo
[ 46%] Generating kttsd.gmo
index.docbook:108: parser error : Entity 'kdf' not defined
e file manager is opened from the context menu, can be configured from the &kdf;
                                                                               ^
make[2]: *** [kde-l10n-en_GB-4.4.5/docs/kdeutils/kinfocenter/blockdevices/index.cache.bz2] Error 1
make[1]: *** [kde-l10n-en_GB-4.4.5/docs/kdeutils/kinfocenter/blockdevices/CMakeFiles/blockdevices-handbook.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 46%] [ 46%] Generating kmouth.gmo
Generating kmag.gmo
[ 46%] Generating kmousetool.gmo
...
Comment 8 Paolo Barile 2010-11-01 17:09:38 UTC
Created attachment 252807 [details]
emerge --info aoutput for kde-l10n

Here's my emerge --info output too.
I don't understand why in the past I was able to emerge it with the "it" LINGUAS flag , but I'm not anymore able to do it now! What's changed in the meantime in the build environment?
Comment 9 liva 2010-11-03 00:17:45 UTC
amd64 (ru)
emerge emerge kde-l10n
...
Scanning dependencies of target kpat-manpage-man-kpat
[ 90%] Generating kpat.6
man-kpat.6.Ñо подбоÑка неÑколÑкиÑat' not defined
 попÑлÑÑнÑÑ
 па
       ^
man-kpat.6.docbook:480: parser error : Entity 'kpat' not defined
>&kpat; докÑменÑиÑован в ÑооÑвеÑÑÑвÑÑÑем <emphasis
       ^
man-kpat.6.docbook:499: parser error : Entity 'kpat' not defined
>РазÑабоÑÑики &kpat;:</para>
                                ^
make[2]: *** [kde-l10n-ru-4.4.5/docs/kdegames/kpat/kpat.6] Error 1
make[1]: *** [kde-l10n-ru-4.4.5/docs/kdegames/kpat/CMakeFiles/kpat-manpage-man-kpat.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 90%] Built target konquest-handbook
[ 91%] Built target kolf-handbook
make: *** [all] Error 2
 * ERROR: kde-base/kde-l10n-4.4.5 failed:
 *   Make failed!
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3818:  Called kde4-base_src_compile
 *   environment, line 2890:  Called cmake-utils_src_compile
 *   environment, line 1070:  Called _execute_optionaly 'src_compile'
 *   environment, line  456:  Called enable_cmake-utils_src_compile
 *   environment, line 1449:  Called cmake-utils_src_make
 *   environment, line 1089:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";

USE="-handbook" emerge kde-l10n
compiles



Comment 10 Martin Baute 2010-11-05 06:03:57 UTC
I can confirm the workaround "-hanbook". But that is obviously not a solution.
Comment 11 Maxi Combina 2010-11-07 08:48:49 UTC
Same here, but with LINGUAS="ca en en_US es es_ES es_AR pt_BR it".
As a workaround I tried:
# LINGUAS="" emerge kde-l10n

and it emerged correctly.
Comment 12 David E. Narváez 2010-11-10 12:23:32 UTC
Got insight from another thread on KDE

https://bugs.kde.org/show_bug.cgi?id=256418#c3

Specifically:

> 1) Entity 'kdf' not defined
> en_GB-4.4.5/docs/kdeutils/kinfocenter/blockdevices/index.docbook -> that is a
> broken language docbook.
> 
> 2) Entity 'kpat' not defined
> We had a problem in the kde archiv with man-kpat.6.docbook switching from DTD
> 4.1 to DTD 4.2; the entity &kpat; had to be replaced with &kpatience; to make
> this docbook man page compilable. I have no idea why this was necessary,
> man-kpat.6.docbook is unchanged since < 4.0.
> 
> I have no 4.4 kde source environment available any more, so I can't dig into
> that issue further. My guess is that this is a Gentoo issue related to  mixing
> DTD 4.1/4.2

I can't check en_GB's case but investigating es' kpat man page, I discovered that line 662 on kde4-base.eclass patches docbook files to use DTD V1.1, but kpat's man page requires DTD V1.0, so after patching 
man-kpat.6.docbook it breaks.

What could be a strategy to avoid this?
Comment 13 Martin Baute 2010-11-10 12:51:10 UTC
(In reply to comment #12)
> Got insight from another thread on KDE
> 
> https://bugs.kde.org/show_bug.cgi?id=256418#c3
> 

Note the last entry to that upstream bug, by Burkhard Lueck:

> The entity &kpat; is defined in
> http://websvn.kde.org/tags/KDE/4.4.0/kdelibs/kdoctools/customization/obsolete/general.entities?view=log.
> This file with the entity was removed before 4.5.0 was released.
>
> Obviously you try to build a language from kde 4.4.5 with kdelibs >= 4.5.0. 
> Check if you have a file
> $KDEDIR/share/apps/ksgmltools2/customization/obsolete/general.entities,
> I am sure you will not find it.
>
> Closing as downstream.
Comment 14 David E. Narváez 2010-11-11 02:02:01 UTC
Created attachment 253943 [details, diff]
Patch for kde4-base.eclass file to avoid patching man-kpat.6.docbook's DTD
Comment 15 David E. Narváez 2010-11-11 02:02:55 UTC
(In reply to comment #13)
> (In reply to comment #12)
> > Got insight from another thread on KDE
> > 
> > https://bugs.kde.org/show_bug.cgi?id=256418#c3
> > 
> 
> Note the last entry to that upstream bug, by Burkhard Lueck:

That was just a wild guess and he wasn't right, that file is actually there, but I won't be updating that thread any more.

The previously attached file patches the kde4-base.eclass file so that it won't upgrade man-kpat.6.docbook files, it works for me using LINGUAS="es"

David E. Narváez 
Comment 16 Eric F. GARIOUD 2010-11-17 10:25:03 UTC
(In reply to comment #15)

> The previously attached file patches the kde4-base.eclass file so that it won't
> upgrade man-kpat.6.docbook files, it works for me using LINGUAS="es"

1/ I had the same problem with linguas_fr
2/ I applied the patch and it works with regard to the kpat entry.

However

3/ The build now fails with kresources-handbook

Scanning dependencies of target kresources-handbook
[ 91%] Generating index.cache.bz2 
index.docbook:139: element bookinfo: validity error : Element bookinfo content does not follow the DTD, expecting ((graphic | mediaobject | legalnotice | modespec | subjectset | keywordset | itermset | abbrev | address | artpagenums | author | authorgroup | authorinitials | bibliomisc | biblioset | collab | confgroup | contractnum | contractsponsor | copyright | corpauthor | corpname | edition | editor | invpartnumber | isbn | issn | issuenum | orgname | biblioid | citebiblioid | bibliosource | bibliorelation | bibliocoverage | othercredit | pagenums | printhistory | productname | productnumber | pubdate | publisher | publishername | pubsnumber | revhistory | seriesvolnums | subtitle | title | titleabbrev | volumenum | citetitle | personname | honorific | firstname | surname | lineage | othername | affiliation | authorblurb | contrib | indexterm)* , date , releaseinfo , (graphic | mediaobject | legalnotice | modespec | subjectset | keywordset | itermset | abbrev | address | artpagenums | author | authorgroup | authorinitials | bibliomisc | biblioset | collab | confgroup | contractnum | contractsponsor | copyright | corpauthor | corpname | edition | editor | invpartnumber | isbn | issn | issuenum | orgname | biblioid | citebiblioid | bibliosource | bibliorelation | bibliocoverage | othercredit | pagenums | printhistory | productname | productnumber | pubdate | publisher | publishername | pubsnumber | revhistory | seriesvolnums | subtitle | title | titleabbrev | volumenum | citetitle | personname | honorific | firstname | surname | lineage | othername | affiliation | authorblurb | contrib | indexterm)* , abstract , keywordset , (graphic | mediaobject | legalnotice | modespec | subjectset | keywordset | itermset | abbrev | abstract | address | artpagenums | author | authorgroup | authorinitials | bibliomisc | biblioset | collab | confgroup | contractnum | contractsponsor | copyright | corpauthor | corpname | date | edition | editor | invpartnumber | isbn | issn | issuenum | orgname | biblioid | citebiblioid | bibliosource | bibliorelation | bibliocoverage | othercredit | pagenums | printhistory | productname | productnumber | pubdate | publisher | publishername | pubsnumber | releaseinfo | revhistory | seriesvolnums | subtitle | title | titleabbrev | volumenum | citetitle | personname | honorific | firstname | surname | lineage | othername | affiliation | authorblurb | contrib | indexterm)*), got (title authorgroup copyright copyright legalnotice date releaseinfo keywordset abstract )
</bookinfo>
           ^
make[2]: *** [kde-l10n-fr-4.4.5/docs/kdepim/korganizer/index.cache.bz2] Error 1
make[1]: *** [kde-l10n-fr-4.4.5/docs/kdepim/korganizer/CMakeFiles/korganizer-handbook.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 91%] Built target knode-handbook
[ 91%] Built target kresources-handbook
make: *** [all] Error 2
 * ERROR: kde-base/kde-l10n-4.4.5 failed:
 *   Make failed!

Comment 17 David E. Narváez 2010-11-19 05:56:57 UTC
Created attachment 254787 [details, diff]
kde4-base.eclass patch to remove docbook upgrading

Confirmed broken emerge with LINUGAS="fr".

The problem was also traced to docbook upgrades done by the kde4-base eclass so I started to wonder if those were needed at all. I removed those lines that patch the docbook version and tried both fr and es  in LINGUAS, and both work, so I'm attaching the patch though I think there's got to be a good reason for the docbook upgrading, maybe the attached patch will break something else so use with caution.

I think we'd all like to hear from a member of the Gentoo KDE Team about this bug, in order to be able to emerge docs in any language.
Comment 18 Oleh Kravchenko 2010-11-20 07:57:56 UTC
The same error occurred with kde-base/kde-l10n-4.4.5  USE="handbook (-aqua) (-kdeenablefinal) (-kdeprefix)" LINGUAS="ru uk -ar -bg -ca -ca@valencia -cs -csb -da -de -el -en_GB* -eo -es -et -eu -fi -fr -fy -ga -gl -gu -he -hi -hr -hu -id -is -it -ja -kk -km -kn -ko -lt -lv -mai -mk -ml -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -si -sk -sl -sr -sv -tg -tr -wa -zh_CN -zh_TW" 0 kB
Comment 19 David E. Narváez 2010-11-21 18:37:39 UTC
(In reply to comment #18)
> The same error occurred with kde-base/kde-l10n-4.4.5  USE="handbook (-aqua)
> (-kdeenablefinal) (-kdeprefix)" LINGUAS="ru uk -ar -bg -ca -ca@valencia -cs
> -csb -da -de -el -en_GB* -eo -es -et -eu -fi -fr -fy -ga -gl -gu -he -hi -hr
> -hu -id -is -it -ja -kk -km -kn -ko -lt -lv -mai -mk -ml -nb -nds -nl -nn -pa
> -pl -pt -pt_BR -ro -si -sk -sl -sr -sv -tg -tr -wa -zh_CN -zh_TW" 0 kB

Does the error persists after the patch?

David E. Narváez
Comment 20 Andreas K. Hüttel gentoo-dev 2010-11-21 19:46:37 UTC
Created attachment 255059 [details, diff]
patch to enable dtd upgrade only outside kde-base/koffice/...

Unfortunately, the patching of the docbook files is needed by a lot of kde-misc packages. 

Could you please test the attached patch for kde4-base.eclass, and give feedback here?! It disables the patching for kde-base, koffice, and kdevelop - and should solve the problem.
Comment 21 David E. Narváez 2010-11-21 20:21:50 UTC
(In reply to comment #20)
> Could you please test the attached patch for kde4-base.eclass, and give
> feedback here?! It disables the patching for kde-base, koffice, and kdevelop -
> and should solve the problem.

It works for me when emerging kde-base/kde-l10n with LINGUAS="es"

David E. Narváez

Comment 22 Martin Baute 2010-11-21 21:06:56 UTC
Works for me (kde-base/kde-l10n-de-4.4.5, LINGUAS="de"). Haven't tried any other packages yet, though, so I cannot say if it broke things elsewhere.
Comment 23 Andreas K. Hüttel gentoo-dev 2010-11-24 23:57:23 UTC
Patch is committed.