Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 342921 - app-text/evince-2.30.3: Undeclared dependency on dev-perl/XML-parser
Summary: app-text/evince-2.30.3: Undeclared dependency on dev-perl/XML-parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-27 12:54 UTC by Raymond Jennings
Modified: 2010-10-27 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raymond Jennings 2010-10-27 12:54:01 UTC
Evince failed to merge, configure choked.

Manually emerging XML-Parser first fixed it.



Reproducible: Always

Steps to Reproduce:
1.  Don't emerge dev-perl/XML-Parser
2.  Emerge app-text/evince
3.

Actual Results:  
build failure, configure choked.

Expected Results:  
no build failure, and XML-Parser would be automerged as a dependency of evince.

Suggested course of action is to amend the ebuild to depend on dev-perl/XML-Parser
Comment 1 Samuli Suominen gentoo-dev 2010-10-27 13:06:47 UTC
nah, you just forgot to run "perl-cleaner --reallyall" after dev-lang/perl upgrade
evince already has the depend because it depends on intltool, and intltool depends on XML-Parser

*** This bug has been marked as a duplicate of bug 41124 ***