Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 341201 - dev-lang/php 5.3.3-r1 build fails due to outdated ssl linkage
Summary: dev-lang/php 5.3.3-r1 build fails due to outdated ssl linkage
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2010-10-16 06:54 UTC by George Papadopoulos
Modified: 2010-10-18 07:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Build log (build.log,661.34 KB, text/plain)
2010-10-16 09:50 UTC, Jakub Kowalski

Note You need to log in before you can comment on or make changes to this bug.
Description George Papadopoulos 2010-10-16 06:54:14 UTC
I get this error somewhere in the process of compilation.

/usr/lib/gcc/i686-pc-linux-gnu/4.4.3/../../../../i686-pc-linux-gnu/bin/ld: warning:, needed by /usr/lib/, may conflict with
/usr/lib/gcc/i686-pc-linux-gnu/4.4.3/../../../../i686-pc-linux-gnu/bin/ld: warning:, needed by /usr/lib/, may conflict with
Generating phar.php
/bin/sh: line 1: 14600 Segmentation fault      ` if test -x "/var/tmp/portage/dev-lang/php-5.3.3-r1/work/sapis-build/cli/sapi/cli/php"; then /var/tmp/portage/dev-lang/php-5.3.3-r1/work/sapis-build/cli/build/shtool echo -n -- "/var/tmp/p$
make: *** [ext/phar/phar.php] Error 139
 ^[[31;01m*^[[0m ERROR: dev-lang/php-5.3.3-r1 failed:
 ^[[31;01m*^[[0m   emake failed

A segmentation fault that is!! Is this a known bug??
Comment 1 Jakub Kowalski 2010-10-16 09:50:55 UTC
Created attachment 250831 [details]
Build log
Comment 2 Jakub Kowalski 2010-10-16 09:53:04 UTC
Same happens to me.

Portage (default/linux/x86/10.0, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34-gentoo-r6 i686)
                        System Settings
System uname: Linux-2.6.34-gentoo-r6-i686-Pentium_III_-Coppermine-with-gentoo-1.12.13
Timestamp of tree: Sat, 16 Oct 2010 01:45:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.65-r1
sys-devel/automake:  1.8.5-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
CFLAGS="-march=i686 -mtune=pentium3 -O2 -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=i686 -mtune=pentium3 -O2 -pipe"
FEATURES="assume-digests collision-protect distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict test unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl acpi apache2 apm atm avahi berkdb bindist bzip2 cli cracklib crypt cxx dovecot-sasl dri fortran gdbm iconv imap jpeg kerberos ldap libwww maildir mailwrapper mbox mmx mmxext modules mudflap mysql ncurses nls nptl nptlonly openmp pam pcre png pppd readline reflection samba sasl session snmp ssl sysfs tcpd truetype unicode vhosts x86 xml zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl en" PHP_TARGETS="php-5.2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 

[ebuild     U ] dev-lang/php-5.3.3-r1 [5.2.14] USE="apache2 berkdb bzip2 cgi cli crypt ctype fileinfo%* filter gd gdbm hash iconv imap json kerberos ldap mysql mysqli nls phar%* posix readline session simplexml snmp sockets ssl tokenizer truetype unicode xml xmlreader xmlwriter zlib -adabas -bcmath -birdstep -calendar -cdb -cjk -concurrentmodphp -curl -curlwrappers -db2 -dbmaker -debug -doc -embed -empress -empress-bcs -enchant% -esoob -exif -firebird -flatfile -fpm% -frontbase -ftp -gd-external -gmp -inifile -interbase -intl% -iodbc -ipv6 -kolab -ldap-sasl -libedit -mssql -mysqlnd% -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -soap -solid -spell -sqlite -sqlite3% -suhosin -sybase-ct -sysvipc -threads -tidy -wddx -xmlrpc -xpm -xsl -zip (-dbase%) (-discard-path%) (-fdftk%) (-force-cgi-redirect%) (-mcve%) (-mhash%) (-msql%) (-ncurses%*) (-pcre%*) (-reflection%*) (-spl%*) (-yaz%)"
Comment 3 Robert Peter 2010-10-16 15:44:47 UTC
There seems to be a problem when inculding libcrypto headers 0.9.8 and linking against (the build php executable segfaults as you can see).

I do not have a solution for this yet. But as a workaraound you can emerge php without crypt support (if you do not need it):

USE="-crypt" emerge php
Comment 4 George Papadopoulos 2010-10-16 17:44:45 UTC
Nope. That didn`t solve it for me!!
Comment 5 SpanKY gentoo-dev 2010-10-16 21:06:14 UTC
run `revdep-rebuild` on the ssl libraries as the emerge logs told you to
Comment 6 George Papadopoulos 2010-10-17 09:41:44 UTC
I tried revdep-rebuild on libssl, libmysqlclient, libcrypto and I still get the same error. 

I even tried 

USE="-crypt" emerge php

Any other ideas? I feel like I have a crippled system!! :-)
Comment 7 Jakub Kowalski 2010-10-18 07:15:44 UTC
I did:
revdep-rebuild -L
rm /usr/lib/
revdep-rebuild -L
rm /usr/lib/

Works ok now.

My world update script invokes revdep-rebuild and I didn't pay enough attention to openssl elog message.

Why regular revdep-rebuild isn't enough and direct indication of particular libs is needed?