Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 341127 - kde-base/kwrite-4.4.5 does not honour print settings in KDE print settings dialog
Summary: kde-base/kwrite-4.4.5 does not honour print settings in KDE print settings di...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on: cups-1.4
Blocks:
  Show dependency tree
 
Reported: 2010-10-15 14:58 UTC by Stephen Bosch
Modified: 2011-08-23 21:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Bosch 2010-10-15 14:58:56 UTC
The KDE 4 print dialog supports printing multiple pages per sheet and page ranges.

When printing from kwrite, these settings are accepted but not honoured.

Try this:

1. Open a multi-page text document with kwrite.
2. Go to File menu and choose Print...
3. Click the "Options >>" button.
4. Select a page range which is less than the total number of pages in the document.
5. Click "Print"

Kwrite will ignore your instructions and print every page of your document.

Similarly, it will refuse to panel your pages:

1. Open a multi-page text document with kwrite.
2. Go to File menu and choose Print...
3. Click the "Options >>" button.
4. Click the "Pages" tab
5. Select two or four pages per sheet
6. Click "Print"
7. Watch the full page sheets come streaming out of your printer.

I have tested this with the cups-pdf driver and with my printer, and the results are the same.

This functionality seems to work with Okular. Some people say there are big problems with printing from kate in KDE 4. I found this in the archives:

http://linux.derkeiler.com/Mailing-Lists/KDE/2009-10/msg00199.html

It's odd -- this message does not appear in the mailing list archives on the KDE website, even though this is clearly a post to the main mailing list.
Comment 1 Stephen Bosch 2010-10-15 15:00:31 UTC
Version numbers might help:

KDE 4.4.5
Kwrite 4.4.5

# emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.11.2-r0, 2.6.35-gentoo-r10 i686)
=================================================================
System uname: Linux-2.6.35-gentoo-r10-i686-Intel-R-_Pentium-R-_M_processor_2.00GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 15 Oct 2010 14:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en fr nb en_GB en_CA"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lisp /var/lib/layman/dottout /var/lib/layman/sunrise"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi aim alsa ao apm arts audiofile bash-completion berkdb branding bzip2 cairo calendar cdda cddb cdinstall cdparanoia cdr clamav cli cracklib crypt css cups curl curlwrappers cxx dbus dga dri dv dvb dvd dvdr encode exif expat fbcon festival ffmpeg firefox flac fontconfig foomaticdb fortran ftp gdbm gif gimp ginac glut gnuplot gphoto2 gpm gsm gtk hal handbook hddtemp iconv icq icu idn imagemagick imap imlib ipv6 jabber java jingle joystick jpeg jpeg2k kde kontact lame latex lcms libnotify lm_sensors mad mbrola mmx mng modules mp3 mp4 mpeg mplayer msn mudflap musicbrainz mysql ncurses nls nptl nptlonly nsplugin odbc offensive ofx ogg opengl openmp oscar oss pam pcmcia pcre pda pdf perl plasma plotutils png posix ppds pppd python qt3support qt4 raw rdesktop readline reflection samba scanner sdl session sql sse sse2 ssl startup-notification svg svga sysfs syslog tcpd theora threads tiff truetype unicode usb v4l v4l2 vcd vim-syntax vnc vorbis webkit wifi win32codecs wmf wxwidgets x264 x86 xine xinerama xinetd xorg xscreensaver xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGI# emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.11.2-r0, 2.6.35-gentoo-r10 i686)
=================================================================
System uname: Linux-2.6.35-gentoo-r10-i686-Intel-R-_Pentium-R-_M_processor_2.00GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 15 Oct 2010 14:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en fr nb en_GB en_CA"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lisp /var/lib/layman/dottout /var/lib/layman/sunrise"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi aim alsa ao apm arts audiofile bash-completion berkdb branding bzip2 cairo calendar cdda cddb cdinstall cdparanoia cdr clamav cli cracklib crypt css cups curl curlwrappers cxx dbus dga dri dv dvb dvd dvdr encode exif expat fbcon festival ffmpeg firefox flac fontconfig foomaticdb fortran ftp gdbm gif gimp ginac glut gnuplot gphoto2 gpm gsm gtk hal handbook hddtemp iconv icq icu idn imagemagick imap imlib ipv6 jabber java jingle joystick jpeg jpeg2k kde kontact lame latex lcms libnotify lm_sensors mad mbrola mmx mng modules mp3 mp4 mpeg mplayer msn mudflap musicbrainz mysql ncurses nls nptl nptlonly nsplugin odbc offensive ofx ogg opengl openmp oscar oss pam pcmcia pcre pda pdf perl plasma plotutils png posix ppds pppd python qt3support qt4 raw rdesktop readline reflection samba scanner sdl session sql sse sse2 ssl startup-notification svg svga sysfs syslog tcpd theora threads tiff truetype unicode usb v4l v4l2 vcd vim-syntax vnc vorbis webkit wifi win32codecs wmf wxwidgets x264 x86 xine xinerama xinetd xorg xscreensaver xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en fr nb en_GB en_CA" PHP_TARGETS="php-5.2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

NS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en fr nb en_GB en_CA" PHP_TARGETS="php-5.2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 2 Eric F. GARIOUD 2010-10-18 06:33:50 UTC
(In reply to comment #0)
> 1. Open a multi-page text document with kwrite.
> 2. Go to File menu and choose Print...
> 3. Click the "Options >>" button.
> 4. Select a page range which is less than the total number of pages in the
> document.
> 5. Click "Print"
> Kwrite will ignore your instructions and print every page of your document.
=====
Hi Stephen,
Sorry but I cannot reproduce this bug. I do this several times a day and it works OK under :
Kwrite 4.4.5 / KDE 4.4.5 / x86_64 Gentoo-Sources 2.6.34-r11
+ Cups 1.4.4-r2 + Hplip 3.9.12-r1 (hpijs)

AFAIK : Until we get qt 4.7 which is said handling the page selection itself, page selection should be done by cups. (As in kde3)
=> For my 2cts : Either you get a problem with cups or you do not get the hack that allows kwrite to use cups for page selection.
Comment 3 Stephen Bosch 2010-10-18 07:01:01 UTC
(In reply to comment #2)

Hi Eric,

> Hi Stephen,
> Sorry but I cannot reproduce this bug. I do this several times a day and it
> works OK under :
> Kwrite 4.4.5 / KDE 4.4.5 / x86_64 Gentoo-Sources 2.6.34-r11
> + Cups 1.4.4-r2 + Hplip 3.9.12-r1 (hpijs)
> 
> AFAIK : Until we get qt 4.7 which is said handling the page selection itself,
> page selection should be done by cups. (As in kde3)
> => For my 2cts : Either you get a problem with cups or you do not get the hack
> that allows kwrite to use cups for page selection.

You're using an unstable cups (1.4.4-r2). I am on the stable version (1.3.11-r2), where this does not work. Considering that other KDE apps (such as Okular) do work, it's hard not to think of this as kwrite bug.

Either that, or it's a cups bug, until 1.4.4-r2 goes stable...

Comment 4 Eric F. GARIOUD 2010-10-18 07:51:53 UTC
(In reply to comment #3)
> You're using an unstable cups (1.4.4-r2). I am on the stable version

Indeed! But this was my only solution to workaround a bug I had with printing when upgrading to kde 4.4.5

> ...Considering that other KDE apps (such as
> Okular) do work, it's hard not to think of this as kwrite bug.
> Either that, or it's a cups bug, until 1.4.4-r2 goes stable...

Well, I hope gentoo kde team will be able to bring a more official light on this problem and help you solve it.
As an ordinary user, all I can do is put the following page to your information, see item 3 in :
http://linux.derkeiler.com/Mailing-Lists/KDE/2009-10/msg00199.html

Good luck.
Comment 5 Andreas K. Hüttel gentoo-dev 2011-04-03 16:17:09 UTC
Here's my "official light": KDE printing support is a big mess in kde-4*. Sorry, not much we can do about that but wait for upstream...
Comment 6 Stephen Bosch 2011-04-03 20:02:58 UTC
Okay, so it has been a while since I filed this. I tried reproducing this with my current setup.

kwrite seems unable to calculate the number of pages to print. By default, You get the option of printing "1 to 1", even if the document clearly has more pages.

If you choose to print "1 to 1", then absolutely nothing happens. I suppose this is better than printing the entire document!

If you choose to print "1 to 4", say (the document I tested with probably has 12 pages or so), then lo, and behold -- it prints four pages, exactly the four pages you would expect.

If you choose to print "4 to 6", it also works.

I suppose this means that the buggy behaviour I described when I filed the bug has been fixed (somewhere), although the not printing single pages and not calculating the number of pages the file requires are almost as bothersome.

KDE and kwrite version numbers are the same. Here is my current emerge --info:

Portage 2.1.9.42 (default/linux/x86/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.38-gentoo i686)
=================================================================
System uname: Linux-2.6.38-gentoo-i686-Intel-R-_Pentium-R-_M_processor_2.00GHz-with-gentoo-1.12.14
Timestamp of tree: Sun, 03 Apr 2011 12:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 3.1.3-r1
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en fr nb en_GB en_CA"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lisp /var/lib/layman/dottout /var/lib/layman/sunrise"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi aim alsa ao apm arts audiofile bash-completion berkdb branding bzip2 cairo calendar cdda cddb cdinstall cdparanoia cdr clamav cli cracklib crypt css cups curl curlwrappers cxx dbus dga dri dv dvb dvd dvdr encode exif expat fbcon festival ffmpeg firefox flac fontconfig foomaticdb fortran ftp gdbm gif gimp ginac glut gnuplot gphoto2 gpm gsm gtk handbook hddtemp iconv icq icu idn imagemagick imap imlib ipv6 jabber java jingle joystick jpeg jpeg2k kde kontact lame latex lcms libnotify lm_sensors mad mbrola mmx mng modules mp3 mp4 mpeg mplayer msn mudflap musicbrainz mysql ncurses nls nptl nptlonly nsplugin odbc offensive ofx ogg opengl openmp oscar oss pam pcmcia pcre pda pdf perl plasma plotutils png posix ppds pppd python qt3support qt4 raw rdesktop readline samba scanner sdl session sql sse sse2 ssl startup-notification svg svga sysfs syslog tcpd theora threads tiff truetype unicode usb v4l v4l2 vcd vim-syntax vnc vorbis webkit wifi win32codecs wmf wxwidgets x264 x86 xine xinerama xinetd xorg xscreensaver xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en fr nb en_GB en_CA" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Andreas K. Hüttel gentoo-dev 2011-05-28 18:19:28 UTC
Looks like it might be related to cups-1.3.

Have you tried kde-4.6 in the meantime?
Comment 8 Stephen Bosch 2011-05-31 18:10:04 UTC
(In reply to comment #7)
> Looks like it might be related to cups-1.3.
> 
> Have you tried kde-4.6 in the meantime?

No, not yet, although it is now stable, is that correct?

I have been putting off building it because I have an IBM Thinkpad T40 which I need for school and work, and the KDE build is going to take days, and that's assuming nothing breaks.

Are you able to reproduce the page count problem?
Comment 9 Andreas K. Hüttel gentoo-dev 2011-08-23 21:40:21 UTC
Not in the tree anymore