Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 340135 - gnome-base/gvfs-1.6.3: gvfsd-obexftp segfault trying to browse phone content
Summary: gnome-base/gvfs-1.6.3: gvfsd-obexftp segfault trying to browse phone content
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on: 349474
Blocks:
  Show dependency tree
 
Reported: 2010-10-08 12:07 UTC by MJ
Modified: 2011-01-03 20:59 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MJ 2010-10-08 12:07:24 UTC
I'm trying to connect to my phone and see its filesystem throught Nautilus, as I used to do months ago.

I'm on a stable x86 gentoo, using Gnome 2.30.2

I'm using the bluetooth-applet in Gnome.
I can send files to the phone, but when I try to "explore file" nothing happens, and I can find this error in dmesg:

gvfsd-obexftp[15507]: segfault at 8 ip 08052d64 sp bfe91a30 error 4 in gvfsd-obexftp[8048000+21000]

Gvfs-1.6.4-r1 in ~ behave the same way.

Obex related software installed:
[I] app-mobilephone/obex-data-server
     Installed versions:  0.4.5
[I] app-mobilephone/obexd
     Installed versions:  0.29
[I] dev-libs/openobex
     Installed versions:  1.5

Reproducible: Always

Steps to Reproduce:
1. try to browse file on an associated phone
2. look at dmesg

Actual Results:  
Nothing happens. The phone is not mounted, and the error is shown in dmesg.

Expected Results:  
Mount the mobile phone like any other storage memory.
Comment 1 Pacho Ramos gentoo-dev 2010-10-08 17:44:23 UTC
Do you get the same segfault on a new created user account?
Comment 2 MJ 2010-10-09 08:27:36 UTC
I get it with root and a new user.

The list of associated devices is shared between users, I didn't know..


Same error ("gvfsd-obexftp[5929]: segfault at 8 ip 08052d64 sp bfa79510 error 4 in gvfsd-obexftp[8048000+21000]") got by root and test too.
Comment 3 Pacho Ramos gentoo-dev 2010-10-09 10:13:46 UTC
Then try to get a proper backtrace:
FEATURES="$FEATURES debug splitdebug" CFLAGS="-O2 -pipe -ggdb" CXXFLAGS="-O2 -pipe -ggdb" emerge -1 glib dbus dbus-glib obex-data-server bluez gtk+ gvfs bug-buddy

Then, logout and login and try to reproduce the crash, bug-buddy should then appear and guide you.
Comment 4 MJ 2010-10-09 20:55:12 UTC
I did exactly what you told me to do, but nothing different happens.

I even tried to re-emerge those packages with use-flag "debug" active, but still.. silenty segfault.
No bug-buddy pops up.

Now I can find these lines in /var/log/messages:
Oct  9 22:28:26 Celiane bluetoothd[5042]: Bluetooth deamon 4.69
Oct  9 22:28:26 Celiane bluetoothd[5043]: Starting SDP server
Oct  9 22:28:26 Celiane bluetoothd[5043]: Starting experimental netlink support
Oct  9 22:28:26 Celiane bluetoothd[5043]: Failed to find Bluetooth netlink family
Oct  9 22:28:26 Celiane bluetoothd[5043]: Failed to init netlink plugin
Oct  9 22:28:26 Celiane bluetoothd[5043]: Failed to open control socket: Protocol not supported (93)
Oct  9 22:28:26 Celiane bluetoothd[5043]: Can't init bnep module
Oct  9 22:28:26 Celiane bluetoothd[5043]: Failed to init network plugin
Oct  9 22:28:26 Celiane bluetoothd[5043]: HCI dev 0 registered
Oct  9 22:28:26 Celiane bluetoothd[5043]: HCI dev 0 up
Oct  9 22:28:26 Celiane bluetoothd[5043]: Starting security manager 0
Oct  9 22:28:26 Celiane bluetoothd[5043]: ioctl(HCIUNBLOCKADDR): Invalid argument (22)
Oct  9 22:28:26 Celiane bluetoothd[5043]: probe failed with driver input-headset for device /org/bluez/5042/hci0/dev_00_21_AB_50_05_FC
Oct  9 22:28:26 Celiane bluetoothd[5043]: probe failed with driver input-headset for device /org/bluez/5042/hci0/dev_A8_7B_39_B9_3E_5B
Oct  9 22:28:26 Celiane bluetoothd[5043]: probe failed with driver input-headset for device /org/bluez/5042/hci0/dev_A8_7E_33_1F_E2_CA
Oct  9 22:28:26 Celiane bluetoothd[5043]: Adapter /org/bluez/5042/hci0 has been enabled
Oct  9 22:29:20 Celiane kernel: [  140.029248] gvfsd-obexftp[5048]: segfault at 8 ip 08052e70 sp bfd8ad60 error 4 in gvfsd-obexftp[8048000+23000]


I have no idea where to look for further information at the moment.
Can I give you more/best info?
Comment 5 Pacho Ramos gentoo-dev 2010-11-18 21:34:27 UTC
gvfs-1.6.6 was just added to tree, please check with it. Good luck!
Comment 6 MJ 2010-11-18 23:54:40 UTC
gvfs-1.6.6 emerged, but no luck.

I still get:

[  119.361688] gvfsd-obexftp[5061]: segfault at 8 ip 08052d64 sp bff767c0 error 4 in gvfsd-obexftp[8048000+21000]
[  141.893587] gvfsd-obexftp[5065]: segfault at 8 ip 08052d64 sp bff733e0 error 4 in gvfsd-obexftp[8048000+21000]

(those two errors refers to two different attempts to browse a phone).
Comment 7 Pacho Ramos gentoo-dev 2010-11-19 08:49:07 UTC
Does any other member from Gnome team know how reporter could get a proper backtrace from gvfs-obexftp? :-/
Comment 8 Alexey 2010-12-28 20:08:22 UTC
this bug appeared gnome-base/gvfs-1.6.4-r2 to
kernel: gvfsd-obexftp[5592]: segfault at 8 ip 08053150 sp bff0a2b0 error 4 in gvfsd-obexftp[8048000+24000]
Comment 9 Gilles Dartiguelongue gentoo-dev 2010-12-29 09:26:35 UTC
*** Bug 350008 has been marked as a duplicate of this bug. ***
Comment 10 Alexey 2010-12-29 15:51:59 UTC
Ok, as bug 350008 was _resolved dublicate_ [tnx to crackie man].
There are ugly way to fix presented problem with _gvfsd-obexftp segfault_:
Install back (by masking newer versions in /etc/portage/package.mask) sys-apps/dbus-1.2.24 and dev-libs/dbus-glib-0.86 as it depend.
Well now browsing files on mobile phone works ;)
Comment 11 MJ 2010-12-29 23:23:45 UTC
Thank you.
Downgrading dbus maybe solve the problem, but I'd like to keep the current stable version of dbus (1.4.1). I don't think this bug should be marked as resolved, am I wrong?
Comment 12 Pacho Ramos gentoo-dev 2010-12-30 10:05:39 UTC
It won't be marked as resolved in that case, but would be interesting to confirm it's a dbus related problem
Comment 13 MJ 2010-12-30 14:16:01 UTC
Bad news.
Downgraded to sys-apps/dbus-1.2.24 and dev-libs/dbus-glib-0.86 and..

[   78.861504] gvfsd-obexftp[5186]: segfault at 8 ip 08052d64 sp bf901f80 error 4 in gvfsd-obexftp[8048000+21000]

Same behaviour of newer version of dbus.
Comment 15 MJ 2011-01-03 10:17:40 UTC
Syncing portage I found and emerged app-mobilephone/obexd-0.37.
Now I can browse the phone. The segfault disappeared and Nautilus come back to mounting the device.
I'm using the current version of dbus.

Should I change the bug status to fixed/upstream or somebody else is in charge of that?


Thank you to anyone.
Comment 16 Pacho Ramos gentoo-dev 2011-01-03 11:42:34 UTC
Yes, since obexd-0.37 is going stable anyway

Thanks for your testing :-)
Comment 17 Szymon Zygmunt 2011-01-03 14:02:15 UTC
(In reply to comment #15)
> Syncing portage I found and emerged app-mobilephone/obexd-0.37.
> Now I can browse the phone. The segfault disappeared and Nautilus come back to
> mounting the device.
> I'm using the current version of dbus.

Is still seagfulting for me when I try to browse my n6300. I have:

gnome-base/gvfs-1.6.4-r2
sys-apps/dbus-1.4.1
app-mobilephone/obexd-0.37

and seagfult in dmesg like:

gvfsd-obexftp[5185]: segfault at 8 ip 08052fa0 sp bfa71870 error 4 in gvfsd-obexftp[8048000+23000]



Comment 18 Pacho Ramos gentoo-dev 2011-01-03 14:08:17 UTC
(In reply to comment #17)
> (In reply to comment #15)
> > Syncing portage I found and emerged app-mobilephone/obexd-0.37.
> > Now I can browse the phone. The segfault disappeared and Nautilus come back to
> > mounting the device.
> > I'm using the current version of dbus.
> 
> Is still seagfulting for me when I try to browse my n6300. I have:
> 
> gnome-base/gvfs-1.6.4-r2
> sys-apps/dbus-1.4.1
> app-mobilephone/obexd-0.37
> 
> and seagfult in dmesg like:
> 
> gvfsd-obexftp[5185]: segfault at 8 ip 08052fa0 sp bfa71870 error 4 in
> gvfsd-obexftp[8048000+23000]
> 

Maybe you are suffering that "dbus related problem" pointed by another CCed people, have you tried to downgrade dbus as pointed before? Maybe you should open a new bug report for your problem but, if we are unable to get a proper backtrace (http://www.gentoo.org/proj/en/qa/backtraces.xml) will be really difficult to solve the problem :-(
Comment 19 MJ 2011-01-03 14:15:00 UTC
(In reply to comment #17)
> (In reply to comment #15)
> > Syncing portage I found and emerged app-mobilephone/obexd-0.37.
> > Now I can browse the phone. The segfault disappeared and Nautilus come back to
> > mounting the device.
> > I'm using the current version of dbus.
> 
> Is still seagfulting for me when I try to browse my n6300. I have:
> 
> gnome-base/gvfs-1.6.4-r2
> sys-apps/dbus-1.4.1
> app-mobilephone/obexd-0.37
> 
> and seagfult in dmesg like:
> 
> gvfsd-obexftp[5185]: segfault at 8 ip 08052fa0 sp bfa71870 error 4 in
> gvfsd-obexftp[8048000+23000]
> 

Maybe you can also try to rebuild dbus and dbus-glib.
I recompiled just them and emerged obexd.
Comment 20 Szymon Zygmunt 2011-01-03 19:41:30 UTC
(In reply to comment #18)

[...]
> Maybe you are suffering that "dbus related problem" pointed by another CCed
> people, have you tried to downgrade dbus as pointed before?

Downgrade dbus and dbus-glib as mentioned before solve this seagfult. Current stable dbus probably cause the problem.
Comment 21 Pacho Ramos gentoo-dev 2011-01-03 20:05:34 UTC
(In reply to comment #20)
> (In reply to comment #18)
> 
> [...]
> > Maybe you are suffering that "dbus related problem" pointed by another CCed
> > people, have you tried to downgrade dbus as pointed before?
> 
> Downgrade dbus and dbus-glib as mentioned before solve this seagfult. Current
> stable dbus probably cause the problem.
> 

And what about simply rebuilding latest dbus and dbus-glib?
Comment 22 Szymon Zygmunt 2011-01-03 20:20:43 UTC
(In reply to comment #21)

[...]
> > Downgrade dbus and dbus-glib as mentioned before solve this seagfult. Current
> > stable dbus probably cause the problem.
> > 
> 
> And what about simply rebuilding latest dbus and dbus-glib?

Didn't help. The same result - segfault.


Comment 23 Pacho Ramos gentoo-dev 2011-01-03 20:59:58 UTC
(In reply to comment #22)
> (In reply to comment #21)
> 
> [...]
> > > Downgrade dbus and dbus-glib as mentioned before solve this seagfult. Current
> > > stable dbus probably cause the problem.
> > > 
> > 
> > And what about simply rebuilding latest dbus and dbus-glib?
> 
> Didn't help. The same result - segfault.
> 

Go to bug 350008 then as it was related with dbus:
http://bugs.gentoo.org/show_bug.cgi?id=350008#c0
Failed to mount OBEX volume: DBus error org.freedesktop.DBus.Error.NoReply:
Message did not receive a reply (timeout by message bus)