Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339617 - xf86-video-ati-6.13.2 slow
Summary: xf86-video-ati-6.13.2 slow
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 2 votes (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-03 19:30 UTC by pavel sanda
Modified: 2015-02-22 02:14 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pavel sanda 2010-10-03 19:30:00 UTC
after upgrading from 6.13.1 to 6.13.2 my terminals became much slower when rendering text and when moving with cursor.
is this report on gentoo or should I directly go to upstream?

Reproducible: Always
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2010-10-04 10:33:36 UTC
emerge --info please. Which version of libX11 and X are you using?
Comment 2 pavel sanda 2010-10-04 11:56:16 UTC
Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.3.2, glibc-2.11.2-r0, 2.6.35-gentoo-r9 i686)
=================================================================
System uname: Linux-2.6.35-gentoo-r9-i686-Intel-R-_Core-TM-2_Duo_CPU_T9550_@_2.66GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 01 Oct 2010 17:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r3
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.67
sys-devel/automake:  1.4_p6-r1, 1.7.9-r2, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.2-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"       
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"              
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"   
GENTOO_MIRRORS="ftp://ftp.sh.cvut.cz/MIRRORS/gentoo/"
LANG="en_US"                    
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"                  
PKGDIR="/usr/portage/packages"  
PORTAGE_CONFIGROOT="/"          
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"       
PORTDIR="/usr/portage"          
PORTDIR_OVERLAY="/var/lib/layman/rebutia /usr/local/portage/layman/sunrise /usr/local/portage/layman/enlightenment /usr/local/portage"            
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa avahi berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk hal hdaps iconv ieee1394 ipv6 jbig jpeg jpeg2k laptop latex lcms lm_sensors mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support qt4 readline reflection sdl session spell sse sse2 sse3 ssl startup-notification svg sysfs tcpd threads tiff truetype unicode usb vim-syntax vorbis wifi x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 pavel sanda 2010-10-04 11:59:57 UTC
xorg-server 1.7.7-r1
libX11 1.3.4

ati radeon HD3650
Comment 4 Cyp 2010-10-07 08:02:06 UTC
My terminals were slow at one point after upgrading to 6.13.2. It doesn't seem reproducible.

I've also been experiencing some graphics corruption after upgrading. It's most reproducible in nedit, just opening nedit and typing a few characters results in very visible corruption due to the cursor not being completely erased when it moves.

xorg-server 1.9.0.901
libX11 1.3.6
OpenGL renderer string: Mesa DRI R600 (RV710 954F) 20090101  TCL DRI2
OpenGL version string: 2.0 Mesa 7.8.2
01:00.0 VGA compatible controller: ATI Technologies Inc RV710 [Radeon HD 4350] (prog-if 00 [VGA controller])
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2011-03-31 08:03:04 UTC
Hi,
Could you try latest 1.9 xorg + xf86-video-ati-6.14.1 with KMS enabled?
It should magically cure all your issues (it did for me :P).
Comment 6 pavel sanda 2011-04-12 13:10:07 UTC
the relevant bug in xorg bugzilla is still opened so i dont believe upgrade is going to do anything else than to collapse my system. since its almost impossible to downgrade back due to droppped ebuilds i'll stick to my current setup.

feel free to wontfix the bug.
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2011-04-20 22:00:45 UTC
Hm rather could you add the xorg bugzilla link here to URL field. KTHX
Comment 9 pavel sanda 2011-04-20 22:05:07 UTC
erm to url field ;)
Comment 10 Tomáš Chvátal (RETIRED) gentoo-dev 2011-04-20 22:09:08 UTC
To be honest i don't want to close the bug cause I have the same issue. :D
Comment 11 Tomáš Chvátal (RETIRED) gentoo-dev 2011-04-20 22:09:55 UTC
Btw that sluggish behaviour is not that bad so it could not be used :)
Comment 12 pavel sanda 2011-04-20 22:12:25 UTC
really depends. i lost smooth scrolling on terminal which is quite important
to quick peeking of the various listings etc.
Comment 13 Peter 2012-01-02 16:02:23 UTC
xf86-video-ati 6.14.3
xorg-server 1.11.2-r2
mesa 7.11.2

KDE is usable with desktop effects turned off, but its kind of ridiculous that its so slow.  I mean my thinkpad has faster 3d.

I've tried classic and gallium:

OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 (R420 4B4C) x86/MMX/SSE2 TCL DRI2
OpenGL version string: 1.5 Mesa 7.11.2
OpenGL extensions:

64 GLX Visuals
    visual  x   bf lv rg d st  colorbuffer  sr ax dp st accumbuffer  ms  cav
  id dep cl sp  sz l  ci b ro  r  g  b  a F gb bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------------
0x021 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x022 24 dc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x0b9 24 tc  0  24  0 r  . .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
0x0ba 24 tc  0  24  0 r  . .   8  8  8  0 .  .  0  0  0 16 16 16  0  0 0 Slow
0x0bb 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0  0  0  0  0  0 0 None
0x0bc 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0  0  0 16 16 16  0  0 0 Slow
0x0bd 24 tc  0  24  0 r  . .   8  8  8  0 .  .  0 16  0  0  0  0  0  0 0 None
0x0be 24 tc  0  24  0 r  . .   8  8  8  0 .  .  0 16  0 16 16 16  0  0 0 Slow
0x0bf 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 16  0  0  0  0  0  0 0 None
0x0c0 24 tc  0  24  0 r  y .   8  8  8  0 .  .  0 16  0 16 16 16  0  0 0 Slow

etc.

Card is Radeon x850 XT PE
Comment 14 jannis 2014-01-25 12:56:35 UTC
Is this still an issue or can it be closed? 6.13.2 is still in tree but there are newer versions marked stable for all arches that 6.13.2 is stable for.
Comment 15 pavel sanda 2014-01-25 19:32:45 UTC
not fixed, but certainly can be closed as wontfix, 6.13.1 (the version which worked) is not in tree anymore.
Comment 16 Matt Turner gentoo-dev 2015-02-22 02:14:59 UTC
There's not really anything Gentoo developers can do to solve this. Please file a bug upstream https://bugs.freedesktop.org/enter_bug.cgi?product=DRI if the problem persists.