Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339574 - Ebuild request for gradle
Summary: Ebuild request for gradle
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 7 votes (vote)
Assignee: Florian Schmaus
URL: http://www.gradle.org
Whiteboard:
Keywords:
: 492402 (view as bug list)
Depends on:
Blocks: needsGradle 556982 577726 600698
  Show dependency tree
 
Reported: 2010-10-03 11:04 UTC by Pun
Modified: 2021-06-25 10:40 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pun 2010-10-03 11:04:18 UTC
Gradle is a java build tool. http://www.gradle.org .I would try to write an ebuild for it myself but I'm not sure what is the best way to handle build systems that try to download jars from the internet.

Reproducible: Always
Comment 1 Michael Weber (RETIRED) gentoo-dev 2010-10-03 17:15:39 UTC
Hi,

you can download these .jar files as SRC_URI (and redefine src_unpack to not extract these ,jar zip files, just copy them to the desired destination) and disable the download code (if it isn't disable by the files existance).

Have a look at #gentoo-dev-help or #gentoo-sunrise on irc.freenode.net.
http://www.gentoo.org/proj/en/sunrise/

Bye
Comment 3 Assaf Berg 2011-04-11 08:15:49 UTC
The latest ebuild (currently 1.0 M2) is maintain in github: https://github.com/asssaf/portage/tree/master/dev-java/gradle-bin
Comment 4 Assaf Berg 2012-07-10 07:24:18 UTC
gradle 1.0 has been released. I think it should be included in portage.

I have a working ebuild, but it can probably be written better ( https://github.com/asssaf/portage/blob/master/dev-java/gradle-bin/gradle-bin-1.0.ebuild )
Comment 5 Patrick McMunn 2013-12-02 13:30:31 UTC
It looks like this bug should be added as a blocker for bug 421503.
Comment 6 Florian Schmaus gentoo-dev 2013-12-02 14:05:52 UTC
I started working on a gradle ebuild some time ago. You can currently find the following components/ebuilds in my overlay:

- dev-java/gradle [1]
- dev-java/gradle-bin [2]
- virtual/gradle [3]
- app-admin/gradle-eselect [4]

gradle-bin seems to work, but I haven't tested it and it may be out of date. Bootstrapping gradle with gradle is work in progress, therefore non-bin gradle is broken at the moment. The eselect module allows to switch between gradle and gradle-bin, and hopefully between different gradle slots in the future.

1: https://gitorious.org/flow-s-ebuilds/flow-s-ebuilds/source/master:dev-java/gradle
2: https://gitorious.org/flow-s-ebuilds/flow-s-ebuilds/source/master:dev-java/gradle-bin
3: https://gitorious.org/flow-s-ebuilds/flow-s-ebuilds/source/master:virtual/gradle
4: https://gitorious.org/flow-s-ebuilds/flow-s-ebuilds/source/master:app-admin/gradle-eselect
Comment 7 Tim Harder gentoo-dev 2014-03-13 19:07:07 UTC
*** Bug 492402 has been marked as a duplicate of this bug. ***
Comment 8 John J. Aylward 2014-06-23 21:05:19 UTC
(In reply to Florian Schmaus from comment #6)
> I started working on a gradle ebuild some time ago. You can currently find
> the following components/ebuilds in my overlay:
> 
> - dev-java/gradle [1]
> - dev-java/gradle-bin [2]
> - virtual/gradle [3]
> - app-admin/gradle-eselect [4]
> 
> gradle-bin seems to work, but I haven't tested it and it may be out of date.
> Bootstrapping gradle with gradle is work in progress, therefore non-bin
> gradle is broken at the moment. The eselect module allows to switch between
> gradle and gradle-bin, and hopefully between different gradle slots in the
> future.
> 

The bootstrap could possibly be handled similarly to the icedtea ebuilds where the source build depends on an existing install first (either bin or source). I'm just starting to learn gradle myself, so maybe this wouldn't be feasible.
Comment 9 Florian Schmaus gentoo-dev 2015-02-24 16:52:34 UTC
The gradle ebuilds are now available in Gentoo's Java overlay. Please report any issues here or in #gentoo-java.
Comment 10 Florian Schmaus gentoo-dev 2016-01-21 10:08:28 UTC
Someone asked in java-overlay's github issue tracker about moving gradle to the main tree and I replied with the current state: https://github.com/gentoo/java-overlay/issues/28#issuecomment-173197270
Comment 11 Larry the Git Cow gentoo-dev 2021-06-25 10:40:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e619b4bf7bdc8bdfa5757e4730fbe5241d532fa0

commit e619b4bf7bdc8bdfa5757e4730fbe5241d532fa0
Author:     Florian Schmaus <flow@gentoo.org>
AuthorDate: 2021-06-25 10:25:05 +0000
Commit:     Florian Schmaus <flow@gentoo.org>
CommitDate: 2021-06-25 10:40:19 +0000

    dev-java/gradle-bin: add 6.8.3 and 7.1, drop old
    
    Unlike the dropped 6.3 ebuild, these ebuilds only install versioned
    gradle symlinks in /usr/bin, e.g. /usr/bin/gradle-bin-7.1. The
    /usr/bin/gradle symlink is managed by app-eselect/eselect-gradle.
    
    Closes: https://bugs.gentoo.org/339574
    Signed-off-by: Florian Schmaus <flow@gentoo.org>

 dev-java/gradle-bin/Manifest                       |  3 +-
 ...adle-bin-6.3.ebuild => gradle-bin-6.8.3.ebuild} | 38 +++++++++-----
 dev-java/gradle-bin/gradle-bin-7.1.ebuild          | 61 ++++++++++++++++++++++
 3 files changed, 88 insertions(+), 14 deletions(-)