Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339079 - net-proxy/http-replicator: start script not working
Summary: net-proxy/http-replicator: start script not working
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Maurice van der Pot (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-29 07:57 UTC by Valentin Avram
Modified: 2012-05-03 18:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valentin Avram 2010-09-29 07:57:38 UTC
Hello.

There seems to be a problem in the way the init.d script tries to start http-replicator. It always reports failure to start it. Running it manually with the same parameters, as the init script would do, works fine.

Steps to reproduce:
1. Install http-replicator: emerge -av http-replicator
2. Configure it minimally in /etc/conf.d/http-replicator
3. Start it via /etc/init.d/http-replicator

Actual result:
 * Starting Http-Replicator ...
 * Failed to start Http-Replicator [ !! ] 

Expected result:
# /etc/init.d/http-replicator start
 * Starting Http-Replicator ... [ ok ]

There is a thread on forums about it, kind of old (last post: Oct 12, 2009) but it seems everybody preferred to use the workaround instead of submitting a bug: http://forums.gentoo.org/viewtopic-t-787761.html

Info about the system:
# eix -I http-replicator
[I] net-proxy/http-replicator
     Available versions:  3.0-r1 3.0-r2
     Installed versions:  3.0-r2(18:32:41 09/28/10)

# emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31.12-x86-[REMOVED] i686)
=================================================================
System uname: Linux-2.6.31.12-x86-[REMOVED]-i686-Intel-R-_Xeon-R-_CPU_E5430_@_2.66GHz-with-gentoo-1.12.13
Timestamp of tree: Tue, 28 Sep 2010 13:00:01 +0000
app-shells/bash:     4.0_p37
dev-lang/python:     2.4.6, 2.5.4-r4, 2.6.4-r1
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="[REMOVED]"
USE="apache2 berkdb bzip2 cli cracklib crypt cxx dri erandom gd gdbm iconv innodb jpeg modules mudflap ncurses nls nptl nptlonly openmp pam pcre pie pppd python readline reflection session snmp ssl sysfs tcpd tiff truetype unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_alias authz_default authn_file authz_groupfile authz_host authz_user deflate dir env expires filter headers include log_config mime negotiation rewrite setenvif unique_id" APACHE2_MPMS="prefork" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Possible solutions:
1. check the http-replicator code and fix the return code
2. add --oknodo to the start() method in the init script

Thank you for your time.
Comment 1 Valentin Avram 2011-01-31 15:47:05 UTC
Come on guys, it's been 4 (FOUR) months since i reported this bug and NOTHING has been done so far, except for assigning the bug to a retired gentoo-dev.

It's extremely easy to create a workaround in the init script, although it would be more proper to check the perl script and see why it does not return 0.

I'd be more than happy to do it myself for you, just please act like someone there is still alive. If most of the bugs get 4+ months of wait time, then where is Gentoo is going? Shouldn't Gentoo be the fastest distro out there (like the penguin species)? How about the bug-fixing being the fastest too? 4 months is definatelly not fast.
Comment 2 KillerC 2011-03-16 16:01:57 UTC
The bug may not of been closed but this issue doesn't seem to exist, startup script works fine, at least for me.
Comment 3 Christoph Junghans gentoo-dev 2012-05-03 16:44:56 UTC
Works fine for me as well.

@Valentin: Is it still valid with python-2.7?
Comment 4 Valentin Avram 2012-05-03 17:38:47 UTC
Hello.

I can confirm that using python-2.7.2 there are no more problems when starting http-replicator service on a clean install.

I don't have python-2.6 installed anywhere so test it again, so since:
- I first reported the bug in 09.2010 on python 2.6,
- the gentoo forums thread i found was about python 2.6 and last updated in 2009,
- the latest python-2.x now is python-2.7.2,
- I don't have at this moment a test-server available to crucify it,

I believe this bug can be closed. I have set it to RESOLVED / OBSOLETE.

Please close it (and add a new category for RESOLVED called "TIME FIXES EVERYTHING" - it matches more that "WORKSFORME" or "OBSOLETE" in this case).

PS. I still wonder if the problem persists on some poor-dude-server's which is stuck with python-2.6 (still stable and available in portage).

Thank you for your time.
Comment 5 Christoph Junghans gentoo-dev 2012-05-03 18:02:42 UTC
When fixing bug #315875, I will make it depend on python-2.7 only.