Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 338370 - media-video/mplayer-9999: demuxer: lavf: 'too many videopackets in the buffer' with mp4
Summary: media-video/mplayer-9999: demuxer: lavf: 'too many videopackets in the buffer...
Status: VERIFIED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-22 17:27 UTC by Hanno Zysik (geki)
Modified: 2011-04-30 10:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
mplayer debug (mplayer.debug,361.02 KB, text/plain)
2010-09-25 12:41 UTC, Hanno Zysik (geki)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Zysik (geki) 2010-09-22 17:27:16 UTC
Since I have to use mplayer trunk wrt bug 326351.

Latest Naruto episodes exhibit this problem:
http://takafansubs.com/torrents/%5BTaka%5D_Naruto_Shippuuden_178_%5B720p%5D%5BA3D1078C%5D.mp4.torrent

$ mplayer -demuxer lavfpref -xineramascreen 1 naruto/\[Taka\]_Naruto_Shippuuden_178_\[720p\]\[A3D1078C\].mp4
...
Zu viele Videopakete im Puffer: (4096 in 33229961 Bytes).
( too many videopackets in the buffer )
...

With '-demuxer mov' this does not happen.
Comment 1 Hanno Zysik (geki) 2010-09-22 17:28:41 UTC
# emerge --info
Portage 2.2_rc85 (default/linux/amd64/10.0/no-multilib, gcc-4.4.4, glibc-2.11.2-r0, 2.6.34-gentoo x86_64)
=================================================================
System uname: Linux-2.6.34-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 21 Sep 2010 17:15:03 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.67
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.34 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -mtune=core2 -march=core2 -pipe -fomit-frame-pointer -funswitch-loops"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mtune=core2 -march=core2 -pipe -fomit-frame-pointer -funswitch-loops -fvisibility-inlines-hidden"
DISTDIR="/mnt/data/distfiles"
FEATURES="assume-digests distlocks fixlafiles fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,--sort-common"
LINGUAS="de en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/data/tmp"
PORTDIR="/mnt/data/portage"
PORTDIR_OVERLAY="/usr/local/src/java-overlay /usr/local/src/portage /usr/local/src/mozilla-overlay"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="aac alsa amd64 apache2 avi berkdb bitmap-fonts bzip2 cairo cdr cups custom-cflags custom-cxxflags dbus dts dvd dvdr gd gif glx gpm hardenedphp imap imlib ipv6 java6 jpeg jpeg2k libnotify mad mmx mmxext mp3 mpeg mysql nls nptl nsplugin nvidia ogg oggvorbis opengl openssl pam perl png python3 sse sse2 sse3 ssl svg theora threads truetype truetype-fonts type1-fonts unicode usb vhosts videos vorbis x264 xinerama xml xulrunner xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="empty plug" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="ptp2 sonydscf1 sonydscf55" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Hanno Zysik (geki) 2010-09-25 12:41:51 UTC
Created attachment 248592 [details]
mplayer debug

output of:
mplayer -msglevel demuxer=9:ds=9 -xineramascreen 1 naruto/\[Taka\]_Naruto_Shippuuden_178_\[720p\]\[A3D1078C\].mp4 >/tmp/mplayer.debug

Nothing really new but it just fills the buffer and boom. :)
Comment 3 Reimar Döffinger 2010-09-25 13:02:25 UTC
ffplay does not play the audio either, so it is a libavformat bug and should be reported to FFmpeg upstream instead.
Comment 4 Hanno Zysik (geki) 2010-09-25 13:43:13 UTC
reported here: https://roundup.ffmpeg.org/issue2246
Comment 5 Hanno Zysik (geki) 2011-04-30 10:20:43 UTC
Well, looks like a bad encoding.