Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 337953 - Epson Inkjet Printer Driver (ESC/P-R) for Linux ebuild request
Summary: Epson Inkjet Printer Driver (ESC/P-R) for Linux ebuild request
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Mike Gilbert
Whiteboard: [sunrise-overlay]
Keywords: EBUILD, InOverlay
: 500234 (view as bug list)
Depends on:
Blocks: printer-drivers
  Show dependency tree
Reported: 2010-09-18 15:13 UTC by niogic
Modified: 2015-01-15 04:26 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---

net-print/epson-inkjet-printer-escpr-1.0.1.ebuild (epson-inkjet-printer-escpr-1.0.1.ebuild,680 bytes, text/plain)
2010-11-19 17:10 UTC, Thomas Kuther
net-print/epson-inkjet-printer-escpr-1.0.1.ebuild (epson-inkjet-printer-escpr-1.0.1.ebuild,658 bytes, text/plain)
2010-11-19 17:25 UTC, Thomas Kuther
ebuild for 1.0.2, ~x86 works (epson-inkjet-printer-escpr-1.0.2.ebuild,663 bytes, text/plain)
2011-03-21 19:19 UTC, daid kahl
Updated ebuild file (epson-inkjet-printer-escpr-1.1.1.ebuild,558 bytes, text/plain)
2012-01-07 23:25 UTC, Moritz Schlarb
ebuild for 1.4.0 (epson-escpr-1.4.0.ebuild,473 bytes, text/plain)
2014-07-19 16:06 UTC, Sam Jorna (wraeth)
New ebuild for v1.4.1 (epson-inkjet-printer-escpr-1.4.1.ebuild,564 bytes, text/plain)
2014-08-12 09:51 UTC, sphakka

Note You need to log in before you can comment on or make changes to this bug.
Description niogic 2010-09-18 15:13:58 UTC

The project is GPL and it provides the printer drivers for some epson printers.
I can't print without it (i hope i can with it!!)

Sources (rpms..) here:

Anyone want to make an ebuild? :)
Comment 1 Thomas Kuther 2010-11-19 17:10:07 UTC
Created attachment 254849 [details]

As a start.. a proposed ebuild. ~amd64 tested.
Comment 2 Thomas Kuther 2010-11-19 17:25:24 UTC
Created attachment 254851 [details]

removed useless cutils dep.
Comment 3 daid kahl 2011-03-21 19:19:22 UTC
Created attachment 266761 [details]
ebuild for 1.0.2, ~x86 works
Comment 4 sphakka 2011-03-31 17:26:40 UTC
Hi there,
thanks for this ebuild: 1.0.2 also works with my Stylus SX620FW on ~amd64 :-)


Comment 5 Moritz Schlarb 2011-04-29 20:35:49 UTC
I can confirm it working with an Epson Stylus SX405 on ~x86, although system-config-printer gives me a warning about a missing program "epson-escpr-wrapper", which is installed to /usr/libexec/cups/filter/epson-escpr-wrapper.
Propably system-config-printer just doesn't know to search i that path, but that would be another bug.
Comment 6 Elfenbein, Karsten 2011-06-25 09:14:33 UTC
the "ebuild for 1.0.2, ~x86 works" file should be 1.0.3 by now as upstream has a new version

also works on ~amd64 with a BX305FW
Comment 7 renato gallo 2011-07-13 06:07:31 UTC
i restarted cups several times but I cannot find the printer in list 
Bus 002 Device 011: ID 04b8:084a Seiko Epson Corp. 
epson sx405

Add Printer
Local Printers: 	
CUPS-PDF (Virtual PDF Printer)
Samsung CLP-310 Series (Samsung CLP-310 Series)
---->no epson here.....

which device uri do you use ?

emerge --info
Portage (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.12.2-r0, 2.6.39-gentoo-r2 x86_64)
System uname: Linux-2.6.39-gentoo-r2-x86_64-Intel-R-_Core-TM-_i5_CPU_760_@_2.80GHz-with-gentoo-2.0.2
Timestamp of tree: Sun, 10 Jul 2011 18:15:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.25-r2
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.65-r1
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82
sys-kernel/linux-headers: (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo vmware zugaina sunrise
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/vmware /var/lib/layman/zugaina /var/lib/layman/sunrise"
USE="X a52 aac aalib acl alsa amd64 atmo auto-hinter avahi bash-completion berkdb bidi bittorrent bluetooth bzip2 cairo cdda cddb cdr cjk cli cracklib crypt cups curl cxx dbus dc1394 desktopglobe dga dirac directfb djvu dri dts dvb dvd eds encode esd examples exif extras fbcon ffmpeg flac fluidsynth fontconfig fontforge foomaticdb fortran gd gdbm ggi gif gimp gme gnome gnutls gphoto2 gpm gstreamer gtk hal-info httpd iconv id3tag ieee1394 ipv6 java jce jpeg jpeg2k kate kde lame lapack lcms ldap libass libcaca libnotify libproxy libtiger libv4l2 lirc live lua lzma mad matroska mdnsresponder-compat mmx mng modplug modules mp3 mpeg mtp mudflap multilib musepack mythtv ncurses nls nptl nptlonly nsplugin nspluginwrapper odbc odk ogg openexr opengl openmp optimisememory oss pam pango pasteafter pcre pdf perl php plasma png policykit ppds pppd projectm ps pvr python qalculate qt3support qt4 qwt raw readline remoteosd romio rtsp run-as-root samba schroedinger scim screensaver script sdk sdl sdl-image semantic-desktop session shine shout skins slp smbsharemodes smp speex sqlite sse sse2 ssl stream svg swat sysfs system-libvncserver taglib tcpd templates theora tiff tilepath tk tools truetype truetype-debugger twolame type3 udev unicode upnp usb utils v4l2 vaapi vcdx vdpau vix vlm vmware_guest_freebsd vmware_guest_linux vmware_guest_netware vmware_guest_solaris vmware_guest_winPre2k vmware_guest_windows vorbis webkit winbind wma-fixed wmf x264 xml xorg xosd xv zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2 adc65 agfa_cl20 aox ax203 barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 jl2005a kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 st2205 stv0674 stv0680 sx330z template topfield toshiba_pdrm11" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="hp1000 hp1005 hp1018 hp1020 hp1215 hp1500 hp1600 hp2600n hpp1005 hpp1006 hpp1007 hpp1008 hpp1505 km2200 km2300 km2430 km2480 km2490 km2530 kmcpwl lm500 oki3200 oki3300 oki3400 oki3530 oki5100 oki5200 oki5500 oki5600 oki5800 sa2160 sa300 sa315 sa3160 xp6110 xp6115" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 8 Moritz Schlarb 2012-01-07 23:25:06 UTC
Created attachment 298287 [details]
Updated ebuild file

I've updated the ebuild to the current version 1.1.1 shipped by avasys.

I plan on committing it to sunrise overlay, but I ask for some testing, especially regarding the autoreconf part in src_prepare().
Comment 9 Moritz Schlarb 2012-01-10 19:07:15 UTC
The ebuild is now in sunrise overlay, you can view it at:
Comment 10 Thomas Sachau gentoo-dev 2012-01-10 19:13:24 UTC
updating keywords/whiteboard on request of Moritz Schlarb, ebuild will be avaidable in sunrise overlay, once some sunrise dev did a review commit.
Comment 11 niogic 2012-03-06 15:26:35 UTC
Do someone have in it's DISTFILES the file

* epson-inkjet-printer-escpr-1.0.1-1lsb3.2.src.rpm


* epson-inkjet-printer-escpr-1.0.1-1lsb3.2.tar.gz

Or also the 1.0.2 version will do.

If so please attach/send a link because has deleted the file and it doesn't seem cached/mirrored anywhere !!

The 1.1 version seem to have dropped support for "Epson Stylus Color CX4400/CX4450/DX4400/DX4450" and I can't find the PPD anymore.

Also if someone has got the PPDs installed by 1.0.1 under "/usr/share/cups/model" can please compress and attach/send a link.
Comment 12 urcindalo 2012-12-22 18:47:12 UTC
I have an all-in-one Stylus SX445W, which currently I can only access through a Windows virtual machine :(

Would it be possible to have a working epson-inkjet-printer-201105w ebuild driver added to the tree? The LSB driver files are here:

Thanks in advance and Merry Xmas to everyone!
Comment 13 boozo 2013-02-02 20:10:01 UTC
please: note that the sources repository has changed form Avasys to Epson download site and the tarball is also fetch restricted
(src -> )
Comment 14 samtygier 2013-02-14 09:25:29 UTC
looks like the current version is now epson-inkjet-printer-escpr-1.2.2-1lsb3.2.tar.gz
Comment 15 Matija "hook" Šuklje 2013-03-03 09:45:15 UTC
(In reply to comment #13)
> please: note that the sources repository has changed form Avasys to Epson
> download site and the tarball is also fetch restricted
> (src -> )

After the ESC/P-R drivers moved to Epson’s website, you are prompted to agree with the license to download the drivers.

But, since the ESC/P-R (as oposed to the old ESC/P) is licensed only under GPL-2 )(without further restricitive licenses), we should be allowed just fine to put the source tarball on Gentoo’s mirrors.
Comment 16 Matija "hook" Šuklje 2013-03-05 22:04:00 UTC
Just bumping the ebuild in Sunrise and dowloading the tarball from Epson’s website worked just fine for me.
Comment 17 Matija "hook" Šuklje 2013-03-05 23:23:44 UTC
(In reply to comment #16)
> Just bumping the ebuild in Sunrise and dowloading the tarball from Epson’s
> website worked just fine for me.

Tested the same bumped ebuild and source tarball also on ARM and it works just fine. I suggest that the next ebuild gets ARCH="~arm" added.
Comment 18 Matija "hook" Šuklje 2013-03-07 11:34:30 UTC
(In reply to comment #15)
> (In reply to comment #13)
> > please: note that the sources repository has changed form Avasys to Epson
> > download site and the tarball is also fetch restricted
> > (src -> )
> After the ESC/P-R drivers moved to Epson’s website, you are prompted to
> agree with the license to download the drivers.
> But, since the ESC/P-R (as oposed to the old ESC/P) is licensed only under
> GPL-2 )(without further restricitive licenses), we should be allowed just
> fine to put the source tarball on Gentoo’s mirrors.

Also regarding the restriction see following comments in Bug 455776 for a suggested solution:
Comment 19 samtygier 2013-07-05 08:32:13 UTC
Epson have released Ver. 1.2.3(06-2013)
Comment 20 Jeroen Roovers (RETIRED) gentoo-dev 2014-02-04 07:23:09 UTC
*** Bug 500234 has been marked as a duplicate of this bug. ***
Comment 22 Sam Jorna (wraeth) gentoo-dev 2014-07-19 16:06:08 UTC
Created attachment 381056 [details]
ebuild for 1.4.0

Note this tested working on amd64
Comment 24 sphakka 2014-08-12 09:51:38 UTC
Created attachment 382730 [details]
New ebuild for v1.4.1
Comment 25 sphakka 2014-08-12 10:19:10 UTC
(In reply to sphakka from comment #24)
> Created attachment 382730 [details]
> New ebuild for v1.4.1

Removed fetch restriction, as the download link is directly reachable (see attachment #382730 [details]).

Actually, on the Web download page, Epson asks for accepting *their* EULA which wraps around GPL plus some typical corporation prattles. BTW, further download links are available here:


Improvements for this ebuild may come from Bug #364129.

This works with my Stylus SX620-FW :-)
Comment 26 sphakka 2014-08-12 10:22:55 UTC
Please also note that the correct bug URL, as it results from following the current one, should be changed to:
Comment 27 Merlijn Wajer 2014-09-10 09:41:30 UTC
Thanks for this ebuild. I can confirm 1.4.1 works fine on arm. Except for one thing, the download uri didn't work. I recommend either using some fetch-restrict mechanism or linking to a (different) mirror.

I'd be glad to help out.
Comment 28 jospezial 2014-11-16 20:37:08 UTC
Ver. 1.4.4(10-2014) is available

As in #c26 please update the "bug URL"

For CX/DX44?0:
These printers are supported by gutenprint if you want to use them with cups. :

Gitweb as well as the and http://anon{cvs,git} web sites are currently not available pending restructuring of our read-only access setup.
Update (2014-09-19):
At this point there's still no ETA to resume the gitweb and http access. We're waiting on systems from a new sponsor to host these services.
Comment 29 Mike Gilbert gentoo-dev 2015-01-15 04:26:52 UTC
I just added version 1.4.4 to the tree to scratch my own itch. Enjoy!