Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 337932 - media-gfx/digikam-1.4.0 configure fails (mysql_install_db tool not found)
Summary: media-gfx/digikam-1.4.0 configure fails (mysql_install_db tool not found)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-18 13:35 UTC by Aleister
Modified: 2011-05-13 23:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleister 2010-09-18 13:35:56 UTC
* CPV:  media-gfx/digikam-1.4.0
 * REPO: gentoo
 * Maintainer: dilfridge@gentoo.org kde@gentoo.org
 * USE:  amd64 elibc_glibc gphoto2 kernel_linux linguas_en_GB multilib semantic-desktop thumbnails userland_GNU
>>> Unpacking source...
>>> Unpacking digikam-1.4.0.tar.bz2 to /var/tmp/portage/media-gfx/digikam-1.4.0/work
>>> Source unpacked in /var/tmp/portage/media-gfx/digikam-1.4.0/work
>>> Preparing source in /var/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0 ...
 * Enabling languages:  en_GB
 * Applying digikam-1.3.0-docs.patch ...
 [ ok ]
 * Applying digikam-1.3.0-pgf.patch ...
 [ ok ]
 * Applying digikam-1.4.0-clapack.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0_build"
cmake -C /var/tmp/portage/media-gfx/digikam-1.4.0/temp/gentoo_common_config.cmake -DCMAKE_INSTALL_PREFIX=/usr -DKDE4_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DFORCED_UNBUNDLE=ON -DWITH_LQR=ON -DGWENVIEW_SEMANTICINFO_BACKEND=Nepomuk -DWITH_KdepimLibs=OFF -DBUILD_doc=OFF -DBUILD_DOC=OFF -DBUILD_Doc=OFF -DWITH_MarbleWidget=OFF -DENABLE_GPHOTO2=ON -DWITH_gphoto2=ON -DWITH_GPHOTO2=ON -DWITH_Gphoto2=ON -DWITH_LensFun=OFF -DWITH_Soprano=ON -DENABLE_themedesigner=OFF -DENABLE_THEMEDESIGNER=OFF -DENABLE_Themedesigner=OFF -DENABLE_THUMBS_DB=ON -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/media-gfx/digikam-1.4.0/temp/gentoo_rules.cmake  /var/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0
loading initial cache file /var/tmp/portage/media-gfx/digikam-1.4.0/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.6.3 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4 
-- Found Perl: /usr/bin/perl 
-- Found Phonon: /usr/include  (found version "4.4.2", required is "4.3.80")
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.5 include dir: /usr/include
-- Found KDE 4.5 library dir: /usr/lib64
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- checking for module 'lcms'
--   found lcms, version 1.19
-- Found lcms version 1.19, /usr/lib64/liblcms.so
-- Found JPEG: /usr/lib64/libjpeg.so 
-- Found ZLIB: /usr/lib64/libz.so 
-- Found PNG: /usr/lib64/libpng.so 
-- Found TIFF: /usr/lib64/libtiff.so 
-- checking for module 'libpgf'
--   found libpgf, version 6.09.44
-- Found Jasper: /usr/lib64/libjasper.so 
-- Check Kdcraw library in local sub-folder...
-- Check Kdcraw library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkdcraw release >= 0.2.0
-- Found libkdcraw: /usr/lib64/libkdcraw.so
-- Check Kexiv2 library in local sub-folder...
-- Check Kexiv2 library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkexiv2 release >= 0.2.0
-- Found libkexiv2: /usr/lib64/libkexiv2.so
-- Check Kipi library in local sub-folder...
-- Check Kipi library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkipi release >= 0.2.0
-- Found libkipi: /usr/lib64/libkipi.so
-- Found clapack includes: /usr/include/clapack
-- Found clapack library: /usr/lib64/libclapack.so
-- Identified libjpeg version: 80
-- checking for module 'libkdcraw>=1.1.0'
--   found libkdcraw, version 1.1.0
-- checking for module 'libkexiv2>=1.1.0'
--   found libkexiv2, version 1.1.0
-- Found MySQL server executable at: SERVERCMD_MYSQL-NOTFOUND
-- Found MySQL install_db executable at: INITCMD_MYSQL-NOTFOUND
-- Found gphoto2: -L/usr/lib64 -lgphoto2_port;-L/usr/lib64 -lgphoto2 -lgphoto2_port -lm
-- Found GLIB2: /usr/lib64/libglib-2.0.so 
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Performing Test HAVE_LQR_0_4
-- Performing Test HAVE_LQR_0_4 - Success
-- Found Lqr-1: /usr/include/lqr-1 
-- Found Soprano: /usr/include 
-- Found SharedDesktopOntologies: /usr/share/ontology 
-- Found Nepomuk: /usr/lib64/libnepomuk.so 
-- Could NOT find Doxygen  (missing:  DOXYGEN_EXECUTABLE) 
-- 
-- ----------------------------------------------------------------------------------
--  digiKam 1.4.0 dependencies results   <http://www.digikam.org>
-- 
--  Qt4 SQL module found..................... YES
--  MySQL Server found....................... NO
-- 
--  digiKam needs MySQL Server. You need to install the package containing the "mysqld" executable.
--  If you have this executable installed, please specify the folder containing it by MYSQLD_PATH
CMake Error at CMakeLists.txt:121 (MESSAGE):
Call Stack (most recent call first):
  CMakeLists.txt:266 (PRINT_EXECUTABLE_STATUS)


--  MySQL install_db tool found.............. NO
-- 
--  digiKam needs MySQL install_db tool. You need to install the package containing the "mysql_install_db" executable.
--  If you have this executable installed, please specify the folder containing it by MYSQL_TOOLS_PATH
CMake Error at CMakeLists.txt:121 (MESSAGE):
Call Stack (most recent call first):
  CMakeLists.txt:268 (PRINT_EXECUTABLE_STATUS)


--  libtiff library found.................... YES
--  libpng library found..................... YES
--  libjasper library found.................. YES
--  liblcms library found.................... YES
--  libkipi library found.................... YES
--  libkexiv2 library found.................. YES
--  libkdcraw library found.................. YES
--  libpgf library found..................... YES (optional)
--  libclapack library found................. YES (optional)
--  libgphoto2 library found................. YES (optional)
--  libkdepimlibs library found.............. NO  (optional)
-- 
--  digiKam will be compiled without address book support.
-- 
--  libmarblewidget library found............ NO  (optional)
-- 
--  digiKam will be compiled without geolocation using Marble widget support.
-- 
--  Nepomuk libraries found.................. YES (optional)
--  liblensfun library found................. NO  (optional)
-- 
--  digiKam will be compiled without lens auto-correction image editor tool.
-- 
--  libglib2 library found................... YES (optional)
--  liblqr-1 library found................... YES (optional)
--  Doxygen found............................ NO  (optional)
-- 
--  You will not be able to to generate the API documentation.
--  This does not affect building digiKam in any way.
-- 
--  digiKam can be compiled.................. YES
-- ----------------------------------------------------------------------------------
-- 
-- Adjusting compilation flags for GCC version ( 4.4.4 )
-- 
-- Documentation will NOT be installed
-- Because the option -DBUILD_DOC=ON wasn't passed to cmake
-- 
-- Looking for dgettext
-- Looking for dgettext - found
-- Found Gettext: built in libc
-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -O2 -pipe -march=native  -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common
C++             -O2 -pipe -march=native  -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden
Linker flags:
Executable      -Wl,--enable-new-dtags -Wl,-O1 -Wl,--as-needed
Module          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,-O1 -Wl,--as-needed
Shared          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,-O1 -Wl,--as-needed

-- Configuring incomplete, errors occurred!
 * ERROR: media-gfx/digikam-1.4.0 failed:
 *   cmake failed
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 3873:  Called kde4-base_src_configure
 *   environment, line 3003:  Called cmake-utils_src_configure
 *   environment, line 1143:  Called _execute_optionaly 'src_configure'
 *   environment, line  525:  Called enable_cmake-utils_src_configure
 *   environment, line 1576:  Called die
 * The specific snippet of code:
 *       cmake "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 * 
 * If you need support, post the output of 'emerge --info =media-gfx/digikam-1.4.0',
 * the complete build log and the output of 'emerge -pqv =media-gfx/digikam-1.4.0'.
 * The complete build log is located at '/var/tmp/portage/media-gfx/digikam-1.4.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/digikam-1.4.0/temp/environment'.
 * S: '/var/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0'


Reproducible: Always

Steps to Reproduce:
1.try to emerge digikam-1.4.0
2.see it fail :)
3.




emerge --info
Portage 2.1.9.7 (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.35-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6750_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 18 Sep 2010 00:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.67
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2, 4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/net_portage"
EMERGE_DEFAULT_OPTS="--with-bdeps y --jobs 3 --load-average 6"
FEATURES="assume-digests distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.tiscali.nl/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/net_portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://192.168.0.1/gentoo-portage"
USE="X acl alsa amd64 bash-completion bzip2 cli cracklib crypt custom-cflags cxx dbus dri dvd fortran gdbm gpm handbook iconv kde lzma minimal mmx mmxext modules mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre pppd qt3support qt4 readline reflection semantic-desktop session spell sse sse2 ssl ssse3 sysfs tcpd theora threads truetype unicode vorbis x264 xcb xinerama xorg xscreensaver zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Andreas K. Hüttel gentoo-dev 2010-09-18 14:42:35 UTC
Sigh. They really require mysql now.

Fixed, resync your tree in an hour please. 
(Or just emerge -1 virtual/mysql )