Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 337880 - Better shared library handling
Summary: Better shared library handling
Status: RESOLVED INVALID
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on: preserve-libs
Blocks:
  Show dependency tree
 
Reported: 2010-09-18 11:51 UTC by Niko E.
Modified: 2010-11-04 15:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Niko E. 2010-09-18 11:51:49 UTC
It would be usefull to postpone the uninstall of shared libraries or atleast their .so files would be postponed until revdep-rebuild is done and the old versions are no longer needet. This would avoid breaking half of the installed packages when widely used libraries like libjpeg, libogg oder libpng are updated. 

Reproducible: Always

Steps to Reproduce:
emerge -vuD @world #when libjpeg has an update

Actual Results:  
half the system is in an anusable state since the old libjpeg.so.XY is no longer pressend

Expected Results:  
remove old versions of .so files as a final step in revdep-rebuild

a list of .so files that are obsolet could be maintained. revdep-rebuild could check this to see if anything still depends on then and remove them if this is not the case.
Comment 1 Zac Medico gentoo-dev 2010-09-18 12:04:15 UTC
This sounds a lot like FEATURES=preserve-libs and @preserved-rebuild in portage-2.2_rc* (see bug #240323).
Comment 2 Niko E. 2010-11-04 11:54:37 UTC
if it is comming anyway, i can close this as invalid