Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336575 - net-misc/iputils-20100418 - arping.c:35:28: error: sysfs/libsysfs.h: No such file or directory
Summary: net-misc/iputils-20100418 - arping.c:35:28: error: sysfs/libsysfs.h: No such ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2010-09-09 09:59 UTC by Eugene Vandyuk
Modified: 2010-09-14 13:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Vandyuk 2010-09-09 09:59:48 UTC
Failed when emerge to the empty root with only few configs (make.conf, make.profile).

Reproducible: Always

Steps to Reproduce:
1. cat - > /mnt/gentoo/etc/make.conf

2. ln -sf /usr/portage/profile/default/linux/x86/10.0 /mnt/gentoo/etc/make.profile
3. mount -B /usr/portage /mnt/gentoo/usr/portage
4. mount -B /usr/src /mnt/gentoo/usr/src
5. emerge -e --root=/mnt/gentoo --config-root=/mnt/gentoo --root-deps=rdeps world

Actual Results:  
 * ERROR: net-misc/iputils-20100418 failed:
 *   make main failed
 * Call stack:
 *, line  54:  Called src_compile
 *   environment, line 2573:  Called die
 * The specific snippet of code:
 *       emake || die "make main failed"

Expected Results:  
Month ago this procedure works perfectly - successful compilation and using the resulting build as template for OpenVZ containers.

Portage (default/linux/x86/10.0/server, gcc-4.4.3, glibc-2.11.2-r0, 2.6.27-openvz-kuindzhi.1 i686)
                        System Settings
System uname: Linux-2.6.27-openvz-kuindzhi.1-i686-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-1.12.13
Timestamp of tree: Thu, 09 Sep 2010 09:30:23 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81
virtual/os-headers:  2.6.30-r1
CFLAGS="-march=core2 -O2 -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl apache2 berkdb bzip2 cli cracklib crypt cups cxx dri gd gdbm gpm iconv lm_sensors mmx modules mudflap mysql ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session snmp sse sse2 ssl sysfs tcpd truetype x86 xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Eugene Vandyuk 2010-09-09 10:11:34 UTC
 # cat /var/tmp/portage/net-misc/iputils-20100418/temp/build.log
 * CPV:  net-misc/iputils-20100418
 * REPO: gentoo
 * USE:  elibc_glibc ipv6 kernel_linux ssl userland_GNU x86
 * Applying 021109-uclibc-no-ether_ntohost.patch ...                      [ ok ]
 * Applying iputils-20100418-openssl.patch ...                            [ ok ]
 * Applying iputils-20100418-so_mark.patch ...                            [ ok ]
 * Applying iputils-20100418-makefile.patch ...                           [ ok ]
 * Applying iputils-20100418-proper-libs.patch ...                        [ ok ]
 * Applying iputils-20100418-printf-size.patch ...                        [ ok ]
 * Applying iputils-20100418-aliasing.patch ...                           [ ok ]
 * Applying iputils-20071127-kernel-ifaddr.patch ...                      [ ok ]
 * Applying iputils-20070202-idn.patch ...                                [ ok ]
 * Applying iputils-20100418-ping-CVE-2010-2529.patch ...                 [ ok ]
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE -Wl,-O1 -Wl,--as-needed  tracepath.c   -o tracepath
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE  -c -o ping.o ping.c
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE  -c -o ping_common.o ping_common.c
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE -Wl,-O1 -Wl,--as-needed  clockdiff.c   -o clockdiff
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE -Wl,-O1 -Wl,--as-needed  rdisc.c   -o rdisc
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE  -c -o arping.o arping.c
rdisc.c: В функции 'prusage':i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE  -c -o tftpd.o tftpd.c
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE  -c -o tftpsubs.o tftpsubs.c
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE -Wl,-O1 -Wl,--as-needed  rarpd.c   -o rarpd

rdisc.c:234: предупреждение: формат не является строковой константой, и не заданы аргументы форматирования
arping.c:35:28: error: sysfs/libsysfs.h: Нет такого файла или каталога
arping.c: В функции 'set_device_broadcast':
arping.c:321: предупреждение: неявная декларация функции 'sysfs_open_class_device'
arping.c:321: предупреждение: в присваивании целое преобразуется в указатель без приведения типа
arping.c:327: предупреждение: неявная декларация функции 'sysfs_get_classdev_attr'
arping.c:327: предупреждение: в присваивании целое преобразуется в указатель без приведения типа
arping.c:333: предупреждение: неявная декларация функции 'sysfs_read_attribute'
arping.c:339: ошибка: доступ по указателю на неполный тип
i686-pc-linux-gnu-gcc -pipe -Wstrict-prototypes -Wall  -DHAVE_OPENSSL -D_GNU_SOURCE -Wl,-O1 -Wl,--as-needed  tracepath6.c   -o tracepath6
make: *** [arping.o] Ошибка 1
make: *** Ожидание завершения заданий...
 * ERROR: net-misc/iputils-20100418 failed:
 *   make main failed
 * Call stack:
 *, line  54:  Called src_compile
 *   environment, line 2573:  Called die
 * The specific snippet of code:
 *       emake || die "make main failed"
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2010-09-10 16:43:10 UTC
=net-misc/iputils-20100418 correctly DEPENDs on sys-fs/sysfsutils which provides /usr/include/sysfs/libsysfs.h so this is a bit of a mystery.

Comment 3 SpanKY gentoo-dev 2010-09-10 18:10:46 UTC
but it didnt always.  if your emerge sync is out of date, you'll probably hit the old bug.  verify you're actually up to date.
Comment 4 Eugene Vandyuk 2010-09-13 08:16:43 UTC
(In reply to comment #3)
> but it didnt always.  if your emerge sync is out of date, you'll probably hit
> the old bug.  verify you're actually up to date.

When I open this bug report, my portage tree was dated 2010/09/09 17:05 .
Today I sync my tree again and retry this bug with absolutely same result:

ERROR: net-misc/iputils-20100418 failed

Only workaround for now is :
echo "=net-misc/iputils-20100418" >> /etc/portage/package.mask
Comment 5 SpanKY gentoo-dev 2010-09-13 19:07:20 UTC
why dont you use the tips we already posted to further diagnose your system to see what's going on.  the obvious questions: do you have libsysfs ?  is it installing the header it is supposed to ?

if your ROOT=/ system lacks libsysfs, and you dont install it, there isnt much to be done.  you're forcing ROOT=/somewhere/else which the toolchain will not be considering.
Comment 6 Eugene Vandyuk 2010-09-14 11:38:44 UTC
Of course, on time of compiling "iputils" file "sysfs/libsysfs.h" exists in building (guest /mnt/gentoo) image, but it's not present in the builder (host /) system.
Problem was solved when I manualy emerge sysfsutils to the ROOT=/ before emerging to the /mnt/gentoo .
Now net-misc/iputils-20100418 RDEPEND's (run-time) on sys-fs/sysfsutils, but it seems that it need to be DEPEND (for compilation)?
It's correct when compilation depends on default ROOT=/ when I use explicit ROOT=/mnt/gentoo,CONFIG_ROOT=/mnt/gentoo declaration ?
It's posible to DEPEND on ROOT & CONFIG_ROOT when emerging ?
Comment 7 SpanKY gentoo-dev 2010-09-14 13:11:48 UTC
review the iputils ebuild -- it already does DEPEND on it

as for depend behavior with ROOT values and such, you'll have to post that to the gentoo portage mailing list